summaryrefslogtreecommitdiff
path: root/app-backup/restic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-25 11:25:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-25 11:25:16 +0100
commit70a8e0f526762c28622fae5f944f8f59f9abf728 (patch)
treea58f1b704c29cff0ad8201d20ebbf7a11018f88f /app-backup/restic
parent4eda0fe5576868e6c7f97b51aa1c279ff8cd320c (diff)
gentoo auto-resync : 25:09:2023 - 11:25:16
Diffstat (limited to 'app-backup/restic')
-rw-r--r--app-backup/restic/Manifest3
-rw-r--r--app-backup/restic/restic-0.16.0.ebuild47
2 files changed, 50 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index a8ce97c9c30b..5cdc976c940e 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -1,4 +1,7 @@
DIST restic-0.15.2-deps.tar.xz 159164476 BLAKE2B 652c5f880dc88ab9b4fcfb0168cf5bce19587f7c0195e379ac01ff227fd453bb5fc6ab72b7803d7070f92ea608a077aa0f79005f000b5626d7ea8841c9ec9643 SHA512 e4ef9ebfc09998e912128d84790081d16c05dad23e680f642e204974fc1ddd3a1f92ad2035227f6448f7661e24ba69379b1dc8198115d2d3d780ad0b0c7a475c
DIST restic-0.15.2.tar.gz 23924222 BLAKE2B d07f505a9d3a425c2fbad275f43a3a23e0b84b673e0ac77f52c45c2965266b483ae136fe99f0bc82903680ff0c5843edd1ed72e4864e5977c2ed2c85a703520c SHA512 8135f8a77c6f1264d962156f58fca4023da6581099cfd4a69379d8f1f137443c217c0207aeb7d41b603b341e78e9b3050c6bdad81323e0efd7b81805f33263bd
+DIST restic-0.16.0-vendor.tar.xz 3220044 BLAKE2B b3b27f397b440c59afe2c1f25346e243c51da4dbee53bfd5b5e113bc1c8c88bea328911fa8aaf5287989e5d4f5dfc7a28e0a3878cce172c18bcbdadc1aaa7abb SHA512 69f335d3cdd9b554b5f0b0255864854c2b3eb14c224f6474f3249be649faa1fa82b378c6c5582c09771771ccf8a12adb6ba527ccb2006606ca1724606366c849
+DIST restic-0.16.0.tar.gz 23972221 BLAKE2B f9f28cb5751265368583b8b1ac01fad591cccb13ae0a9c7b8b3d41329783230484d190d763223c2a43d57b001ddcb3cefbfb2a37cf00eaef7b49ddb2c9610375 SHA512 d51732b611407cc8ebc40c9acb45df8154f87ece26b37d32074b59f5cfb56cbcca71695036923a50739215426dce614fb32d8cd18c581d37dc10d8a25b8c95e5
EBUILD restic-0.15.2.ebuild 1123 BLAKE2B bad05f9623f42c02e02799d6cf8937b4a60633a3c6c5c80c1665c38924cbfa7e7e66695ba53b974afb331c0f6283efc65c33d62913c7ad58087bed60daf4d1e5 SHA512 f67d7375f460c521f7825000e0a0a37ca79051a82df30e9d741a83fd0e1cc52418ac956631c044fcdfeb20fafdbab771011f1c054c0dcc8aa57d1538d9dadf9b
+EBUILD restic-0.16.0.ebuild 1156 BLAKE2B 84c4659f33efd12fea6a308c356bbfc85bd088077798bce44b0515730777c233476fb713479bbd90c87e4a3b37ed2cd0eb0e06195d4bcf15073e451093197812 SHA512 b9eb9a50a787ac1235fdd03a2b47ef49822ac0d6eb01b6cbc51242164d8b8508dee5a301dfe3ddbbcc627627763a983ee2a34d1a2f7bc7dc0727e0f8b6a6ca74
MISC metadata.xml 584 BLAKE2B 76c5cf916e847dd9e8cd3dd205c9c6e68198aed895c1067ddb7e73a6e8610d973313d6ffc553c89ea5ca1caecf1b19d02424ec3f693a191e85a1a9ecae1e4721 SHA512 676f7b108bae1af9ee9431f9a08b8870a8207a92ec3214cd2d5774112c1065453a5c8f56c1e0a49180ba2c32a02c990494cb85a15487be62e02d76580eabc611
diff --git a/app-backup/restic/restic-0.16.0.ebuild b/app-backup/restic/restic-0.16.0.ebuild
new file mode 100644
index 000000000000..ecaff989e08b
--- /dev/null
+++ b/app-backup/restic/restic-0.16.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION="A backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://gentoo.kropotkin.rocks/go-pkgs/${P}-vendor.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 LGPL-3-with-linking-exception MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local mygoargs=(
+ -tags release
+ -ldflags "-X main.version=${PV}"
+ -asmflags "-trimpath=${S}"
+ -gcflags "-trimpath=${S}"
+ )
+
+ ego build "${mygoargs[@]}" -o restic ./cmd/restic
+}
+
+src_test() {
+ addwrite /dev/fuse
+ # a number of the ./cmd/... tests fail
+ # ego test -timeout 30m ./cmd/... ./internal/...
+ RESTIC_TEST_FUSE=0 ego test -timeout 30m ./internal/...
+}
+
+src_install() {
+ dobin restic
+
+ newbashcomp doc/bash-completion.sh "${PN}"
+ newzshcomp doc/zsh-completion.zsh _restic
+ newfishcomp doc/fish-completion.fish "${PN}"
+
+ doman doc/man/*
+ dodoc doc/*.rst
+}