summaryrefslogtreecommitdiff
path: root/app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild')
-rw-r--r--app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild b/app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild
new file mode 100644
index 000000000000..ce161ddf95a6
--- /dev/null
+++ b/app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+UPSTREAM_PV=$(ver_rs 0 '-')
+
+DESCRIPTION="Local/remote mirroring+incremental backup"
+HOMEPAGE="https://github.com/sol1/rdiff-backup"
+SRC_URI="https://github.com/sol1/${PN}/archive/r${UPSTREAM_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+DEPEND="
+ net-libs/librsync:0=
+"
+RDEPEND="${DEPEND}
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/pyxattr[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-librsync-1.0.0.patch"
+ "${FILESDIR}/${P}-no-docs.patch"
+)
+
+python_install_all() {
+ local HTML_DOCS=( FAQ.html )
+ use examples && HTML_DOCS+=( examples.html )
+ distutils-r1_python_install_all
+}