summaryrefslogtreecommitdiff
path: root/app-backup/luckybackup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/luckybackup
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/luckybackup')
-rw-r--r--app-backup/luckybackup/Manifest3
-rw-r--r--app-backup/luckybackup/luckybackup-0.4.9.ebuild59
-rw-r--r--app-backup/luckybackup/metadata.xml11
3 files changed, 73 insertions, 0 deletions
diff --git a/app-backup/luckybackup/Manifest b/app-backup/luckybackup/Manifest
new file mode 100644
index 000000000000..8ba05fa49307
--- /dev/null
+++ b/app-backup/luckybackup/Manifest
@@ -0,0 +1,3 @@
+DIST luckybackup-0.4.9.tar.gz 5954338 BLAKE2B 632738f8c422ba7d56536fae866ce31d224910b41495e4df3be28a8013ba776e30b4d8e70ceb26c92d28aaf70c96402f27687c55d8f5d7aa5d405bab506a66be SHA512 86d6f1bd84f3bfd89734f0f2066cb17bbf9b4ede96167398de03a460c14d24bf4b50a91bb380655ace9a23497271e102b940ea99a7595cf17f596660dae7f7dd
+EBUILD luckybackup-0.4.9.ebuild 1442 BLAKE2B 07b9b559b32179733248d205b862f5e4eb1e4ccbf1e4fcd6ea63a0c07ffee7436055236bfc12fcc9aebfacd53b279379c1a0ee3d4d132fb892679f3cc338da4a SHA512 68d4d5e8b5d70b1b2a20471e97c65459969d2f7486fe700e1e18031c68eb612776970a2ac411b17cf8bc83e34e51dd87175bbfd62b405cbedecd32499eaf8cb8
+MISC metadata.xml 328 BLAKE2B b41ac27e6b5c14d5c6bf9df4a47291ffe57bc679b06ab27b3cf9135be123195a161be705ffd2349f3cc4a5f618c2e75740a677696afa244a3a3716be625aa223 SHA512 64415b71b483e93f41d75f858bbdbce2c612b5e7c37753237d7c2374b1bb2bd2d30a86d18b32f5ac015e15c57e94553019756d2cc6021c803d25da527929ddeb
diff --git a/app-backup/luckybackup/luckybackup-0.4.9.ebuild b/app-backup/luckybackup/luckybackup-0.4.9.ebuild
new file mode 100644
index 000000000000..eab1f1a17131
--- /dev/null
+++ b/app-backup/luckybackup/luckybackup-0.4.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Powerful and flexible backup (and syncing) tool, using RSync and Qt"
+HOMEPAGE="http://luckybackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+DOCS=( readme/{AUTHORS,README,TODO,TRANSLATIONS,changelog} )
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:g" \
+ -e "s:/usr/share/doc/packages/${PN}:/usr/share/doc/${PF}:g" \
+ luckybackup.pro src/global.cpp || die "sed failed"
+
+ # The su-to-root command is an ubuntu-specific script so it will
+ # not work with Gentoo. No reason to have it anyway.
+ sed -i -e "/^Exec/s:=.*:=/usr/bin/${PN}:" menu/${PN}-gnome-su.desktop \
+ || die "failed to remove su-to-root"
+
+ # causes empty directory to be installed
+ sed -i -e '/^INSTALLS/s/debianmenu //' luckybackup.pro \
+ || die "sed installs failed"
+
+ # bogus dependency - bug #645732
+ sed -i -e '/QT += network/s/^/#/' luckybackup.pro || die
+
+ # remove text version - cannot remote HTML version
+ # as it's used within the application
+ rm license/gpl.txt || die "rm failed"
+
+ default
+}
+
+src_configure() {
+ eqmake5 ${PN}.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
diff --git a/app-backup/luckybackup/metadata.xml b/app-backup/luckybackup/metadata.xml
new file mode 100644
index 000000000000..06fb30b44cd1
--- /dev/null
+++ b/app-backup/luckybackup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">luckybackup</remote-id>
+ </upstream>
+</pkgmetadata>