summaryrefslogtreecommitdiff
path: root/app-backup/kup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /app-backup/kup
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'app-backup/kup')
-rw-r--r--app-backup/kup/Manifest3
-rw-r--r--app-backup/kup/files/kup-0.7.3-libgit2.patch140
-rw-r--r--app-backup/kup/kup-0.7.3.ebuild10
3 files changed, 147 insertions, 6 deletions
diff --git a/app-backup/kup/Manifest b/app-backup/kup/Manifest
index 48ccb94bd826..96b0802c25ce 100644
--- a/app-backup/kup/Manifest
+++ b/app-backup/kup/Manifest
@@ -1,3 +1,4 @@
+AUX kup-0.7.3-libgit2.patch 4160 BLAKE2B 5b71ed1308108432148ab4fd69e3228f07bb7afb78d8cffb47ff7e0045119e8ac7494d770ec7354fc7655a4eb5c021e3c396152114bb85a7d9a2169dbf54761c SHA512 39052b65077f5a30afcf6c9234920d4f9a04ce2478a0b64c54b8320212bc246bbe07401f5242b6d1bdc2bf03be1af764192a020b7fe52716d33916d28605cab4
DIST kup-0.7.3.tar.gz 1024916 BLAKE2B aab2a1c58bc7feb6cc734a61385841b9c9b47995ba0c7e66b0596ddd7ae77b2a2b750f23f452e591c609f4a59a894815f8cfcb82c8bc266769b6e908463c009c SHA512 62609eb3c9a873045a9f02d22be5413f73f909e77d82f287ff5b2f816d2d6930a8d8ca77537a52189a98fe11441eb10f5530dfdab02ed0c09b53a2c4b5b4be80
-EBUILD kup-0.7.3.ebuild 1416 BLAKE2B ae35f888716b8da423f03097a94a218a0c99ee4d5df71ca5a2144edc9e959169a94df323d2997852a951c77ced2790ffdacf747e54eecbb9f841707806c2bcac SHA512 0e2a7decd6439cded9c6b4441584333fde84ccf33be731fa03a5b047f9ffdb6e1158161b611e3694154296068c2d86ce7847bdf735da3e7ca89be0faf8d3ad09
+EBUILD kup-0.7.3.ebuild 1479 BLAKE2B 32576c5fff58c4a4b9226e91666b6c3f6f2bf47dbfa8ef2b2bd9a44334151f829c4bcd7976a1452196732bf80b6034760aa7ac194d829338119d46f016d5d289 SHA512 df770219c2c3f844df70bd1ed3d6a568d82f1c2d88eebd6320a2d9401a010c2c12692982156fb560b333f7a378fe83a8cf77b73ca8cf543bcaa06adc75a47599
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/app-backup/kup/files/kup-0.7.3-libgit2.patch b/app-backup/kup/files/kup-0.7.3-libgit2.patch
new file mode 100644
index 000000000000..a6b1c536afc1
--- /dev/null
+++ b/app-backup/kup/files/kup-0.7.3-libgit2.patch
@@ -0,0 +1,140 @@
+From 2ca19e917f895e24a5379be669b9ad77ff5692f5 Mon Sep 17 00:00:00 2001
+From: Simon Persson <simon.persson@mykolab.com>
+Date: Mon, 16 Mar 2020 17:03:33 +0800
+Subject: Remove copy of libgit2
+
+API seems to have stabilized a lot, such that different distros can be
+expected to have a compatible version.
+---
+ CMakeLists.txt | 13 +-
+ filedigger/CMakeLists.txt | 2 +-
+ filedigger/main.cpp | 12 -
+ kioslave/CMakeLists.txt | 2 +-
+ kioslave/bupslave.cpp | 8 -
+
+From ee720980113162c019eecabc01dfa5763cfb7585 Mon Sep 17 00:00:00 2001
+From: Adriaan de Groot <groot@kde.org>
+Date: Mon, 6 Apr 2020 23:06:53 +0200
+Subject: Link to libgit2 via imported target
+
+---
+ filedigger/CMakeLists.txt | 2 +-
+ kioslave/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2118193..76a1367 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,18 +6,7 @@ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
+
+ project(kup)
+
+-# Use this option if you want to use the system LibGit2 library.
+-# This is not recommended unless you know what you are doing.
+-option(USE_SYSTEM_LIBGIT2 "Don't set this option unless your are sure that your system version of LibGit2 library is fully compatible with Kup." OFF)
+-if (USE_SYSTEM_LIBGIT2)
+- find_package(LibGit2 REQUIRED)
+- set(libgit_link_name git2)
+-else (USE_SYSTEM_LIBGIT2)
+- set(BUILD_SHARED_LIBS ON)
+- add_subdirectory(libgit2-0.19.0)
+- include_directories(${CMAKE_SOURCE_DIR}/libgit2-0.19.0/include)
+- set(libgit_link_name git24kup)
+-endif (USE_SYSTEM_LIBGIT2)
++find_package(LibGit2 REQUIRED)
+
+ if("${CMAKE_BUILD_TYPE}" STREQUAL "Debug" OR "${CMAKE_BUILD_TYPE}" STREQUAL "DebugFull")
+ message(WARNING "enabling debug output!")
+diff --git a/filedigger/CMakeLists.txt b/filedigger/CMakeLists.txt
+index 2fcdd82..fd6a3a0 100644
+--- a/filedigger/CMakeLists.txt
++++ b/filedigger/CMakeLists.txt
+@@ -37,7 +37,7 @@ KF5::I18n
+ KF5::I18n
+ KF5::IconThemes
+ KF5::JobWidgets
+-${libgit_link_name}
++LibGit2::LibGit2
+ )
+
+ ########### install files ###############
+diff --git a/filedigger/main.cpp b/filedigger/main.cpp
+index 6682985..43fe9ae 100644
+--- a/filedigger/main.cpp
++++ b/filedigger/main.cpp
+@@ -21,11 +21,7 @@
+ #include "filedigger.h"
+ #include "mergedvfs.h"
+
+-#if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
+ #include <git2/global.h>
+-#else
+-#include <git2/threads.h>
+-#endif
+
+ #include <KAboutData>
+ #include <KLocalizedString>
+@@ -66,19 +62,11 @@ int main(int pArgCount, char **pArgArray) {
+ }
+
+ // This needs to be called first thing, before any other calls to libgit2.
+- #if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
+ git_libgit2_init();
+- #else
+- git_threads_init();
+- #endif
+
+ FileDigger *lFileDigger = new FileDigger(lRepoPath, lParser.value(QStringLiteral("branch")));
+ lFileDigger->show();
+ int lRetVal = lApp.exec();
+- #if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
+ git_libgit2_shutdown();
+- #else
+- git_threads_shutdown();
+- #endif
+ return lRetVal;
+ }
+diff --git a/kioslave/CMakeLists.txt b/kioslave/CMakeLists.txt
+index 7187f33..83e6122 100644
+--- a/kioslave/CMakeLists.txt
++++ b/kioslave/CMakeLists.txt
+@@ -17,7 +17,7 @@ target_link_libraries(kio_bup
+ Qt5::Core
+ KF5::KIOCore
+ KF5::I18n
+-${libgit_link_name}
++LibGit2::LibGit2
+ )
+
+ install(TARGETS kio_bup DESTINATION ${PLUGIN_INSTALL_DIR})
+diff --git a/kioslave/bupslave.cpp b/kioslave/bupslave.cpp
+index 1a7e1a3..0812658 100644
+--- a/kioslave/bupslave.cpp
++++ b/kioslave/bupslave.cpp
+@@ -64,22 +64,14 @@ BupSlave::BupSlave(const QByteArray &pPoolSocket, const QByteArray &pAppSocket)
+ {
+ mRepository = nullptr;
+ mOpenFile = nullptr;
+- #if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
+ git_libgit2_init();
+- #else
+- git_threads_init();
+- #endif
+ }
+
+ BupSlave::~BupSlave() {
+ if(mRepository != nullptr) {
+ delete mRepository;
+ }
+- #if LIBGIT2_VER_MAJOR == 0 && LIBGIT2_VER_MINOR >= 24
+ git_libgit2_shutdown();
+- #else
+- git_threads_shutdown();
+- #endif
+ }
+
+ void BupSlave::close() {
+--
+cgit v1.1
+
diff --git a/app-backup/kup/kup-0.7.3.ebuild b/app-backup/kup/kup-0.7.3.ebuild
index d479069e1b3f..8af41a81c73b 100644
--- a/app-backup/kup/kup-0.7.3.ebuild
+++ b/app-backup/kup/kup-0.7.3.ebuild
@@ -49,9 +49,9 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${PN^}-${P}"
-src_configure() {
- local mycmakeargs=(
- -DUSE_SYSTEM_LIBGIT2=ON
- )
- ecm_src_configure
+PATCHES=( "${FILESDIR}/${P}-libgit2.patch" )
+
+src_prepare() {
+ ecm_src_prepare
+ rm -r libgit2-0.19.0 || die "Failed to remove bundled libgit2-0.19.0"
}