summaryrefslogtreecommitdiff
path: root/app-backup/holland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-backup/holland
reinit the tree, so we can have metadata
Diffstat (limited to 'app-backup/holland')
-rw-r--r--app-backup/holland/Manifest5
-rw-r--r--app-backup/holland/holland-1.0.10.ebuild55
-rw-r--r--app-backup/holland/metadata.xml5
3 files changed, 65 insertions, 0 deletions
diff --git a/app-backup/holland/Manifest b/app-backup/holland/Manifest
new file mode 100644
index 000000000000..0576d6ca7f0b
--- /dev/null
+++ b/app-backup/holland/Manifest
@@ -0,0 +1,5 @@
+DIST holland-1.0.10.tar.gz 449334 SHA256 c893be3dc77126125334dfa9eec404d7608a78a2bf88ec1d7ddc12ad7f7ed8d1 SHA512 5183ec73012edcaba50ef5cc9b892480d5f60301d01d17bd96c5490bd8e6ae42bd21abb6084e6665317b8025489981a02293cd583964f01e86459609b93e918f WHIRLPOOL fa8934c635f4347ffc6a327f6135d61ca26805d727fe4caca32ba9c23224062492553182e24d15fc59177787241903dd3409396c176fab2d55c34e9dcc5668e3
+EBUILD holland-1.0.10.ebuild 1410 SHA256 138a2053fa7c0d40eac370a5b055401f48537d294948493f3e423515777c8b6f SHA512 d1ed02610f3eb782014988467af619094a7c10856f20329d797ca19a06404f0ca3318439d3e6ba472991266c65fd329f5e458e88ccb18903e202a6615033f1b0 WHIRLPOOL 746e344df05dd4ce606977af81874e43106be83e538077b4259374b3f3bb19ee8c6a8eeb0ee3d81e1a049fe90cbbe59edc2b90a0777b1b4e7e03709141dc6be8
+MISC ChangeLog 2309 SHA256 801cf852f160fb01b3a9b5ef6c1cea9015881952caf836b3187caa08b2b35512 SHA512 115249941f4c4c51473337d0212a4f6572e696c61b6886c1e47f5ef4496da3f9b160f4c7a8c06a38d9e1077ca711ca72a7e0accd83a8d61ddc181fee04625d9f WHIRLPOOL 05d95c7479c7f31da017095de9712e3c3c71262866fbaf07eef854e79a70987bc6a8bd3f38e28e8a9e537898644a1e446c1b4863ca137b5f6d4a7cc2734dbe7d
+MISC ChangeLog-2015 372 SHA256 b65273dadce15f7b86dd99ca2cea1e4aa2de7060d474601afe119ca74ba6d85d SHA512 38141aa37ea6046f445e5fbb712e32dfadf7a9d4d3cc28a3520fd408891e1f64f4165db81e65a5b99ab615a61a4f4ff62e96e3c588d9935046e76f1aad63b80a WHIRLPOOL a7eb4f587dc66e5fb8627bb3d3a82a0ce9e7f0958335beecf2a60c0e1d10821f1021c1f23b2aef0c07642a5ac901661df76dd893257e0c95291f4c590f894d0f
+MISC metadata.xml 167 SHA256 5fe493e76bba84455c54b3a46adfae5a1bfe01c764ef0d9e5f6d3e8a1d142188 SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33 WHIRLPOOL dc6c3dfc7fd7f0d76c97f0786cb76a55b8564f8437f96d4ccebf985817b9f6dcc4c61830aa5df80d725e4a54b281ea2e03d6b0859214af081112cba15025e64b
diff --git a/app-backup/holland/holland-1.0.10.ebuild b/app-backup/holland/holland-1.0.10.ebuild
new file mode 100644
index 000000000000..93923b276ab7
--- /dev/null
+++ b/app-backup/holland/holland-1.0.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Holland Core Plugins"
+HOMEPAGE="http://www.hollandbackup.org/"
+SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +mysql postgres sqlite"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ mysql? ( ~app-backup/holland-backup-mysql-meta-${PV}[${PYTHON_USEDEP}] )
+ postgres? ( ~app-backup/holland-backup-pgdump-${PV}[${PYTHON_USEDEP}] )
+ sqlite? ( ~app-backup/holland-backup-sqlite-${PV}[${PYTHON_USEDEP}] )
+ examples? (
+ ~app-backup/holland-backup-example-${PV}[${PYTHON_USEDEP}]
+ ~app-backup/holland-backup-random-${PV}[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local DOCS=( README config/README config/providers/README docs/man/README docs/man/holland.rst )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+
+ keepdir /var/log/holland
+
+ keepdir /etc/holland
+ keepdir /etc/holland/backupsets
+ keepdir /etc/holland/providers
+
+ insinto /etc/holland
+ doins config/holland.conf
+
+ insinto /etc/holland/backupsets
+ doins config/backupsets/default.conf
+
+ doman docs/man/holland.1
+}
diff --git a/app-backup/holland/metadata.xml b/app-backup/holland/metadata.xml
new file mode 100644
index 000000000000..7a38bb900964
--- /dev/null
+++ b/app-backup/holland/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>