summaryrefslogtreecommitdiff
path: root/app-backup/holland/holland-1.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/holland/holland-1.0.10.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/holland/holland-1.0.10.ebuild')
-rw-r--r--app-backup/holland/holland-1.0.10.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-backup/holland/holland-1.0.10.ebuild b/app-backup/holland/holland-1.0.10.ebuild
new file mode 100644
index 000000000000..93923b276ab7
--- /dev/null
+++ b/app-backup/holland/holland-1.0.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Holland Core Plugins"
+HOMEPAGE="http://www.hollandbackup.org/"
+SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +mysql postgres sqlite"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ mysql? ( ~app-backup/holland-backup-mysql-meta-${PV}[${PYTHON_USEDEP}] )
+ postgres? ( ~app-backup/holland-backup-pgdump-${PV}[${PYTHON_USEDEP}] )
+ sqlite? ( ~app-backup/holland-backup-sqlite-${PV}[${PYTHON_USEDEP}] )
+ examples? (
+ ~app-backup/holland-backup-example-${PV}[${PYTHON_USEDEP}]
+ ~app-backup/holland-backup-random-${PV}[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local DOCS=( README config/README config/providers/README docs/man/README docs/man/holland.rst )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+
+ keepdir /var/log/holland
+
+ keepdir /etc/holland
+ keepdir /etc/holland/backupsets
+ keepdir /etc/holland/providers
+
+ insinto /etc/holland
+ doins config/holland.conf
+
+ insinto /etc/holland/backupsets
+ doins config/backupsets/default.conf
+
+ doman docs/man/holland.1
+}