summaryrefslogtreecommitdiff
path: root/app-backup/holland-backup-example
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/holland-backup-example
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/holland-backup-example')
-rw-r--r--app-backup/holland-backup-example/Manifest3
-rw-r--r--app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild39
-rw-r--r--app-backup/holland-backup-example/metadata.xml5
3 files changed, 47 insertions, 0 deletions
diff --git a/app-backup/holland-backup-example/Manifest b/app-backup/holland-backup-example/Manifest
new file mode 100644
index 000000000000..80b6b875cbe7
--- /dev/null
+++ b/app-backup/holland-backup-example/Manifest
@@ -0,0 +1,3 @@
+DIST holland-1.0.10.tar.gz 449334 BLAKE2B 0b0290b916448be1865ff2b5c2f0e78de9c4640418fc049b999f5dd171d8fa54c63411b5b8972c843d98f77e6b9726dbc849cb73d3771244e871bb9fea67652a SHA512 5183ec73012edcaba50ef5cc9b892480d5f60301d01d17bd96c5490bd8e6ae42bd21abb6084e6665317b8025489981a02293cd583964f01e86459609b93e918f
+EBUILD holland-backup-example-1.0.10.ebuild 889 BLAKE2B 0dea10cf383013019f2044fa58daa72f0af1f029379387b1c21500d02d47b999e7cc708787d4a4a8f46c3411b318f02efbff2ee75f93471f84938e24fd5cf660 SHA512 8b40e08af7c36e67674a34237c4d4c07b92bcce2d0633d9097bc6adffac967c6c69f4e21bd74136a948d2bdb1e2d91471d1c3e83be728c83667783b83efce76c
+MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild b/app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild
new file mode 100644
index 000000000000..381e70da2771
--- /dev/null
+++ b/app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Holland Example Plugin"
+HOMEPAGE="http://www.hollandbackup.org/"
+
+MY_P="${P%%-*}-${P##*-}"
+
+SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+PDEPEND="~app-backup/holland-${PV}[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/plugins/${PN//-/.}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ keepdir /etc/holland
+ keepdir /etc/holland/backupsets
+ keepdir /etc/holland/providers
+
+ insinto /etc/holland/backupsets
+ doins "${S}"/../../config/backupsets/examples/${PN##*-}.conf
+
+ insinto /etc/holland/providers
+ doins "${S}"/../../config/providers/${PN##*-}.conf
+}
diff --git a/app-backup/holland-backup-example/metadata.xml b/app-backup/holland-backup-example/metadata.xml
new file mode 100644
index 000000000000..7a38bb900964
--- /dev/null
+++ b/app-backup/holland-backup-example/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>