summaryrefslogtreecommitdiff
path: root/app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild')
-rw-r--r--app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild b/app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild
new file mode 100644
index 000000000000..381e70da2771
--- /dev/null
+++ b/app-backup/holland-backup-example/holland-backup-example-1.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Holland Example Plugin"
+HOMEPAGE="http://www.hollandbackup.org/"
+
+MY_P="${P%%-*}-${P##*-}"
+
+SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+PDEPEND="~app-backup/holland-${PV}[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/plugins/${PN//-/.}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ keepdir /etc/holland
+ keepdir /etc/holland/backupsets
+ keepdir /etc/holland/providers
+
+ insinto /etc/holland/backupsets
+ doins "${S}"/../../config/backupsets/examples/${PN##*-}.conf
+
+ insinto /etc/holland/providers
+ doins "${S}"/../../config/providers/${PN##*-}.conf
+}