summaryrefslogtreecommitdiff
path: root/app-backup/dirvish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/dirvish
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/dirvish')
-rw-r--r--app-backup/dirvish/Manifest4
-rw-r--r--app-backup/dirvish/dirvish-1.2.1.ebuild45
-rw-r--r--app-backup/dirvish/files/master.conf.example33
-rw-r--r--app-backup/dirvish/metadata.xml10
4 files changed, 92 insertions, 0 deletions
diff --git a/app-backup/dirvish/Manifest b/app-backup/dirvish/Manifest
new file mode 100644
index 000000000000..9da079da18dc
--- /dev/null
+++ b/app-backup/dirvish/Manifest
@@ -0,0 +1,4 @@
+AUX master.conf.example 639 BLAKE2B dede249d8a96a5f7c655b35a1e5087ddc224a009611fb07dc4a5548b3bbe7d949c12d577ccf6abbf63580578e564dc5db988a05e03772e834734ae777f420d55 SHA512 37107271ce39de9aa744e31c1abff9871eb3e58ac48e9c6470abea2742783aeedcc4dd5a698b74f83cfa23a987a3d97dee260502d883367e707edef6b99f636a
+DIST dirvish-1.2.1.tgz 49132 BLAKE2B c5ba8fee055216602fa9f645d4f797b1b5e30a9acf850e3e9c8df64760348ba89dcaf1f0a61e497b03db4a5c7bdc30b5765c0b9949218572244f896feb80b51d SHA512 3618d4e73a19ed9bffa1d68561292f8d61948ab914cf0503771fe6f058af52d02707caaf73ef8b06ddbbeef72817712ab0312c3ab086f8da036c02c1fa22d0a4
+EBUILD dirvish-1.2.1.ebuild 961 BLAKE2B 72c7cdc2ff9bcc17607da288fedf0cb0211fc599dcbbf30346208d5c56c617bf0c0f18c5aebf45e8a28109322eb17f5521ea7c398138ed19650f8b039f9ada33 SHA512 6dabdb4a13ecc8e5522eaccc55284411abec74a6cd0855deed0b2593819b42b7024da87097145ca74658b04a288282b78da00f61bffa6396e50b6cceb5b1d6fb
+MISC metadata.xml 463 BLAKE2B 1af6853a016edac5d0ea68bcf6127ae52a6d799141659fd7dc82e1da79a21c9a73ee48d2707ba3b76776c6999d9b1ef105c59bfa8ab7c05b49285b111b620d61 SHA512 924bc0fcb516c7a91c81e36bb32423d82e08c255aa4a3f16a8df649720b9f14641877ad3cbd3dc1862b1c5f0df19d30b85c4aab4ff41d34dc4586137cd235475
diff --git a/app-backup/dirvish/dirvish-1.2.1.ebuild b/app-backup/dirvish/dirvish-1.2.1.ebuild
new file mode 100644
index 000000000000..13f3e8b769af
--- /dev/null
+++ b/app-backup/dirvish/dirvish-1.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Dirvish is a fast, disk based, rotating network backup system"
+HOMEPAGE="http://www.dirvish.org/"
+SRC_URI="http://dirvish.org/${P}.tgz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="app-arch/tar"
+RDEPEND="dev-perl/Time-ParseDate
+ dev-perl/Time-Period
+ >=net-misc/rsync-2.5.7"
+
+src_prepare() {
+ default
+
+ local f
+ for f in dirvish dirvish-runall dirvish-expire dirvish-locate; do
+ cat > $f <<-EOF || die
+ #!/usr/bin/perl
+
+ \$CONFDIR = "/etc/dirvish";
+
+ EOF
+ cat $f.pl >> $f || die
+ cat loadconfig.pl >> $f || die
+ done
+}
+
+src_install() {
+ dosbin dirvish dirvish-runall dirvish-expire dirvish-locate
+ doman dirvish.8 dirvish-runall.8 dirvish-expire.8 dirvish-locate.8 dirvish.conf.5
+
+ HTML_DOCS=( {FAQ,RELEASE,TODO}.html )
+ einstalldocs
+
+ insinto /etc/dirvish
+ doins "${FILESDIR}"/master.conf.example
+}
diff --git a/app-backup/dirvish/files/master.conf.example b/app-backup/dirvish/files/master.conf.example
new file mode 100644
index 000000000000..8264b88b8321
--- /dev/null
+++ b/app-backup/dirvish/files/master.conf.example
@@ -0,0 +1,33 @@
+bank:
+ /backup/dirvish/server
+ /backup/dirvish/laptop
+ /backup/dirvish/firewall
+exclude:
+ lost+found/
+ proc/
+ core
+Runall:
+ serverroot 03:00
+ serverboot 03:00
+ serverhome 03:00
+ serveropt 03:00
+ serverspare 03:00
+ laptoproot 03:00
+ laptopboot 03:00
+ laptopopt 03:00
+ laptopspare 03:00
+ firewallroot 03:00
+ firewallboot 03:00
+
+expire-default: never
+
+# keep the sunday backups forever, the dailies for 3 months
+expire-rule:
+# MIN HR DOM MON DOW STRFTIME_FMT
+ * * * * * +3 months
+ * * * * 1 never
+
+pre-server: /usr/local/sbin/dirvish-pre
+
+post-server: /usr/local/sbin/dirvish-post
+
diff --git a/app-backup/dirvish/metadata.xml b/app-backup/dirvish/metadata.xml
new file mode 100644
index 000000000000..003cb2d2d730
--- /dev/null
+++ b/app-backup/dirvish/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">Dirvish is a fast, disk based, rotating network
+ backup system. With dirvish you can maintain a set of complete images
+ of your filesystems with unattended creation and expiration. A dirvish
+ backup vault is like a time machine for your data.
+ </longdescription>
+</pkgmetadata>