summaryrefslogtreecommitdiff
path: root/app-backup/dirvish/dirvish-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-backup/dirvish/dirvish-1.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-backup/dirvish/dirvish-1.2.1.ebuild')
-rw-r--r--app-backup/dirvish/dirvish-1.2.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-backup/dirvish/dirvish-1.2.1.ebuild b/app-backup/dirvish/dirvish-1.2.1.ebuild
new file mode 100644
index 000000000000..57629ae47577
--- /dev/null
+++ b/app-backup/dirvish/dirvish-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Dirvish is a fast, disk based, rotating network backup system"
+HOMEPAGE="http://www.dirvish.org/"
+SRC_URI="http://dirvish.org/${P}.tgz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="app-arch/tar"
+RDEPEND="dev-perl/Time-ParseDate
+ dev-perl/Time-Period
+ >=net-misc/rsync-2.5.7"
+
+src_compile() {
+ for f in dirvish dirvish-runall dirvish-expire dirvish-locate ; do
+ cat > $f <<-EOF
+ #!/usr/bin/perl
+
+ \$CONFDIR = "/etc/dirvish";
+
+ EOF
+ cat $f.pl >> $f
+ cat loadconfig.pl >> $f
+ done
+}
+
+src_install() {
+ dosbin dirvish dirvish-runall dirvish-expire dirvish-locate
+ doman dirvish.8 dirvish-runall.8 dirvish-expire.8 dirvish-locate.8 dirvish.conf.5
+ dohtml FAQ.html INSTALL RELEASE.html TODO.html
+ dodoc CHANGELOG
+
+ insinto /etc/dirvish; doins "${FILESDIR}"/master.conf.example
+}