summaryrefslogtreecommitdiff
path: root/app-backup/deja-dup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /app-backup/deja-dup
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'app-backup/deja-dup')
-rw-r--r--app-backup/deja-dup/Manifest3
-rw-r--r--app-backup/deja-dup/deja-dup-42.7.ebuild57
-rw-r--r--app-backup/deja-dup/metadata.xml31
3 files changed, 91 insertions, 0 deletions
diff --git a/app-backup/deja-dup/Manifest b/app-backup/deja-dup/Manifest
new file mode 100644
index 000000000000..18360977ce71
--- /dev/null
+++ b/app-backup/deja-dup/Manifest
@@ -0,0 +1,3 @@
+DIST deja-dup-42.7.tar.bz2 1384797 BLAKE2B f462df835039606b721d935e086e51ee27e861baa1fbc5836bb79952c838921cf5f28d439465451c5259bc2c77fa9cb839488c8b0196c6d176e32d9e42180539 SHA512 80c57fe75635346cf2597195e7f7b76e2562aaa6900e78fbfb7ad6ada9c268df36d4e16aa7ca522e1570987f5826586e1cab5fecb7d5ba90e34a23a349b47a74
+EBUILD deja-dup-42.7.ebuild 1054 BLAKE2B 62e25df12f269508e54780de326a047cea6c77871e69568755d5d38bc3c4b3aa73daeed4faaa8cef471ecd5567d8c9fb2cf03799d3d677ae6b7759d9369efe41 SHA512 f9b7faeb1435a611e9a013bd37a1e7913ac27564785a2afb94b4e87c4544572e2385dc6b549107b1190d50feec551fe7775bc3652d40660fd7134721ef7700a5
+MISC metadata.xml 1196 BLAKE2B 8dc19ef11655294c5a708e72243b81b60abc4b31dbfec4a2f414c9935bdc77cdc2c74364489781c6b357b04a1bdc9634a69e537808ae1a4c297003f2b5569613 SHA512 9569a06abda95896b3ae4e6a5990c41ae3c1a60d7ad39ea99383f61e6e3ff3908cb9f49183961ada04b8bda997b45cc1d4a05355284a88e51207d659a670ab6f
diff --git a/app-backup/deja-dup/deja-dup-42.7.ebuild b/app-backup/deja-dup/deja-dup-42.7.ebuild
new file mode 100644
index 000000000000..379d6a0cd948
--- /dev/null
+++ b/app-backup/deja-dup/deja-dup-42.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson gnome2-utils vala xdg
+
+DESCRIPTION="Simple backup tool using duplicity back-end"
+HOMEPAGE="https://wiki.gnome.org/Apps/DejaDup"
+SRC_URI="https://gitlab.gnome.org/World/deja-dup/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ $(vala_depend)
+ dev-util/intltool
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-libs/appstream-glib )
+"
+
+DEPEND="
+ >=app-backup/duplicity-0.7.14
+ >=app-crypt/libsecret-0.18.6[vala]
+ >=dev-libs/glib-2.64:2[dbus]
+ >=dev-libs/json-glib-1.2
+ dev-libs/libgpg-error
+ >=gui-libs/libhandy-1.0
+ >=net-libs/libsoup-2.48
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libnotify-0.7
+"
+
+RDEPEND="${DEPEND}
+ gnome-base/dconf
+ gnome-base/gvfs[fuse]
+"
+
+src_prepare() {
+ default
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
diff --git a/app-backup/deja-dup/metadata.xml b/app-backup/deja-dup/metadata.xml
new file mode 100644
index 000000000000..07c33c86cae2
--- /dev/null
+++ b/app-backup/deja-dup/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <name>Oz Tiram</name>
+ <email>oz.tiram@gmail.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Déjà Dup is a simple backup tool. It hides the complexity of backing up the
+ Right Way (encrypted, off-site, and regular) and uses
+ duplicity as the backend.
+
+ Support for local, remote, or cloud backup locations such as Google Drive
+ Securely encrypts and compresses your data
+ Incrementally backs up, letting you restore from any particular backup
+ Schedules regular backups
+ Integrates well into your GNOME desktop
+
+ Déjà Dup focuses on ease of use and personal, accidental data loss.
+ If you need a full system backup or an archival program, you may prefer other
+ backup apps.
+ </longdescription>
+ <upstream>
+ <remote-id type="gitlab">https://gitlab.gnome.org/World/deja-dup</remote-id>
+ <bugs-to>https://gitlab.gnome.org/World/deja-dup/issues</bugs-to>
+ </upstream>
+</pkgmetadata>