summaryrefslogtreecommitdiff
path: root/app-backup/dar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
commit6fe5af3f06c92a6b1a6b21ff5e1bc9d107490971 (patch)
tree872ff7ba355a0b1735779b329c6a6b8b8f728a88 /app-backup/dar
parente564f1661521043bc9e03e613c3cd8c79d5d7713 (diff)
gentoo auto-resync : 25:06:2023 - 19:30:41
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/Manifest2
-rw-r--r--app-backup/dar/dar-2.7.10.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index 2e766fa6fecf..a6c6ecc94622 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,3 +1,5 @@
+DIST dar-2.7.10.tar.gz 2418752 BLAKE2B 31365e900cdcd89c297f78953e82d7288cec524cc3f01a71f659a4e0238797d72c0c629d6fcfad00fa7bdaae1b846d86daa50c7857b13cac0ffac9e98bc398ef SHA512 3b75f06013d13f315280625b3ebf147e833b91164646f271ff81aa0961b788eb12a4dc6a743bbd8de4c7347bad03f2372fd8f5c038d0a83d45f3479cdba4cece
DIST dar-2.7.9.tar.gz 2418755 BLAKE2B c2874318c27d0ed2a045cf8a8547cba45966eae5f9d9682584d57fd034e94b2ce8390dc1a9330c9a96e8ed60fc27ee1f8a0ce2852e5084d0a3fbcc9ddefa8d85 SHA512 d9a4efae266d45eaae99d3f99268f3729992b9b5d01380ac01303705eb8dcf742c9b34b9cc2d1f053e07692438e014dcf417417578dc337f179bac149c98b3b5
+EBUILD dar-2.7.10.ebuild 2292 BLAKE2B fad7a901244d5c64b8cc3fbb2f9c48906ca72f155b0679d5666dfdcf644b52d5991ce79410aaece620b5951f10f2af9a2a5de95d24052bada11fa6f9baa93b01 SHA512 c3cf9615ad174363cf81bb32f8331c4014c0d05b02d8eeb1b6a30d6423d5bab6af96672ebd20a36f8dc3940a598340d132a0a264713ac9c17a257a904cf522cb
EBUILD dar-2.7.9.ebuild 2286 BLAKE2B c30b332ec60399a1c0f8a27eb943a578810b230862d82a803c5124564f06f8a0524fd055585da2450750bbab37ba4d5db90749a5a8d16b2a5b058b8deb02d50d SHA512 cde4434695eac68559dd95f16a51d3142394d71facd874470bbd9f84183f80e70f464b6cca332bd7b5809d176407a4df1e37087b82a8ca55ec52cefff85dd237
MISC metadata.xml 1180 BLAKE2B d978c1b969e7aeb013862c6b76ceb7b466af7b0a16d334bfbaafcdb49e13b4f07727073ff8a24da0f0422161f48805310b8ed7c0cc97b07190b241ad77cec254 SHA512 f8107b5f81d0d00a1873089b084250c98094625274b9c01f8ca11f6dcfa890278ec89d039849c203ccccc8115d54ee3f9365d9f6afc38cb3411f6292c62c11c0
diff --git a/app-backup/dar/dar-2.7.10.ebuild b/app-backup/dar/dar-2.7.10.ebuild
new file mode 100644
index 000000000000..e6bca3c7f42f
--- /dev/null
+++ b/app-backup/dar/dar-2.7.10.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="https://downloads.sourceforge.net/project/dar/dar/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync xattr"
+
+REQUIRED_USE="
+ ?? ( dar32 dar64 )
+ gpg? ( gcrypt )
+"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-libs/libthreadar
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2:= )
+ curl? ( net-misc/curl )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gpg? ( app-crypt/gpgme:= )
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ nls? ( virtual/libintl )
+ rsync? ( net-libs/librsync:= )
+ xattr? ( sys-apps/attr )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+"
+
+QA_PKGCONFIG_VERSION="" #862025 - upstream has a different numbering scheme for libdar
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-upx
+ $(usev !argon2 --disable-libargon2-linking)
+ $(usev !curl --disable-libcurl-linking)
+ $(usev dar32 --enable-mode=32)
+ $(usev dar64 --enable-mode=64)
+ $(usev !doc --disable-build-html)
+ $(usev !gcrypt --disable-libgcrypt-linking)
+ $(usev !gpg --disable-gpgme-linking)
+ $(usev !lz4 --disable-liblz4-linking)
+ $(usev !lzo --disable-liblzo2-linking)
+ $(usev !nls --disable-nls)
+ $(usev !rsync --disable-librsync-linking)
+ $(usev !xattr --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}