summaryrefslogtreecommitdiff
path: root/app-backup/dar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-05 21:20:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-05 21:20:55 +0100
commit2092ebe8b45cc45ad3357e2ccb2c37d5c1eaba2a (patch)
tree25c07bf0e025915c671c69127e02b8d201967e16 /app-backup/dar
parent2fc12e1ffd37b655f78c4277bd595010e18a8447 (diff)
gentoo auto-resync : 05:08:2023 - 21:20:55
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/Manifest2
-rw-r--r--app-backup/dar/dar-2.7.11.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index 6bad16b6caf0..782b0bbb65c7 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,3 +1,5 @@
DIST dar-2.7.10.tar.gz 2418752 BLAKE2B 31365e900cdcd89c297f78953e82d7288cec524cc3f01a71f659a4e0238797d72c0c629d6fcfad00fa7bdaae1b846d86daa50c7857b13cac0ffac9e98bc398ef SHA512 3b75f06013d13f315280625b3ebf147e833b91164646f271ff81aa0961b788eb12a4dc6a743bbd8de4c7347bad03f2372fd8f5c038d0a83d45f3479cdba4cece
+DIST dar-2.7.11.tar.gz 2417878 BLAKE2B 8cb166585d47f13eb796be25746dbfc33dc56f6194fa61ce811c3319354165152af05b4b82931396f886ef65163ffe2c16096aba0f7ecde6cf5a2b8ead75c4eb SHA512 17f19c865e38a4d319d84882cb8db7825cdd0092cd24af6f5a2aa60bc49cad16d51baea0f8148512e3ca6fc3fdd720b1ccd49b33dcafd674dbfa3256d0c7840e
EBUILD dar-2.7.10.ebuild 2288 BLAKE2B a2116d8ec41d1dc7ea15e57509cb5b02e1f597c4b3e94298b9ce089043574fbf6f5afe0ea518b654f491ab33e59f2ceb4e226e1db975c411ff51c5fab2bb2058 SHA512 f36966ab6bb6c9dca8b1576733acc0c8232725dc87a94a28364f33abd792e50be11e7bea8c8d783c9f648fab7398016796d6571ab600265b3985f1d199e3949d
+EBUILD dar-2.7.11.ebuild 2292 BLAKE2B fad7a901244d5c64b8cc3fbb2f9c48906ca72f155b0679d5666dfdcf644b52d5991ce79410aaece620b5951f10f2af9a2a5de95d24052bada11fa6f9baa93b01 SHA512 c3cf9615ad174363cf81bb32f8331c4014c0d05b02d8eeb1b6a30d6423d5bab6af96672ebd20a36f8dc3940a598340d132a0a264713ac9c17a257a904cf522cb
MISC metadata.xml 1180 BLAKE2B d978c1b969e7aeb013862c6b76ceb7b466af7b0a16d334bfbaafcdb49e13b4f07727073ff8a24da0f0422161f48805310b8ed7c0cc97b07190b241ad77cec254 SHA512 f8107b5f81d0d00a1873089b084250c98094625274b9c01f8ca11f6dcfa890278ec89d039849c203ccccc8115d54ee3f9365d9f6afc38cb3411f6292c62c11c0
diff --git a/app-backup/dar/dar-2.7.11.ebuild b/app-backup/dar/dar-2.7.11.ebuild
new file mode 100644
index 000000000000..e6bca3c7f42f
--- /dev/null
+++ b/app-backup/dar/dar-2.7.11.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="https://downloads.sourceforge.net/project/dar/dar/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync xattr"
+
+REQUIRED_USE="
+ ?? ( dar32 dar64 )
+ gpg? ( gcrypt )
+"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-libs/libthreadar
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2:= )
+ curl? ( net-misc/curl )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gpg? ( app-crypt/gpgme:= )
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ nls? ( virtual/libintl )
+ rsync? ( net-libs/librsync:= )
+ xattr? ( sys-apps/attr )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+"
+
+QA_PKGCONFIG_VERSION="" #862025 - upstream has a different numbering scheme for libdar
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-upx
+ $(usev !argon2 --disable-libargon2-linking)
+ $(usev !curl --disable-libcurl-linking)
+ $(usev dar32 --enable-mode=32)
+ $(usev dar64 --enable-mode=64)
+ $(usev !doc --disable-build-html)
+ $(usev !gcrypt --disable-libgcrypt-linking)
+ $(usev !gpg --disable-gpgme-linking)
+ $(usev !lz4 --disable-liblz4-linking)
+ $(usev !lzo --disable-liblzo2-linking)
+ $(usev !nls --disable-nls)
+ $(usev !rsync --disable-librsync-linking)
+ $(usev !xattr --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}