summaryrefslogtreecommitdiff
path: root/app-backup/dar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /app-backup/dar
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/Manifest2
-rw-r--r--app-backup/dar/dar-2.7.9.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index 74ead3c951e6..1acce01c60a2 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,3 +1,5 @@
DIST dar-2.7.8.tar.gz 2414732 BLAKE2B a6756218b89bfe17869cdd630a712593d6a615f8bac7da71dfad7bb96c91ee8321b0f7ba4515faa91cbf4eee683b1373392084ba76004d971d0a5f492b4238b6 SHA512 af3942b164e8e4f54504a9c561e1a90b950d5afd8c10ab351fc9657626f4b6650a18ea1727c5684918d3067f3b4738285afb78150c850ce77ee8d4a6f5567f2e
+DIST dar-2.7.9.tar.gz 2418755 BLAKE2B c2874318c27d0ed2a045cf8a8547cba45966eae5f9d9682584d57fd034e94b2ce8390dc1a9330c9a96e8ed60fc27ee1f8a0ce2852e5084d0a3fbcc9ddefa8d85 SHA512 d9a4efae266d45eaae99d3f99268f3729992b9b5d01380ac01303705eb8dcf742c9b34b9cc2d1f053e07692438e014dcf417417578dc337f179bac149c98b3b5
EBUILD dar-2.7.8.ebuild 2345 BLAKE2B ba6185e4b138c5c1a6e5ca8ecffc7ecba8c9e5fda8dcadaf24ecf46f841bfaf52ac1176be8499c78fd0d756e8ae60049e5faed05d67ba25e3f9483e103290afb SHA512 c9d16e9ba87351fd04b817868b22ad81e7adbcae96e0ae8d496fb52bffba79f1385a8abde0ed4a6590a1aa46eb58c543b89fb6dc13affe7678b55fdd27ee50e2
+EBUILD dar-2.7.9.ebuild 2290 BLAKE2B 2d1eaf64a3fd9d0c35aa0f64d604592f2416c8169234d5084e3f07bd28455be82ee65bf81e766c4399e1a30b5022a0fdf29c40627eba17ed1d1341dd01dd4980 SHA512 eb31623d4031afd2f9cd34f7ad46873776a52b002fd9fa86b85cf319344928ad80d123af2db025ee0637284b9c597b5617157578ba32e2e1b8eb9fae19e8a760
MISC metadata.xml 1180 BLAKE2B d978c1b969e7aeb013862c6b76ceb7b466af7b0a16d334bfbaafcdb49e13b4f07727073ff8a24da0f0422161f48805310b8ed7c0cc97b07190b241ad77cec254 SHA512 f8107b5f81d0d00a1873089b084250c98094625274b9c01f8ca11f6dcfa890278ec89d039849c203ccccc8115d54ee3f9365d9f6afc38cb3411f6292c62c11c0
diff --git a/app-backup/dar/dar-2.7.9.ebuild b/app-backup/dar/dar-2.7.9.ebuild
new file mode 100644
index 000000000000..472729fb81de
--- /dev/null
+++ b/app-backup/dar/dar-2.7.9.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="https://downloads.sourceforge.net/project/dar/dar/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync xattr"
+
+REQUIRED_USE="?? ( dar32 dar64 )
+ gpg? ( gcrypt )"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-libs/libthreadar
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2:= )
+ curl? ( net-misc/curl )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gpg? ( app-crypt/gpgme:= )
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ nls? ( virtual/libintl )
+ rsync? ( net-libs/librsync:= )
+ xattr? ( sys-apps/attr )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+"
+
+QA_PKGCONFIG_VERSION="" #862025 - upstream has a different numbering scheme for libdar
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-upx
+ $(usev !argon2 --disable-libargon2-linking)
+ $(usev !curl --disable-libcurl-linking)
+ $(usev dar32 --enable-mode=32)
+ $(usev dar64 --enable-mode=64)
+ $(usev !doc --disable-build-html)
+ $(usev !gcrypt --disable-libgcrypt-linking)
+ $(usev !gpg --disable-gpgme-linking)
+ $(usev !lz4 --disable-liblz4-linking)
+ $(usev !lzo --disable-liblzo2-linking)
+ $(usev !nls --disable-nls)
+ $(usev !rsync --disable-librsync-linking)
+ $(usev !xattr --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}