summaryrefslogtreecommitdiff
path: root/app-backup/ccollect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/ccollect
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/ccollect')
-rw-r--r--app-backup/ccollect/Manifest3
-rw-r--r--app-backup/ccollect/ccollect-0.8.ebuild78
-rw-r--r--app-backup/ccollect/metadata.xml7
3 files changed, 88 insertions, 0 deletions
diff --git a/app-backup/ccollect/Manifest b/app-backup/ccollect/Manifest
new file mode 100644
index 000000000000..2464513cc5e3
--- /dev/null
+++ b/app-backup/ccollect/Manifest
@@ -0,0 +1,3 @@
+DIST ccollect-0.8.tar.bz2 60376 BLAKE2B e3580aa6d1438b106c372e5b4abc77b9e19a8e057b93cfbd5882b3e9a899d5fa02c31c030c933c6e3e254687423cc51d0d86787365d40e4f5635aab3aa6dd954 SHA512 dc4b2a8687c636938154f8a4a4048c3f0ef13f6d6e3f6e66d8dcc8f544f3a390a98a8dbfb3ba2ba9019decbec5d628f07461dd3f803e14b2203972936ebf96f3
+EBUILD ccollect-0.8.ebuild 2211 BLAKE2B eee5eddafcac2ca0e74fe8afb936cd9ee578c8e22959ecfb579f97a42e287eb40a2274e795a4ca3cb468fcbe1ac2c626342de7781621cd582339ee0811ff9cbd SHA512 8b40955d9a3d76dddc8bda3b6267b4df351cd32350a95a14e013a0a38d68c422ca5be476c51b3116b4b5ed6190c8e7b9f80f8d1045d01a29d4c4e06d95680e7f
+MISC metadata.xml 219 BLAKE2B 3c2cd05bc68548ac484a4867fe08096d464a904a994babae6b67e953b25fcd50e14a38ea3a45b8a29b8542bf84f31455742f4cff34c491c07d2dfe732c0c6868 SHA512 deccbe684f92cee0cda5253fd564994d5718143e047d6ce61fea68c3f061dc566e88288e13d98df5e68769ea347724bc39b7a466d3f1028498b4b66bc545ca9e
diff --git a/app-backup/ccollect/ccollect-0.8.ebuild b/app-backup/ccollect/ccollect-0.8.ebuild
new file mode 100644
index 000000000000..f4da568241cd
--- /dev/null
+++ b/app-backup/ccollect/ccollect-0.8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Pseudo incremental backup with different exclude lists using hardlinks and rsync"
+HOMEPAGE="https://www.nico.schottelius.org/software/ccollect/"
+SRC_URI="https://www.nico.schottelius.org/software/${PN}/download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ~sparc x86"
+IUSE="doc examples"
+
+DEPEND="
+ doc? (
+ >=app-text/asciidoc-8.1.0
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ )"
+RDEPEND="net-misc/rsync"
+
+# tests need ssh-access
+RESTRICT="test"
+
+src_compile() {
+ use doc && emake XSL=/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl documentation
+}
+
+src_install() {
+ dobin ccollect.sh
+ dosym ccollect.sh /usr/bin/ccollect
+
+ local i
+ for i in add_source analyse_logs archive_config check_config \
+ delete_source list_intervals logwrapper stats; do
+ newbin tools/ccollect_${i}.sh ccollect_${i}
+ done
+
+ insinto /usr/share/${PN}/tools
+ doins tools/config-pre* tools/{gnu-du-backup-size-compare,report_success}.sh
+
+ pushd doc/changes >/dev/null || die
+ for i in * ; do
+ newdoc ${i} NEWS-${i}
+ done
+ popd >/dev/null || die
+
+ if use doc; then
+ doman doc/man/*.1
+
+ find doc/ \( -iname '*.1' -o -iname '*.text' \) -delete || die
+ HTML_DOCS=( doc/{*.htm{,l},man} )
+ fi
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc -r conf/.
+ fi
+}
+
+pkg_postinst() {
+ ewarn "If you're upgrading from 0.6.x or less, you'll have to"
+ ewarn "upgrade your existing configuration as follows:"
+ ewarn "1. Make the scripts in ${EROOT%/}/usr/share/ccollect/scripts executable"
+ ewarn "2. Run all config-pre-\$VER-to-\$VER.sh in ${EROOT%/}/usr/share/ccollect/scripts"
+ ewarn " ascending order, where \$VER is greater or equal than the version"
+ ewarn " you upgraded from."
+ ewarn "Example:"
+ ewarn " You upgraded from 0.5, thus you have to run:"
+ ewarn " ${EROOT%/}/usr/share/ccollect/tools/config-pre-0.6-to-0.6.sh"
+ ewarn " ${EROOT%/}/usr/share/ccollect/tools/config-pre-0.7-to-0.7.sh"
+
+ elog "Please note that many tools are now installed directly to ${EROOT%/}/usr/bin"
+ elog "as recommended by upstream."
+}
diff --git a/app-backup/ccollect/metadata.xml b/app-backup/ccollect/metadata.xml
new file mode 100644
index 000000000000..8626ee05464b
--- /dev/null
+++ b/app-backup/ccollect/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev-zero@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>