summaryrefslogtreecommitdiff
path: root/app-backup/ccollect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-backup/ccollect
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-backup/ccollect')
-rw-r--r--app-backup/ccollect/Manifest2
-rw-r--r--app-backup/ccollect/ccollect-0.8.ebuild53
2 files changed, 29 insertions, 26 deletions
diff --git a/app-backup/ccollect/Manifest b/app-backup/ccollect/Manifest
index f139246f700c..194eddb5cde9 100644
--- a/app-backup/ccollect/Manifest
+++ b/app-backup/ccollect/Manifest
@@ -1,3 +1,3 @@
DIST ccollect-0.8.tar.bz2 60376 BLAKE2B e3580aa6d1438b106c372e5b4abc77b9e19a8e057b93cfbd5882b3e9a899d5fa02c31c030c933c6e3e254687423cc51d0d86787365d40e4f5635aab3aa6dd954 SHA512 dc4b2a8687c636938154f8a4a4048c3f0ef13f6d6e3f6e66d8dcc8f544f3a390a98a8dbfb3ba2ba9019decbec5d628f07461dd3f803e14b2203972936ebf96f3
-EBUILD ccollect-0.8.ebuild 2197 BLAKE2B f07bdf6e9555965af43be6a77e42cba0e4e5a012a1743be0e1578bdb347a16bb54838edddc4891886bc00854f87232d90208862f421abe30c4b38db3a2c16fb4 SHA512 1a06b65dd77c84f118c7f9409fb51f56dd6dd3bc2add24ea130bf918fce2636194a2e3f686e5f4838071191b0f589652ab396ea08df839776973cdb99d13b0a8
+EBUILD ccollect-0.8.ebuild 2209 BLAKE2B c245ee9ee911eb007e5bb3d9992cba79d1778aeffb9a7ae4fbd1a741ac755f4eef382fe6492a04422e634b6d8e3b5f8e7fb3c4337bea8df27d911af438049c14 SHA512 0258656ab9b00506d1a2fb4e841c91945263d692811cb609b6f222fef947eddd37eb6b284e8332a96c09939f9835024fd9ad0ff49b481cd154471a3605c95126
MISC metadata.xml 219 BLAKE2B 3c2cd05bc68548ac484a4867fe08096d464a904a994babae6b67e953b25fcd50e14a38ea3a45b8a29b8542bf84f31455742f4cff34c491c07d2dfe732c0c6868 SHA512 deccbe684f92cee0cda5253fd564994d5718143e047d6ce61fea68c3f061dc566e88288e13d98df5e68769ea347724bc39b7a466d3f1028498b4b66bc545ca9e
diff --git a/app-backup/ccollect/ccollect-0.8.ebuild b/app-backup/ccollect/ccollect-0.8.ebuild
index 8cd9780edb4b..b5a9a055b4ac 100644
--- a/app-backup/ccollect/ccollect-0.8.ebuild
+++ b/app-backup/ccollect/ccollect-0.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
DESCRIPTION="Pseudo incremental backup with different exclude lists using hardlinks and rsync"
HOMEPAGE="http://www.nico.schottelius.org/software/ccollect/"
@@ -12,64 +12,67 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc ~sparc x86"
IUSE="doc examples"
-DEPEND="doc? ( >=app-text/asciidoc-8.1.0
+DEPEND="
+ doc? (
+ >=app-text/asciidoc-8.1.0
app-text/docbook-xsl-stylesheets
app-text/docbook-xml-dtd:4.2
- dev-libs/libxslt )"
+ dev-libs/libxslt
+ )"
RDEPEND="net-misc/rsync"
# tests need ssh-access
RESTRICT="test"
src_compile() {
- if use doc; then
- emake XSL=/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl documentation || die "building docs failed"
- fi
+ use doc && emake XSL=/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl documentation
}
src_install() {
dobin ccollect.sh
dosym ccollect.sh /usr/bin/ccollect
- local tools="add_source analyse_logs archive_config check_config delete_source list_intervals logwrapper stats"
- for t in ${tools} ; do
- newbin tools/ccollect_${t}.sh ccollect_${t}
+ local i
+ for i in add_source analyse_logs archive_config check_config \
+ delete_source list_intervals logwrapper stats; do
+ newbin tools/ccollect_${i}.sh ccollect_${i}
done
insinto /usr/share/${PN}/tools
doins tools/config-pre* tools/{gnu-du-backup-size-compare,report_success}.sh
- dodoc CREDITS README
- pushd doc/changes
- for n in * ; do
- newdoc ${n} NEWS-${n}
- done
- popd
+ pushd doc/changes >/dev/null || die
+ for i in * ; do
+ newdoc ${i} NEWS-${i}
+ done
+ popd >/dev/null || die
if use doc; then
- dohtml doc/*.htm doc/*.html
- dohtml -r doc/man
doman doc/man/*.1
+
+ find doc/ \( -iname '*.1' -o -iname '*.text' \) -delete || die
+ HTML_DOCS=( doc/{*.htm{,l},man} )
fi
+ einstalldocs
if use examples ; then
- # dodoc is not recursive. So do a workaround.
- insinto /usr/share/doc/${PF}/examples/
- doins -r conf/*
+ docinto examples
+ dodoc -r conf/.
fi
}
pkg_postinst() {
ewarn "If you're upgrading from 0.6.x or less, you'll have to"
ewarn "upgrade your existing configuration as follows:"
- ewarn "1. Make the scripts in /usr/share/ccollect/scripts executable"
- ewarn "2. Run all config-pre-\$VER-to-\$VER.sh in /usr/share/ccollect/scripts"
+ ewarn "1. Make the scripts in ${EROOT%/}/usr/share/ccollect/scripts executable"
+ ewarn "2. Run all config-pre-\$VER-to-\$VER.sh in ${EROOT%/}/usr/share/ccollect/scripts"
ewarn " ascending order, where \$VER is greater or equal than the version"
ewarn " you upgraded from."
ewarn "Example:"
ewarn " You upgraded from 0.5, thus you have to run:"
- ewarn " /usr/share/ccollect/tools/config-pre-0.6-to-0.6.sh"
- ewarn " /usr/share/ccollect/tools/config-pre-0.7-to-0.7.sh"
- elog "Please note that many tools are now installed directly to /usr/bin"
+ ewarn " ${EROOT%/}/usr/share/ccollect/tools/config-pre-0.6-to-0.6.sh"
+ ewarn " ${EROOT%/}/usr/share/ccollect/tools/config-pre-0.7-to-0.7.sh"
+
+ elog "Please note that many tools are now installed directly to ${EROOT%/}/usr/bin"
elog "as recommended by upstream."
}