summaryrefslogtreecommitdiff
path: root/app-backup/burp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /app-backup/burp
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'app-backup/burp')
-rw-r--r--app-backup/burp/Manifest3
-rw-r--r--app-backup/burp/burp-2.2.18-r1.ebuild107
-rw-r--r--app-backup/burp/burp-2.2.18.ebuild2
3 files changed, 110 insertions, 2 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index 8bf2ce3969ec..014f3d1cc5b2 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -6,5 +6,6 @@ AUX burp.service 193 BLAKE2B fa9a00f32999834afaf84db9d28f2e8b65688e784e32f78bc01
DIST burp-2.1.32.tar.gz 591737 BLAKE2B fd525bff32348f1dbc37b1c065d262ff8af1d999d19f63711ebcff3fb55e90a7440cc6cfc0b7eefe6f8e250672c799d86e65ed599f0b8d7dd80bebcb99888987 SHA512 2477b7a9a2123b227a27519f7f3d9facca7173a9e63d66f6a8fb2ae5408d8af4ad5bfdd0a14efd6cf80e7bc8e91907f7c293a3d621b86bafdbf163bfa08d0c81
DIST burp-2.2.18.tar.gz 632805 BLAKE2B 6106aa4bd96db035ad5893c2fe314537e620a67519295fdf99efaf2c5a639bedd15b4c8d95caa3daa3072dfac28a1ba7fd7bb4f949d9ea2b70bd13060a22f2c6 SHA512 beb14c61ace6d61b98a10fc4e6709eec9722e28990de862eef6a75984f9fbd0f903c5fe64d20ed84c95528a9889bc22618ba6d2318318cf5d515b35688db0a4d
EBUILD burp-2.1.32-r1.ebuild 2841 BLAKE2B aa96c385aee446cb39191f067eb7896bed961a0711372a8db1aee2209a692286d64ad63cd6cf9551497f00cba8e570b9f46f54d1fb39b08b3982464c8df47457 SHA512 b5405cae46b2991827adf6fb152a12cfb8ef382f07575882f81f73e88a13ab0af93f122fc551293e8e5fa0d6063832eef0cb30dd8f3b9b8cfcfb8082e24780d9
-EBUILD burp-2.2.18.ebuild 2848 BLAKE2B 2e2e1e1df230f6ac6e80f69e807cbc3bf52170500bf6311c3279ca047d0e2577bd614aeef83577d02ded73398642b3ea3a6b06bd3c811958be9bac1e991ab67e SHA512 82823ae3d3fe09979f4d392e09fce6f451f83f6eb586206d4595e8b264d9240e2d9c91b9b11c5f431316161c7897b83c26dff29e67c8f1d76cb945a3e0e6808e
+EBUILD burp-2.2.18-r1.ebuild 2805 BLAKE2B 782cb5e9bc86870986420ca64dce52602d9da652e41e19797ef66eea4d7105f05456facced6fe68048247227c664c71594428a6594fbeb83b0d627500f259b56 SHA512 9b88aad2661aeb6d3a24522719b986239ba84a10264cd81459544a91abe27694db226d09d29fc43a112ef2c6aaf26eff61181caab8b2c489a95f1cd8aab3972e
+EBUILD burp-2.2.18.ebuild 2846 BLAKE2B ec0ad61b2b7502cf0462315e7e515ff285a0d231ee9d4fe98adc0fe38f1397bace971c12f48e27a4205c42465da3993fa8bdac3836b98105c378713ac8f5d411 SHA512 f8b0235a5e77ec0f4911b699dff22c77f022acfc2d2931f9723aff2974aef6fbe4cfeed4e915770306ff819d77a2ffc40c7d624589fa2901d639895de4f294ed
MISC metadata.xml 684 BLAKE2B 3b4511a62d65ec23ef3b1311f57d703154f08e8d82d189a5ea0b555b5d7d686c54365d2992b85c6e5dffa0ee93f7331367925766ea1bfe349446c23d73dba392 SHA512 3752a2b8e2fb49d44d8fe431768ab1b4bc9995099e9bbe4f957677b39ca038a75874bfb0781b1cd1bd4bd79186c0994f2ce5654921a58c9645ffd6dc553f3c9f
diff --git a/app-backup/burp/burp-2.2.18-r1.ebuild b/app-backup/burp/burp-2.2.18-r1.ebuild
new file mode 100644
index 000000000000..2d359b43f0d2
--- /dev/null
+++ b/app-backup/burp/burp-2.2.18-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="https://burp.grke.org/"
+SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl ipv6 libressl test xattr"
+
+CDEPEND="dev-libs/uthash
+ net-libs/librsync
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+RDEPEND="${CDEPEND}
+ acct-group/burp
+ acct-user/burp
+ virtual/logger"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
+ "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ $(use_enable acl)
+ $(use_enable ipv6)
+ $(use_enable xattr)
+ )
+ # --runstatedir option will only work from autoconf-2.70 onwards
+ runstatedir='/run' \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/spool/burp
+ fowners -R root:${PN} /var/spool/burp
+ fperms 0770 /var/spool/burp
+
+ emake DESTDIR="${D}" install-configs
+ fowners -R root:${PN} /etc/burp
+ fperms 0750 /etc/burp
+ fperms 0640 /etc/burp/burp-server.conf
+ fperms 0750 /etc/burp/clientconfdir
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog "Burp ebuilds now support the autoupgrade mechanism in both"
+ elog "client and server mode. In both cases it is disabled by"
+ elog "default. You almost certainly do NOT want to enable it in"
+ elog "client mode because upgrades obtained this way will not be"
+ elog "managed by Portage."
+
+ if [[ ! -e /etc/burp/CA/index.txt ]]; then
+ elog ""
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " /etc/burp/burp-server.conf"
+ elog ""
+ fi
+
+ # According to PMS this can be a space-separated list of version
+ # numbers, even though in practice it is typically just one.
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
+ ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
+ ewarn "the server config file by default. If you use bedup, please"
+ ewarn "update your scripts to invoke it as"
+ ewarn ""
+ ewarn " bedup -c /etc/burp/burp-server.conf"
+ ewarn ""
+ ewarn "Otherwise deduplication will not work!"
+ break
+ fi
+ done
+}
diff --git a/app-backup/burp/burp-2.2.18.ebuild b/app-backup/burp/burp-2.2.18.ebuild
index 944065493170..cf4ac612bd2b 100644
--- a/app-backup/burp/burp-2.2.18.ebuild
+++ b/app-backup/burp/burp-2.2.18.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="amd64 ~arm x86"
IUSE="acl ipv6 libressl test xattr"
CDEPEND="dev-libs/uthash