summaryrefslogtreecommitdiff
path: root/app-backup/borgmatic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /app-backup/borgmatic
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'app-backup/borgmatic')
-rw-r--r--app-backup/borgmatic/Manifest2
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.6.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 43398301b2a1..03ebb6f8cf4a 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,5 +1,7 @@
AUX borgmatic-1.5.1-no_test_coverage.patch 284 BLAKE2B 91e041cb2d3d15b65c47075b0524e6e2a60631702eb10243da79b8051504e33476e6f8d61a3d9a172302b9859a01afb0d640a502cc95f69e45024a8fdb5ebc53 SHA512 1604d425f4c3267a41449f5d05675634f365d0be0630b49812e87d13ebc4ee78e01259f2371afbf2150b5b1203676e20c50c1613be24e0fa39df635d229f80bc
AUX borgmatic-1.5.1-systemd_service_bin_path.patch 446 BLAKE2B bad832573f35e832e5a111a12d6c61cf2e2b1111e91252923e841ae5ec6661ed4f1c4d1e4cc94fe31887d8ee0b2a54aac7d79f8bd0e6f27a2e89f1ff0484c091 SHA512 299791d5079522270954a6742669f3031c0d6164ad7037387dad7f7dccebbe20b83f21f1e30ee61915c2703a370ba9987ab66989c4a99c1706ddf2b17bc2c718
DIST borgmatic-1.5.1.tar.gz 67401 BLAKE2B c11f4b9f9acc7d7bf4e482953968dbaabc33f1513ec8f20868518bca22ffcafee90569c06ec603be919d47d724dd4a3a904e44fbb40c2309d8cb78e9277b5cc7 SHA512 9ded9bd5d6db866d196fedee88737f3d3eef6cb0e61c5f55ac543602c4429adcb57608d7f6c798edfd6ac1ecd14aadd9a88fdf94ef1f0eab4c26a9d2a29c5e38
+DIST borgmatic-1.5.6.tar.gz 70075 BLAKE2B 23e233c7457c25ae5b83571436dcfac4e70bf4c9a9bf9af95b8722533b48fdd82089152da220b7d61a01569233f2aedddf300c3a5ad2c69c631060f0b08e6b59 SHA512 e314fa1f20516dd52f4435c782bf634821a034925c0f11553483a1e55eef5d588e54e7abb1a88d239c1619f291548a5058a8f636d16dd829680089c20c601a79
EBUILD borgmatic-1.5.1-r2.ebuild 2141 BLAKE2B b0aca4c281f46466b2ab6f6ecf3f94adfd51460097e4db346c1f7d5f5461cad820e6cd16ea5ba195af041117df2dbf5c5085ef1079d449e65ce7d97a183ac3be SHA512 d238d0b9b81e5acbc790063c7d6bef904733eee70bb704ac8156593814d941b9b18191586800348f70110269e25c32648f47649e0e59faa507a2e31ed1ecd3ed
+EBUILD borgmatic-1.5.6.ebuild 2141 BLAKE2B b0aca4c281f46466b2ab6f6ecf3f94adfd51460097e4db346c1f7d5f5461cad820e6cd16ea5ba195af041117df2dbf5c5085ef1079d449e65ce7d97a183ac3be SHA512 d238d0b9b81e5acbc790063c7d6bef904733eee70bb704ac8156593814d941b9b18191586800348f70110269e25c32648f47649e0e59faa507a2e31ed1ecd3ed
MISC metadata.xml 365 BLAKE2B 6fceb22a831c0ee0669e3545737da7a6fe778e9b188fba0c72f8e70988404ad444b2b75cd7e6001012cd2226d5f6f7a7096b3f837de905e559e94badf649d412 SHA512 72be8c3e4d69e9c33307d20b3ec2b05b134787fde7e015fa70f0dbea365163f235f21490500d68fe19b771528f813cf3257d1df175d5d009f6e9414ba5ea4db1
diff --git a/app-backup/borgmatic/borgmatic-1.5.6.ebuild b/app-backup/borgmatic/borgmatic-1.5.6.ebuild
new file mode 100644
index 000000000000..a287fddbef27
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.5.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pykwalify-1.6.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.17.0[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Unlike the other two test files in integration/commands, which use the
+ # relevant modules' respective APIs, test_borgmatic.py tries to call the
+ # 'borgmatic' executable - which by the time we execute src_test will
+ # not have been created yet. distutils_install_for_testing would likely
+ # take care of this - but between the aforementioned behaviour inconsistency
+ # and the fact the only test run from this file as of version 1.5.1 is the
+ # parsing of contents of 'borgmatic --version', just skip it for now.
+ rm -f "${S}"/tests/integration/commands/test_borgmatic.py
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ else
+ elog "To upgrade your configuration file to the current version, run:"
+ elog " upgrade-borgmatic-config"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}