summaryrefslogtreecommitdiff
path: root/app-backup/borgmatic/borgmatic-1.7.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-06 17:54:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-06 17:54:58 +0000
commit47223eb70974998c84966981d9e4fc2be27b3f8a (patch)
tree961d3fea7a2e379eac81620131a0b6df82e7e9c3 /app-backup/borgmatic/borgmatic-1.7.8.ebuild
parent62277f96ac0a859cfd02e8d1775081a4ba521682 (diff)
gentoo auto-resync : 06:03:2023 - 17:54:58
Diffstat (limited to 'app-backup/borgmatic/borgmatic-1.7.8.ebuild')
-rw-r--r--app-backup/borgmatic/borgmatic-1.7.8.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-backup/borgmatic/borgmatic-1.7.8.ebuild b/app-backup/borgmatic/borgmatic-1.7.8.ebuild
new file mode 100644
index 000000000000..87cdd1fed96c
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.7.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.3-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}