summaryrefslogtreecommitdiff
path: root/app-backup/borgbackup/borgbackup-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-backup/borgbackup/borgbackup-9999.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/borgbackup/borgbackup-9999.ebuild')
-rw-r--r--app-backup/borgbackup/borgbackup-9999.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/app-backup/borgbackup/borgbackup-9999.ebuild b/app-backup/borgbackup/borgbackup-9999.ebuild
deleted file mode 100644
index fdd80a89ecd9..000000000000
--- a/app-backup/borgbackup/borgbackup-9999.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/borg.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
-HOMEPAGE="https://borgbackup.readthedocs.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="libressl"
-
-# Unfortunately we have a file conflict with app-office/borg, bug #580402
-RDEPEND="
- !!app-office/borg
- app-arch/lz4
- dev-python/llfuse[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
-"
-
-DEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}
-"
-
-python_prepare_all() {
- # allow use of new (renamed) msgpack
- sed -i "s|'msgpack-python.*',||g" setup.py || die
- distutils-r1_python_prepare_all
-}