summaryrefslogtreecommitdiff
path: root/app-backup/attic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-backup/attic
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-backup/attic')
-rw-r--r--app-backup/attic/Manifest4
-rw-r--r--app-backup/attic/attic-0.16-r1.ebuild40
-rw-r--r--app-backup/attic/attic-9999.ebuild40
-rw-r--r--app-backup/attic/metadata.xml11
4 files changed, 95 insertions, 0 deletions
diff --git a/app-backup/attic/Manifest b/app-backup/attic/Manifest
new file mode 100644
index 000000000000..af233a25094b
--- /dev/null
+++ b/app-backup/attic/Manifest
@@ -0,0 +1,4 @@
+DIST attic-0.16.tar.gz 87985 BLAKE2B cc801d8e3b28f6041c053f368c1d5ab00b1b419928d6a84647da7dccb7fb46b477898249873e90ba15c721468c09ae243d450fc978fe8cc3947b2c2e035f2aae SHA512 16139cd93bff59414cc1ce3fd68e2dd0aed4937a20bd1003880961ad2e239a1e982fd0d4f6b791165464213b88dea6ccd8e5e59d2087809be2e1bfdfd3b3186c
+EBUILD attic-0.16-r1.ebuild 930 BLAKE2B 95e95acd781abdab3aaacb913e49868b151eb6b75466d1afc8e821dab9c2147f80fa6129c78f220f96bc7a6475d0d98df804b3c5b4662f970080cc5689ebc0e6 SHA512 101fe0fde2f48e9ceecf21efca1735d6466deb3dde7c10c45f52f8f076f95858b1ea8adcfc432b4eda87bebf3d3dcf529646a1acf1074daeb17857def8bf135a
+EBUILD attic-9999.ebuild 930 BLAKE2B 95e95acd781abdab3aaacb913e49868b151eb6b75466d1afc8e821dab9c2147f80fa6129c78f220f96bc7a6475d0d98df804b3c5b4662f970080cc5689ebc0e6 SHA512 101fe0fde2f48e9ceecf21efca1735d6466deb3dde7c10c45f52f8f076f95858b1ea8adcfc432b4eda87bebf3d3dcf529646a1acf1074daeb17857def8bf135a
+MISC metadata.xml 328 BLAKE2B 4b8c33c80a1e860ec347a8735aad642c9dc441f87b20c588dde534be6d4f9b6981a07314f0643769537ce946f1397eee20801d381c2632d5c98a1d6db12a00cd SHA512 2c24d7eaef0da74758f5726e2b88d2dc11db8a2ea3999abee9305c5e66b236b50d56034d5fae9a7b1d9caa98c7fa3aa54dd06d5279b3a636532010130e40f36a
diff --git a/app-backup/attic/attic-0.16-r1.ebuild b/app-backup/attic/attic-0.16-r1.ebuild
new file mode 100644
index 000000000000..7734e651f958
--- /dev/null
+++ b/app-backup/attic/attic-0.16-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jborg/attic.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Attic is a deduplicating backup program written in Python."
+HOMEPAGE="https://attic-backup.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ dev-python/llfuse[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+python_prepare_all() {
+ # allow use of new (renamed) msgpack
+ sed -i '/msgpack/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/app-backup/attic/attic-9999.ebuild b/app-backup/attic/attic-9999.ebuild
new file mode 100644
index 000000000000..7734e651f958
--- /dev/null
+++ b/app-backup/attic/attic-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jborg/attic.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Attic is a deduplicating backup program written in Python."
+HOMEPAGE="https://attic-backup.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ dev-python/llfuse[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+python_prepare_all() {
+ # allow use of new (renamed) msgpack
+ sed -i '/msgpack/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/app-backup/attic/metadata.xml b/app-backup/attic/metadata.xml
new file mode 100644
index 000000000000..3cefbbec9038
--- /dev/null
+++ b/app-backup/attic/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jborg/attic</remote-id>
+ </upstream>
+</pkgmetadata>