summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
commitf6a034d922bf54efeaa781fcb5388b325b90d945 (patch)
treeb9fafda6cf44bf7b09de2c3d74090de10f9cde04 /app-arch
parent007b0aae027279095b8605c214b535e59df8f6eb (diff)
gentoo auto-resync : 03:05:2023 - 11:25:06
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/Manifest.gzbin17409 -> 17410 bytes
-rw-r--r--app-arch/wimlib/Manifest2
-rw-r--r--app-arch/wimlib/wimlib-1.14.1.ebuild52
3 files changed, 54 insertions, 0 deletions
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index cc98f5251426..106a07875cb9 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ
diff --git a/app-arch/wimlib/Manifest b/app-arch/wimlib/Manifest
index 744eea63457f..7c831d463eaf 100644
--- a/app-arch/wimlib/Manifest
+++ b/app-arch/wimlib/Manifest
@@ -1,3 +1,5 @@
DIST wimlib-1.13.4.tar.gz 1040411 BLAKE2B 4563429d42be39b959a15ef66ac4c173531ff0c0b0f1a341812a4f870c9f189478f3ce78bf6240544f71b1746d98c9eae3f7182d646355343e26526559384f07 SHA512 480fe6fa6c6e8f1bf9c3960f5e1671f3266535b18dc72e9d7c4c05c7fb833d9b00db5ae9fb49154da6e71e536cae8b562cbf81ab5a124e2a79326927e2cf7344
+DIST wimlib-1.14.1.tar.gz 1046078 BLAKE2B 56e44928229c9c4fda662fa64fc4021bd361c2c959f0786764b84fa4cc9d7f7b0d5440edb4d4079657cc7bf450ac9c755f554c7da7a8b2b7e96d69ddbeb4f22f SHA512 9f92a8ce2d386918d66a1a3e52d4fbffeeb9f8b9345b25012fd0bd07039a00be84fd83d83a9bb25bcefab09597a81e9392522be835dd6693dd00050f8624af00
EBUILD wimlib-1.13.4-r1.ebuild 1480 BLAKE2B 8cb36da172e3897b2abbc1efc6b07acfa58c41ba56d39716b40f3d0d299db4f4b02737c97d2beaf1fad48c593bac33e4e9d0dbf27d7dcc18bbc2aaaea77aa203 SHA512 030fcf7ff66bcc05253e7b164158be0cb70ebd8baf79c394a2b63b7b87ba89d54e6e78f3ca53075a2f19572b8989bd94a2d702f47e53c7540f58050d52d94c85
+EBUILD wimlib-1.14.1.ebuild 906 BLAKE2B 2cb2d0126b964a40c948496e114fe56528f4bcf19ff46163399adb5712b2f720b5768d55fbea2c1f711cd589585fc2847cf8eb128ba29e6080bd51c9729c29a1 SHA512 e42c54fe7706aff6587abaec9d53051de8900d9546ff897873ae7fcad00cc4d4a59ff9dd16c0f2d616e47b268f80d55c93ea55a713c02175669f0f1f9a1a59fc
MISC metadata.xml 464 BLAKE2B 23ad11fa613e5c99d7a4f5efcf81a33cbf1b4a297cfdd160541953d65cfa5395743a464230ff563ec218bef5cdc4518291522787675ccee4aac7ac5c302b5576 SHA512 3544db561d9ca74410805cb054984502fe34d7cfa17ab77b519e33438abdb3fccc2eb941f3c1f311f961ee77640f5408b451b984774e107d49410dd7b458b088
diff --git a/app-arch/wimlib/wimlib-1.14.1.ebuild b/app-arch/wimlib/wimlib-1.14.1.ebuild
new file mode 100644
index 000000000000..aa43a0f710cc
--- /dev/null
+++ b/app-arch/wimlib/wimlib-1.14.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools pax-utils
+
+DESCRIPTION="The open source Windows Imaging (WIM) library"
+HOMEPAGE="https://wimlib.net"
+SRC_URI="https://wimlib.net/downloads/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3+ LGPL-3+ ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fuse iso ntfs test yasm"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:3 )
+ iso? (
+ app-arch/cabextract
+ app-cdr/cdrtools
+ )
+ ntfs? ( sys-fs/ntfs3g:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with ntfs ntfs-3g)
+ $(use_with fuse)
+ $(use_enable test test-support)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ pax-mark m "${S}"/.libs/wimlib-imagex
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}