summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
commit4a74938e510c0dad732ae4c48f815dd0f0cabb46 (patch)
treee8c52cd3619bba6cf0a5c367f6c9d2cff0ac9d80 /app-arch
parentebc282ef4dfa408accac685565b8ee5f6faec119 (diff)
gentoo auto-resync : 13:02:2023 - 08:16:09
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/Manifest.gzbin16873 -> 17039 bytes
-rw-r--r--app-arch/dtrx/Manifest4
-rw-r--r--app-arch/dtrx/dtrx-8.5.0.ebuild51
-rw-r--r--app-arch/dtrx/dtrx-9999.ebuild51
-rw-r--r--app-arch/dtrx/metadata.xml14
-rw-r--r--app-arch/xz-utils/Manifest6
-rw-r--r--app-arch/xz-utils/xz-utils-5.2.10.ebuild4
-rw-r--r--app-arch/xz-utils/xz-utils-5.4.1.ebuild2
-rw-r--r--app-arch/xz-utils/xz-utils-9999.ebuild2
9 files changed, 127 insertions, 7 deletions
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index 1f2f533a81f6..f91e63864d53 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ
diff --git a/app-arch/dtrx/Manifest b/app-arch/dtrx/Manifest
new file mode 100644
index 000000000000..03be70996ae4
--- /dev/null
+++ b/app-arch/dtrx/Manifest
@@ -0,0 +1,4 @@
+DIST dtrx-8.5.0.tar.gz 34061 BLAKE2B d8ecbd9f3594440656e40d811846dd302d271f189711176a406572871db69f98bb4fd81a76ebdce697faf8d56029f4dcf735d18795adf732809e6017a7395cf2 SHA512 0ef0c0c9c22d948f6a8ee801372605dae52f4f571a32bbaa180c2c1daab061d623119c91b745f6a86cd28d7d08cdb47029a4de38354bdb28c62acfab080cc0f1
+EBUILD dtrx-8.5.0.ebuild 1009 BLAKE2B c1de59269567d42d2c44e5c96627b52859f85a1569ef65c4e4f73eb2c1d22dbe4b9bdfb7b974ef94fe35bab55c5cf5863e7f412024445efe8c8ddf8e6c0ab719 SHA512 5303fca925198e6432a8673ca36b021cf1cd1d5e869d365d299be2551da430d8d395bdf8df3c8ac2637321c14bf17d327ec2d300c7d7fafbd58cfc0df68e1aa9
+EBUILD dtrx-9999.ebuild 1009 BLAKE2B c1de59269567d42d2c44e5c96627b52859f85a1569ef65c4e4f73eb2c1d22dbe4b9bdfb7b974ef94fe35bab55c5cf5863e7f412024445efe8c8ddf8e6c0ab719 SHA512 5303fca925198e6432a8673ca36b021cf1cd1d5e869d365d299be2551da430d8d395bdf8df3c8ac2637321c14bf17d327ec2d300c7d7fafbd58cfc0df68e1aa9
+MISC metadata.xml 439 BLAKE2B 7490943dfd8a50c9d0ba628b72b6e8367a148b942aba496744337559e1134e26bb1b8fc0741ac912607826b8084643a568198a578c95bc10315f868bcea7742a SHA512 69a3996fd3834a22f1a028873c1061cca325224cfdf321b4c01687d5099aff4e7ed6c601076eaca5b88affab20f0d46b921a13db838de7243d3973fe71a4ab42
diff --git a/app-arch/dtrx/dtrx-8.5.0.ebuild b/app-arch/dtrx/dtrx-8.5.0.ebuild
new file mode 100644
index 000000000000..03c4b8340d0c
--- /dev/null
+++ b/app-arch/dtrx/dtrx-8.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Do The Right eXtraction - extracts archives of different formats"
+HOMEPAGE="https://github.com/dtrx-py/dtrx/
+ https://pypi.org/project/dtrx/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}-py/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+
+pkg_postinst() {
+ local supported_format
+ local -a supported_formats=(
+ arj
+ bzip2
+ cpio
+ gzip
+ lrzip
+ lzip
+ p7zip
+ rpm
+ unrar
+ unzip
+ xz-utils
+ zip
+ zstd
+ )
+
+ for supported_format in ${supported_formats[@]}; do
+ optfeature \
+ "extraction of supported archives using ${supported_format}" \
+ app-arch/${supported_format}
+ done
+}
diff --git a/app-arch/dtrx/dtrx-9999.ebuild b/app-arch/dtrx/dtrx-9999.ebuild
new file mode 100644
index 000000000000..03c4b8340d0c
--- /dev/null
+++ b/app-arch/dtrx/dtrx-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Do The Right eXtraction - extracts archives of different formats"
+HOMEPAGE="https://github.com/dtrx-py/dtrx/
+ https://pypi.org/project/dtrx/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}-py/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+
+pkg_postinst() {
+ local supported_format
+ local -a supported_formats=(
+ arj
+ bzip2
+ cpio
+ gzip
+ lrzip
+ lzip
+ p7zip
+ rpm
+ unrar
+ unzip
+ xz-utils
+ zip
+ zstd
+ )
+
+ for supported_format in ${supported_formats[@]}; do
+ optfeature \
+ "extraction of supported archives using ${supported_format}" \
+ app-arch/${supported_format}
+ done
+}
diff --git a/app-arch/dtrx/metadata.xml b/app-arch/dtrx/metadata.xml
new file mode 100644
index 000000000000..ed325e58479b
--- /dev/null
+++ b/app-arch/dtrx/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/dtrx-py/dtrx/issues/</bugs-to>
+ <remote-id type="github">dtrx-py/dtrx</remote-id>
+ <remote-id type="pypi">dtrx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/xz-utils/Manifest b/app-arch/xz-utils/Manifest
index b169c0529c81..8de838e8544f 100644
--- a/app-arch/xz-utils/Manifest
+++ b/app-arch/xz-utils/Manifest
@@ -2,7 +2,7 @@ DIST xz-5.2.10.tar.gz 2123206 BLAKE2B fdd9e77e21ee65482401e0e43e0b291093a227d452
DIST xz-5.2.10.tar.gz.sig 566 BLAKE2B ce72730816d03084dc0d1559d6f2890b3ebe25a5e6b0720d4775ba2364762b5d1934a3a53f2255f6e68a1cdf42778d85d8b02ab30396b2addab619e95855f733 SHA512 48a0864abee6639116678afab6e8319eb2de903b381362c611fb77f9b6fc21df5f7d9783a250810f7ecc08380fb371a3a791ab55f5a343b68b9d4f9e414da403
DIST xz-5.4.1.tar.gz 2528617 BLAKE2B f4dc8698fb97002aa0548107b448ab0dd8659cce506a83775930f95fd775601f7de1df44866310ac617853410a1915cd4e90ad4088b2fd56418e67b6f0fc4e98 SHA512 5cff8383a68fb88ecbb3770ec48af0ad5582e08de9dccd339e0b685aaa53447e59d6425caa3f63b54a674e5d78c20520876db547d156e6658ad4841660cba85b
DIST xz-5.4.1.tar.gz.sig 566 BLAKE2B f384bcf7ea6bd7d3af65b6b17b379b48826257f403bca0bed1b42697f88edbc38f38eaac03c5564fc466df670f40e2e7ee49974232da4eb849718e89234c224b SHA512 2e6c3bf04ceb29c1bac8fdde7aa09c4d0f96442515d797e06ea860f365fd94777630b0034b98006cf844083efea8642a0bf87b1ff56de6a58446a644b1fd3c1c
-EBUILD xz-utils-5.2.10.ebuild 2894 BLAKE2B 3516bd558ae5bd8bb752854c96264c70764e47b6bcaf185826edb5c18199e67589c0ab3b8c866f5858a6aff902375a69fcfefc198305555a482730db5cacc256 SHA512 e3a8d3305f17d3a183ebf8c111b3631cbdb4fedca6e19d7a47c09371c66cf329b5d390722709d840134b2343e83b427d79baceffd8d97c6ad05a990d337165e2
-EBUILD xz-utils-5.4.1.ebuild 3090 BLAKE2B c800425a52bbbe8b26ae77dfa2f2a02f0854418d6997ec5b82ac3b1e8135f0220a23cf18096486b6adccfec3484b176bbf7653bfdf0131e61348639c03db4e47 SHA512 d30f57566e72f4093a67c5709d65c1655735fe7015b26a4f805da45448a31316efde0209ea8de2a797beae3b0fb03348ddd0a347b090150d6edd5e872dae27bd
-EBUILD xz-utils-9999.ebuild 3098 BLAKE2B 81ecaf3cd48ae89cf35fc0260659b4a72409eeadb7b48823c4ae8169966e75e116125b11cd1f3a2aa766b1dfce19bc8cb616574fe28beaf3810e716dd223ab76 SHA512 75c122415323c4f61014ad428e43ada3363b9442fe7ca1085667403c01c5264b98f216a95cbcd09391e92281f1475febb82e995e2fd43ba7ea2fc776acd22b51
+EBUILD xz-utils-5.2.10.ebuild 2905 BLAKE2B 81f4972db6afb46bbb251ae7c65686564c2dbf3bd27b585f8cc7527fffd7b752f020a4c96d2da772a6ea74493f0aa5a5e335f03a1478e8bed77d587bc2f0f00f SHA512 0ca0295c0072943b44714f63ce2a69e12329cf6c157641afb6ee75f678cd9d23b46aac97248c53676d97996623fe6f4fe5f7a207f9d3cef794652d5c80a66b36
+EBUILD xz-utils-5.4.1.ebuild 3101 BLAKE2B 9b077244b3bf8213127630be4631c0ea9848b9024d840163fc32381a155cc69a8f1f6318453654fea924838c0ad82bf14b03671ec6b492d81ee479adf94e3491 SHA512 0ff92c6688f8b544c7bb76d5043c96ec85594de145a82e0f5ccc021184fa724221feddc9d93dde886610327bd8667411d9a13fad90fcd3284f05c2ff6497eee1
+EBUILD xz-utils-9999.ebuild 3109 BLAKE2B 70874f8d2ef1507c9d1874ba122526ba204f3375bb0536844ade93baced14dd5c59f514edf373fc6941c11364945ab313dfeecd277e1f5fba357397e89952763 SHA512 f841ba60185ad23da3adb549f0a37ea905e971e95e82768b70f297f343d2e35e3e0620fddd16ef7ea14a7386188b33efebf0fad016cce63f79481de0d269405f
MISC metadata.xml 663 BLAKE2B 7a6625813cb3bdbab8a37845c9c64ac53ff377db394f776357d4fff60fbfe7c7b0e954fdc15abcc8874dd6c0f9ee90bc6e179a00bc5d12cd2e7cedc6f998c019 SHA512 696e573853d5d401f22079492d8e2b5f3c27e9ec4b6095f5ff46f109366b1c65c11976123abed06f302b8f03aaa1b0c54884f0156fdfdce23f4bf28feaafd39c
diff --git a/app-arch/xz-utils/xz-utils-5.2.10.ebuild b/app-arch/xz-utils/xz-utils-5.2.10.ebuild
index fb35eaff7363..b7ac59e5664e 100644
--- a/app-arch/xz-utils/xz-utils-5.2.10.ebuild
+++ b/app-arch/xz-utils/xz-utils-5.2.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Remember: we cannot leverage autotools in this ebuild in order
@@ -43,7 +43,7 @@ SLOT="0"
IUSE="+extra-filters nls static-libs"
if [[ ${PV} != 9999 ]] ; then
- BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-lassecollin )"
+ BDEPEND+=" verify-sig? ( >=sec-keys/openpgp-keys-lassecollin-20230213 )"
fi
# Tests currently do not account for smaller feature set
diff --git a/app-arch/xz-utils/xz-utils-5.4.1.ebuild b/app-arch/xz-utils/xz-utils-5.4.1.ebuild
index 9aa96a389d3e..a207c01d98f6 100644
--- a/app-arch/xz-utils/xz-utils-5.4.1.ebuild
+++ b/app-arch/xz-utils/xz-utils-5.4.1.ebuild
@@ -50,7 +50,7 @@ SLOT="0"
IUSE="+extra-filters nls static-libs"
if [[ ${PV} != 9999 ]] ; then
- BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-lassecollin )"
+ BDEPEND+=" verify-sig? ( >=sec-keys/openpgp-keys-lassecollin-20230213 )"
fi
src_prepare() {
diff --git a/app-arch/xz-utils/xz-utils-9999.ebuild b/app-arch/xz-utils/xz-utils-9999.ebuild
index cb694cd99a4a..850c3073746f 100644
--- a/app-arch/xz-utils/xz-utils-9999.ebuild
+++ b/app-arch/xz-utils/xz-utils-9999.ebuild
@@ -50,7 +50,7 @@ SLOT="0"
IUSE="+extra-filters nls static-libs"
if [[ ${PV} != 9999 ]] ; then
- BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-lassecollin )"
+ BDEPEND+=" verify-sig? ( >=sec-keys/openpgp-keys-lassecollin-20230213 )"
fi
src_prepare() {