summaryrefslogtreecommitdiff
path: root/app-arch/zchunk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-07 17:57:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-07 17:57:54 +0000
commitbc75b42f7650c33ffdb61e5e29b0b96cb9111932 (patch)
tree867908c0cf83e6015a5b1544cfdc4e17f1c13753 /app-arch/zchunk
parentb3fef92e618039dc93153a93176184a49606c74a (diff)
gentoo auto-resync : 07:03:2023 - 17:57:54
Diffstat (limited to 'app-arch/zchunk')
-rw-r--r--app-arch/zchunk/Manifest4
-rw-r--r--app-arch/zchunk/metadata.xml15
-rw-r--r--app-arch/zchunk/zchunk-1.2.3.ebuild27
-rw-r--r--app-arch/zchunk/zchunk-9999.ebuild27
4 files changed, 73 insertions, 0 deletions
diff --git a/app-arch/zchunk/Manifest b/app-arch/zchunk/Manifest
new file mode 100644
index 000000000000..a508eb4c20ba
--- /dev/null
+++ b/app-arch/zchunk/Manifest
@@ -0,0 +1,4 @@
+DIST zchunk-1.2.3.tar.gz 1508271 BLAKE2B 7432289f3730083d0634c32f03d1daf2570c21e94ebab0aabeee4527f7ba56aef5cc567dfdb8ede701bea5d0cda4f248f0cf0fdb04e4f5ee1effb888a2907ec9 SHA512 5e46d8c3e36034de8424937cdfac59acdfaf332203e6e5d8b290614cbbe0340998d53b0583b0ef93189f41dc89219a75f50572757ebcea9abd83bd9aad861a73
+EBUILD zchunk-1.2.3.ebuild 569 BLAKE2B c9681269bf4802fb0a1018ecd814b2f6c8da2e747d0e7c10a99f7e0b0963fa82a2688a162e6b96375f1311e5d80ee6c69ccc151e8253386a2b802fadb7ef660d SHA512 938f2e7e8a190708900e4dc74691453902f9332d82bb8445f05ee7d2c20c6d7c155d2903b6c425d0ec5d72fc87a39a0b643700cfb79d0e7a24b2f355f19acf92
+EBUILD zchunk-9999.ebuild 569 BLAKE2B c9681269bf4802fb0a1018ecd814b2f6c8da2e747d0e7c10a99f7e0b0963fa82a2688a162e6b96375f1311e5d80ee6c69ccc151e8253386a2b802fadb7ef660d SHA512 938f2e7e8a190708900e4dc74691453902f9332d82bb8445f05ee7d2c20c6d7c155d2903b6c425d0ec5d72fc87a39a0b643700cfb79d0e7a24b2f355f19acf92
+MISC metadata.xml 481 BLAKE2B f6888c5e64deafa0b7f52a0f1b4c611c610108d91b7f8fd831f49ebc5fe67e5fae1c57e7bef2c1a51510b9beab33ace6aaa25bf6f88ce0d10f39d7c8479b7d06 SHA512 16d3ff19941ec61f62377ea01af9cfa0bc428e05f21610105ab02b3f9ad9464a28e74f2709249014f1720e7c2dd13cc8b3b7d02a880d8a785231af29d7e7b5c2
diff --git a/app-arch/zchunk/metadata.xml b/app-arch/zchunk/metadata.xml
new file mode 100644
index 000000000000..40e1e399be6c
--- /dev/null
+++ b/app-arch/zchunk/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zchunk/zchunk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/zchunk/zchunk-1.2.3.ebuild b/app-arch/zchunk/zchunk-1.2.3.ebuild
new file mode 100644
index 000000000000..76677dce82f5
--- /dev/null
+++ b/app-arch/zchunk/zchunk-1.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="File format designed for highly efficient deltas with good compression"
+HOMEPAGE="https://github.com/zchunk/zchunk"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zchunk/zchunk.git"
+else
+ SRC_URI="https://github.com/zchunk/zchunk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+DEPEND="
+ app-arch/zstd:=
+ net-misc/curl
+ dev-libs/openssl:=
+"
+RDEPEND="${DEPEND}"
diff --git a/app-arch/zchunk/zchunk-9999.ebuild b/app-arch/zchunk/zchunk-9999.ebuild
new file mode 100644
index 000000000000..76677dce82f5
--- /dev/null
+++ b/app-arch/zchunk/zchunk-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="File format designed for highly efficient deltas with good compression"
+HOMEPAGE="https://github.com/zchunk/zchunk"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zchunk/zchunk.git"
+else
+ SRC_URI="https://github.com/zchunk/zchunk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+DEPEND="
+ app-arch/zstd:=
+ net-misc/curl
+ dev-libs/openssl:=
+"
+RDEPEND="${DEPEND}"