summaryrefslogtreecommitdiff
path: root/app-arch/xdms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/xdms
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/xdms')
-rw-r--r--app-arch/xdms/Manifest3
-rw-r--r--app-arch/xdms/metadata.xml12
-rw-r--r--app-arch/xdms/xdms-1.3.2-r1.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/app-arch/xdms/Manifest b/app-arch/xdms/Manifest
new file mode 100644
index 000000000000..f85402ae285d
--- /dev/null
+++ b/app-arch/xdms/Manifest
@@ -0,0 +1,3 @@
+DIST xdms-1.3.2.tar.bz2 43010 BLAKE2B 97118ce2052a93e334b02d1687e4c867f7158bdd99bfc4249a7a22d1eee57c6d6bbb26c640f0bdb61004997fcb6218724de40c759ae51f4b72da8dee0ebde48d SHA512 e29dd1d2373c635ba953ef526849e0b8fa645a0da91fff3a3512ce26eee43fb2c1280f27fae0a42a4fd47106494d6e44c5684eff3581661e538780927b851cac
+EBUILD xdms-1.3.2-r1.ebuild 657 BLAKE2B c6ea38fd2d477e585b6107a9f13b3a7200fa17b1f76e3fbe4ff18ace24017d63207c39c76e1364550c76b51faddd04bb2a1e40702eec4fa578ade1ea60cd7a41 SHA512 3ef03aac116b55f27d6b2251108da74671c0eba85ddf19c9b10b57b0fb13f58a0f00120015be1cb80e9b024bf88e1fb0fbe6a3dc96376b82dd70db5da7df8f1d
+MISC metadata.xml 864 BLAKE2B 209b2fd1290a35b6d372b5725bd9d297a2d9b86a56bc45bdfd725e81399f004ac6d4de87386d883e921bc6a34d2e45797d029d71ec317f7c3930a4d7faf991f6 SHA512 a535abd221a7ea350cfeb4fbb84585cc4f4d6ee83f607ae5d0eee73a709b8df5ed3cf9b3056dbd6b8a68ff06353c5c8b407f322a06a3bbeb5fe3d6d0cea4cdba
diff --git a/app-arch/xdms/metadata.xml b/app-arch/xdms/metadata.xml
new file mode 100644
index 000000000000..ec5a204b1712
--- /dev/null
+++ b/app-arch/xdms/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ Supports decompression of files compressed using all known DMS compression modes, including old and obsolete ones, and also encrypted files, for 100% compatibility.
+ Can test DMS files integrity, view file informations and show attached Banners and FILEID.DIZ .
+ Can generate standard disk images and compressed disk images, using gzip, if you want to store your files in ADF or ADZ formats.
+ Can extract the files contained inside the DMS archives, if the compressed disk is an AmigaDOS disk, using readdisk made by Bernd Schmidt.
+ Can process multiple files in batch with a single command, and also use stdin and stdout for input and output of data.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-arch/xdms/xdms-1.3.2-r1.ebuild b/app-arch/xdms/xdms-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..1282999e0237
--- /dev/null
+++ b/app-arch/xdms/xdms-1.3.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="xDMS - Amiga DMS disk image decompressor"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/xdms"
+SRC_URI="http://zakalwe.fi/~shd/foss/xdms/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86"
+IUSE=""
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+ sed -i Makefile.in \
+ -e "s:COPYING::" \
+ -e "s:share/doc/xdms-{VERSION}:share/doc/xdms-${PF}:" || die
+ sed -i -e "s:-O2::" src/Makefile.in || die
+}
+
+src_configure() {
+ ./configure --prefix=/usr --package-prefix="${D}" || die
+}