summaryrefslogtreecommitdiff
path: root/app-arch/xar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /app-arch/xar
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'app-arch/xar')
-rw-r--r--app-arch/xar/Manifest1
-rw-r--r--app-arch/xar/xar-1.8-r4.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-arch/xar/Manifest b/app-arch/xar/Manifest
index 76838ca079c6..9980440659c0 100644
--- a/app-arch/xar/Manifest
+++ b/app-arch/xar/Manifest
@@ -6,4 +6,5 @@ DIST xar-400.tar.gz 213319 BLAKE2B 55b8695313a1a5ae778b62791f716af00edba7e7b0150
DIST xar-417.1.tar.gz 219350 BLAKE2B 2ca073e52b8d7a12c3d33fb65ccaf0984b912f42e4e9dc52bcaec7af41bafcc530cd055da16646113fb24ee046122425a66351f88279ef79a0f0b2b04ae51f9a SHA512 4c3c61f5289d0b2e380cbde772b383da369ca8ad046f5d779e02f59300288c90c5e31d105a2c01ac17dc719b8b46b55d8d36a8b3b20360f315766fce92dec762
EBUILD xar-1.8-r2.ebuild 1458 BLAKE2B 555288ffa046e123dd907ffc82149fcb8475d8e0523832843ada29a45e0a93e54c231d1ffc0fd0f34a11ca19456c38299a92c631ca07e521146c2408a625968a SHA512 56560c834837cc754a67b75a62e6a6d55e66e01e529013b418371dd241572b0cba263ed259750c2f4864eece26bb2d2de4d4925e575bceaf859b7f06b20890f7
EBUILD xar-1.8-r3.ebuild 2008 BLAKE2B 8c75abf68299e7f82df130cff852346dbabd599b5fe65dcec09d57902cce9ce587d98a3731ca3011ae64d78d0c77919cbaaf84a8b50cafe52728fd04596d2ba1 SHA512 95fd1cefb6f5d117ce6abb5ca6c27d55a9c61186c570e8dbb7b9efe289f1c57a12e605153a235279c700b2a9d7c53393c80be86d5d9a72f97743264aba50f4df
+EBUILD xar-1.8-r4.ebuild 2460 BLAKE2B d1a502c4d69ed2fa1a63a056fb080122deac98861067e0712daac8e55c287bd3a1701c580a5b4acd1bf4ab52721a50bbba50d9a8aaed01687899d1161634bedf SHA512 39cdca2fe8601eaddd1a10e116216cbbb0cafa197058222ffb4b8d060b6cae34432b19f9f2723e5fdd7b4d2afb90e005767e461dcaef557e07a1e9363f50517c
MISC metadata.xml 895 BLAKE2B 7e901c1e2689bc8a94d60eb5ccb993775a7973697320dcd647bd4b3e3e13a4350cd3b1c033a176f2bec7c41bd67a5266ad87b8d3d1a9c5d1bbbceb29726c9226 SHA512 6b0ffedc678b52c23489465ab7267308210d1971ab8aca62471b3a58331bc1c7ff6f8fae9dbb27a7d597aa44b90dc4ff4eac2ef27f726a397aa1ec625d9463f1
diff --git a/app-arch/xar/xar-1.8-r4.ebuild b/app-arch/xar/xar-1.8-r4.ebuild
new file mode 100644
index 000000000000..6106c668f823
--- /dev/null
+++ b/app-arch/xar/xar-1.8-r4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic multilib-minimal multilib
+
+APPLE_PV=417.1
+DESCRIPTION="An easily extensible archive format"
+HOMEPAGE="https://opensource.apple.com/source/xar/"
+SRC_URI="https://opensource.apple.com/tarballs/xar/xar-${APPLE_PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl"
+
+DEPEND="
+ elibc_musl? ( sys-libs/fts-standalone )
+ kernel_linux? ( virtual/acl )
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ app-arch/bzip2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-ext2.patch
+ "${FILESDIR}"/${PN}-1.8-safe_dirname.patch
+ "${FILESDIR}"/${PN}-1.8-arm-ppc.patch
+ "${FILESDIR}"/${PN}-1.8-openssl-1.1.patch
+)
+
+S=${WORKDIR}/${PN}-${APPLE_PV}/${PN}
+
+src_prepare() {
+ default
+
+ # make lib headers available (without installing first?)
+ cd "${S}"/include || die
+ mv ../lib/*.h . || die
+
+ # strip RPATH pointing to ED
+ cd "${S}"/src || die
+ sed -i -e 's/@RPATH@//' Makefile.inc.in || die
+
+ # avoid GNU make (bug?) behaviour of removing xar.o as intermediate
+ # file, this doesn't happen outside portage, but it does from the
+ # ebuild env, causing the install phase to re-compile xar.o and link
+ # the executable
+ echo ".PRECIOUS: @objroot@src/%.o" >> Makefile.inc.in || die
+
+ # drop Darwin specific reliance on CommonCrypto Framework, for it
+ # depends on what version of Darwin we're on, and it is much simpler
+ # to just use open/libressl instead, which we maintain and control
+ cd "${S}" || die
+ sed -i -e 's/__APPLE__/__NO_APPLE__/' \
+ include/archive.h \
+ lib/hash.c \
+ || die
+
+ # fix branding somewhat
+ sed -i -e "/XAR_VERSION/s|%s|%s (Gentoo ${PVR})|" src/xar.c || die
+}
+
+multilib_src_configure() {
+ append-libs $(pkg-config --libs openssl)
+ use elibc_musl && append-libs $(pkg-config --libs fts-standalone)
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static
+ # botched check, fix it up
+ if use kernel_SunOS ; then
+ sed -i -e '/HAVE_SYS_ACL_H/s:^\(.*\)$:/* \1 */:' include/config.h || die
+ fi
+}
+
+multilib_src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}