summaryrefslogtreecommitdiff
path: root/app-arch/wimlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/wimlib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/wimlib')
-rw-r--r--app-arch/wimlib/Manifest3
-rw-r--r--app-arch/wimlib/metadata.xml24
-rw-r--r--app-arch/wimlib/wimlib-1.12.0.ebuild66
3 files changed, 93 insertions, 0 deletions
diff --git a/app-arch/wimlib/Manifest b/app-arch/wimlib/Manifest
new file mode 100644
index 000000000000..bfe18a68ffd7
--- /dev/null
+++ b/app-arch/wimlib/Manifest
@@ -0,0 +1,3 @@
+DIST wimlib-1.12.0.tar.gz 1014508 BLAKE2B d12f4e0b458fe756b74c67f2f643256c44021e0f0c3e2a3a70eb87647c3c6cabd93413917bf8a8c6ab6820860c407f4454454719227f5cbf1a9a81a7bedc1a6e SHA512 0343b37550366f07fd6a6689f4445f390187beddde677f4d6d831c07936d03b613ae95f612ec7a75e978a5e678f33ab766d0f3b3d942886df56e4ef77d4b07b9
+EBUILD wimlib-1.12.0.ebuild 1410 BLAKE2B e8cd8d59c7535051260d2700f25dbcee7daeefaf400fde7b86e2e7d9ae076516251882486ba0a3b8997aa5f11371e72ba8dff681a0f4205afc7d39909fe3fe59 SHA512 fab7e339cc5291fe20d34edb2d0a6054aec70c49e33d8c2a5b28499968b5074a4b02618a05b1127551acea6ed360caa5edb405dc351bda71b230817b9b38c1eb
+MISC metadata.xml 684 BLAKE2B bc45d2b67f015842912d4fa5043bf31f2eb2ae59b29a9104987c6041282730491470fefd065be7ab49de230ea26dc10f64d4fd85591a1df6aec5a6ab408752dd SHA512 999d8b7bd11c22193d1e87e73b70fd750404e92c26b7916a4405c0bdd930a103ef8b809259e0c3ddfb73281f2622b284bd20ea73dff409cc8063406cf41a7724
diff --git a/app-arch/wimlib/metadata.xml b/app-arch/wimlib/metadata.xml
new file mode 100644
index 000000000000..0800647b3dbd
--- /dev/null
+++ b/app-arch/wimlib/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="fuse">
+ Use fuse libraries
+ </flag>
+ <flag name="iso">
+ Install app-cdr/cdrtools in order to prepare iso images
+ </flag>
+ <flag name="ntfs">
+ Use libntfs-3g library from sys-fs/ntfs3g
+ </flag>
+ <flag name="openssl">
+ Use the SHA-1 message digest from libcrypto instead of compilling another implementation
+ </flag>
+ <flag name="yasm">
+ Use yasm assembler instead of nasm
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/app-arch/wimlib/wimlib-1.12.0.ebuild b/app-arch/wimlib/wimlib-1.12.0.ebuild
new file mode 100644
index 000000000000..efc6d34190b6
--- /dev/null
+++ b/app-arch/wimlib/wimlib-1.12.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools pax-utils
+if [[ -z ${PV%%*9999} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://wimlib.net/${PN}"
+else
+ inherit vcs-snapshot
+ MY_PV="${PV/_/-}"
+ MY_PV="${MY_PV^^}"
+ SRC_URI="https://wimlib.net/downloads/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+ RESTRICT="primaryuri"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="The open source Windows Imaging (WIM) library"
+HOMEPAGE="https://wimlib.net/"
+
+LICENSE="|| ( GPL-3+ LGPL-3+ ) CC0-1.0"
+SLOT="0"
+IUSE="cpu_flags_x86_ssse3 fuse iso ntfs openssl threads yasm"
+REQUIRED_USE="cpu_flags_x86_ssse3? ( !openssl )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ ntfs? ( sys-fs/ntfs3g )
+ fuse? ( sys-fs/fuse:0 )
+ openssl? ( dev-libs/openssl:0 )
+ iso? (
+ app-arch/cabextract
+ app-cdr/cdrtools
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ cpu_flags_x86_ssse3? (
+ yasm? ( dev-lang/yasm )
+ !yasm? ( dev-lang/nasm )
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with ntfs ntfs-3g)
+ $(use_with fuse)
+ $(use_enable cpu_flags_x86_ssse3 ssse3-sha1)
+ $(use_with openssl libcrypto)
+ $(use_enable threads multithreaded-compression)
+ )
+ has test ${FEATURES} && myeconfargs+=( --enable-test-support )
+ ac_cv_prog_NASM="$(usex yasm yasm nasm)" \
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ pax-mark m "${S}"/.libs/wimlib-imagex
+}