summaryrefslogtreecommitdiff
path: root/app-arch/vimball
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/vimball
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/vimball')
-rw-r--r--app-arch/vimball/Manifest4
-rw-r--r--app-arch/vimball/metadata.xml12
-rw-r--r--app-arch/vimball/vimball-0.5.1.ebuild29
-rw-r--r--app-arch/vimball/vimball-9999.ebuild29
4 files changed, 74 insertions, 0 deletions
diff --git a/app-arch/vimball/Manifest b/app-arch/vimball/Manifest
new file mode 100644
index 000000000000..fa1d11e654b3
--- /dev/null
+++ b/app-arch/vimball/Manifest
@@ -0,0 +1,4 @@
+DIST vimball-0.5.1.tar.gz 5246 BLAKE2B 8ce95bfe8872f69e501b4453e5a6644d8019367173f8675325775dee58e08618b9ec0908bca9df04839bc165b086d8e5195a0753827d6038d8ccd8adbab80c35 SHA512 f89ba7291e3f4146f2ada7934b0ca74524abc639e586da12e19882e9aebe3f14858a6145b830a32dc19b0deb61f652375d8a56dc7847fd0061d14a2d77208549
+EBUILD vimball-0.5.1.ebuild 658 BLAKE2B ac4d3538759811de18516547558cc950907734f465abbbf43ee5335fc84174e69a8bf50213dea74f71ac72e73f0471d984643f805877f32666fc29d23c52d8cc SHA512 418b0ba38bc2f613c5ac8b6b008a9f07c0a55964fe106cc762b1937aae25792cea238eb49b729ee970dd27c0f84813b08b67dd3c25c1bc8f8f53a0cf02787738
+EBUILD vimball-9999.ebuild 658 BLAKE2B 64f54e6db0d0966ecffb54867ba699172f4da2f45418b30bbe44ac3880ee9e6d6eda1afc2912a393e2a35443f75d6c63196351594554ea6c69d0282e8202f723 SHA512 8b35615ce1cddeefb6b84c68d1dcc308e525883203d0fd08a5aef40f76578ae0b7ddbbb7b69f2f84cc542a1bf6fc9b2ee4d0b60596d0630f57d31054e83bc5c5
+MISC metadata.xml 385 BLAKE2B 5fa1db1263983a5d57031cb72bf9e2b7074faf2134bea6a8cc02d67f9e48ce198c2a8d4a478029d9e3303555c9d248f96e83e6e8071ea7b055f90bb25d38402c SHA512 7086cce11a9a20d93dd24741e060d289c90bbc3c20d5102452d4c987597921b00195badd68d916a64b03faa5dae1fa4adb68654bce5c70c2e1cfa5d8417b33c3
diff --git a/app-arch/vimball/metadata.xml b/app-arch/vimball/metadata.xml
new file mode 100644
index 000000000000..d32fca1cb55b
--- /dev/null
+++ b/app-arch/vimball/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">vimball</remote-id>
+ <remote-id type="github">radhermit/vimball</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/vimball/vimball-0.5.1.ebuild b/app-arch/vimball/vimball-0.5.1.ebuild
new file mode 100644
index 000000000000..9876af4ce01e
--- /dev/null
+++ b/app-arch/vimball/vimball-0.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/radhermit/vimball.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a command-line vimball archive extractor"
+HOMEPAGE="https://github.com/radhermit/vimball"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
diff --git a/app-arch/vimball/vimball-9999.ebuild b/app-arch/vimball/vimball-9999.ebuild
new file mode 100644
index 000000000000..b24f9bccd79f
--- /dev/null
+++ b/app-arch/vimball/vimball-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/radhermit/vimball.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a command-line vimball archive extractor"
+HOMEPAGE="https://github.com/radhermit/vimball"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}