summaryrefslogtreecommitdiff
path: root/app-arch/upx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /app-arch/upx
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'app-arch/upx')
-rw-r--r--app-arch/upx/Manifest3
-rw-r--r--app-arch/upx/metadata.xml16
-rw-r--r--app-arch/upx/upx-3.95.ebuild34
3 files changed, 53 insertions, 0 deletions
diff --git a/app-arch/upx/Manifest b/app-arch/upx/Manifest
new file mode 100644
index 000000000000..6ae8400a5453
--- /dev/null
+++ b/app-arch/upx/Manifest
@@ -0,0 +1,3 @@
+DIST upx-3.95-src.tar.xz 790776 BLAKE2B e7e5e24ba3675ab9f9f3daa36d6d3f00b6af614c2ca64c4d185a065afcdc02373ccf0200f7116ebbfaa1f9b961078f40296b1c716eca80aba86e95d6a9463b99 SHA512 0e1d3e26462057f16587197e73301957e870107808fdbcd24d9976094dfa0e5efbe8da0f9b6732a99f05990dcd4be242a87ea19a7110dc052c6dc982cd596416
+EBUILD upx-3.95.ebuild 807 BLAKE2B 388441afc4a845b9528915a24c8999ba81af251534cefa3ddbd006bdbf1abb9476b536f2c7e857ead636965826d9006fcb29a4c3c27acbfd46401fdf3aef0c3f SHA512 a0884c0ca7e0501d968e364b6726fd4f3eda15bcea687bc77b1eb150da4f27bfc80cc152a0f55cc2223211d9ab81f8bc2f4f3499de5e62bec2860dc989f1720e
+MISC metadata.xml 556 BLAKE2B 79efa27ad3c90188372a09e32997f8e2a6259e546a91518c9b332f5b659f5d21bce26862a0a532a0b63e5fcba3efbb717a1518325184d7f931931a084cbd0396 SHA512 fa0d21d7f5c7b7cdecd54b9c438d1151af0baadb207297cfaa26d7f0230e538156561aeeccd50ef23b7060f6e7d653282a59fabaf6f866aca49cdf0970c35b36
diff --git a/app-arch/upx/metadata.xml b/app-arch/upx/metadata.xml
new file mode 100644
index 000000000000..97da883f8ae3
--- /dev/null
+++ b/app-arch/upx/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">upx/upx</remote-id>
+ </upstream>
+ <longdescription>UPX is a versatile executable packer with a excellent compression ratio</longdescription>
+</pkgmetadata>
diff --git a/app-arch/upx/upx-3.95.ebuild b/app-arch/upx/upx-3.95.ebuild
new file mode 100644
index 000000000000..f0ea16873abd
--- /dev/null
+++ b/app-arch/upx/upx-3.95.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="http://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/ucl-1.03
+ sys-libs/zlib
+ !app-arch/upx-bin"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${P}-src"
+
+src_compile() {
+ tc-export CXX
+ emake CXXFLAGS_WERROR="" all
+}
+
+src_install() {
+ newbin src/upx.out upx
+ dodoc BUGS NEWS PROJECTS README* THANKS doc/*.txt doc/upx.html
+ doman doc/upx.1
+}