summaryrefslogtreecommitdiff
path: root/app-arch/upx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-10 09:32:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-10 09:32:05 +0100
commitd087665a0d6764fc223d2f88a04db01d76af9cc0 (patch)
tree698510baa01e5c4c92f7867e40bed45acd5f4547 /app-arch/upx
parentd8e832445899a9a8ba4d8dc6f61f5feca79a3b85 (diff)
gentoo auto-resync : 10:08:2023 - 09:32:05
Diffstat (limited to 'app-arch/upx')
-rw-r--r--app-arch/upx/Manifest2
-rw-r--r--app-arch/upx/upx-4.1.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/upx/Manifest b/app-arch/upx/Manifest
index b3d92f0dedc3..68f903a87c42 100644
--- a/app-arch/upx/Manifest
+++ b/app-arch/upx/Manifest
@@ -1,3 +1,5 @@
DIST upx-4.0.2-src.tar.xz 1191960 BLAKE2B d1b111d886498628174653e2184bb648862986c6b65441a31ccbbd5360d9fd04d2d8b6cb276111cf4726f38aba0a3cd2c42b6fd62caba69a7996a4e59a5471ca SHA512 0aafbaf97a25e9cd1866d03358f5eceab2c0ba4b2f3acdd58178b41c32af58335b6cb843d83f3398d4ceedc238bfcd95f86a20c38a11d5e4e8af6a28c7e8b82e
+DIST upx-4.1.0-src.tar.xz 1267708 BLAKE2B ef7884028a97b1d7e542fc27756b705582786a22d193b1eef40d0db16580958baddc3baa44429b5ba2c0f7b5d4d0f4f79fdeb777af016b962b07c7639a319090 SHA512 de8306e833198d7f470c050b05c6111a50ea94f2e757c1006433742871ccd93fd7412f942cd776e9eac6c91e379545d72f070f3fe928e75e5d5092b766474f8c
EBUILD upx-4.0.2.ebuild 748 BLAKE2B e4562c894bd26240bb21dc4e579aa56c9c6bf27ef1fd00b6c30da6739cea4458a9de9154a7b1bcf5efa4f5fbd01fe595126f48f593ea2c8b336cc1cec84b3343 SHA512 93e947ff8f3794c0e61637e2587dc9acba3ce6f27024c8f1e9729fa4f915eec7467a62a70694c3d23fb2dbc10e9f5f115cbe9831899df2b77ecc8d4fffec15a6
+EBUILD upx-4.1.0.ebuild 750 BLAKE2B 4524774a64d4d3521ef8ba64473946c06fbf634a92d89fe3384deba61cf1590f20bc909820753f9777ed35a0c50710a22b8c3c50046d1df56e8c1815f3d96a6a SHA512 9aa14d940c7faa895bd377e8cf22ea561fea8bda67e39bbd9a1f86a1ebbb8bed1fbe1d8bcffa125636d15d7df7f1c0a48b011b3ab75f85a48aa20abd6167ed0b
MISC metadata.xml 479 BLAKE2B fafbeeb827ba16ec14c3682982e7cbb1ef9264b637086d58aca32a632b1f273f1cc7ede069d61439a498f04e09368e4095829de7dd95b17afafc80f7ceb15695 SHA512 956e31235fec93e773f9bdbe62de739e3994d92b3a56ea97f65db5b20f182f4fbeed62370a28bf98447fddfa89efec4b8b4d63daf9020210810bd8bb201534e4
diff --git a/app-arch/upx/upx-4.1.0.ebuild b/app-arch/upx/upx-4.1.0.ebuild
new file mode 100644
index 000000000000..e6cb58a6ff24
--- /dev/null
+++ b/app-arch/upx/upx-4.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="https://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+S="${WORKDIR}/${P}-src"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="!app-arch/upx-bin"
+BDEPEND="app-arch/xz-utils[extra-filters]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUPX_CONFIG_DISABLE_WERROR=ON
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Don't run tests in parallel, #878977
+ cmake_src_test -j1
+}