summaryrefslogtreecommitdiff
path: root/app-arch/upx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-28 13:19:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-28 13:19:25 +0000
commit7f273220431bac2cbbe19e52f95a2d33b16e66b4 (patch)
tree5dec949a6ca04a290db44192ef0d5681b4bc3ace /app-arch/upx
parentc1cdf388025eed22cca32ace0115377d0026e712 (diff)
gentoo auto-resync : 28:11:2022 - 13:19:24
Diffstat (limited to 'app-arch/upx')
-rw-r--r--app-arch/upx/Manifest2
-rw-r--r--app-arch/upx/upx-4.0.1.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/upx/Manifest b/app-arch/upx/Manifest
index ccf07a82949e..4ed7f0aeeac7 100644
--- a/app-arch/upx/Manifest
+++ b/app-arch/upx/Manifest
@@ -1,3 +1,5 @@
DIST upx-4.0.0-src.tar.xz 1159308 BLAKE2B d2626a63b626f9b4e913b822e699fa93b7080d322b19555d44d7cf4ce17b37f0d50ec1381d07d0e4f8827e8edcd29d525d497fa79acd18d520ac58e176fb2b72 SHA512 fe3e8c594e845a91338b1e11fe3cb6371430af40a567187d63835e27da8b2abf993a104b0693063f4db984234bada7b2bd16ad79e3ad90861a1f495d99de7de6
+DIST upx-4.0.1-src.tar.xz 1154032 BLAKE2B 0da23cedf73506e06e5dcf19ab0d194d8e578188bb4d75e760fe3f7dc7f24a9d42ff4b75fd9514162f48ae7cfad347b5bd65789805071354a74129960807843b SHA512 f2e42c83fd4a0d273a20c8b0f0d1eb201edcd1f10c779d2a6e8ac0812741c3af0c887382e54894190ecc4c7002a910524b2ed79ae7a7b595b8392598ad2e1235
EBUILD upx-4.0.0.ebuild 651 BLAKE2B 79aca51cc6fa40e8a39fecd5d512cd191d9981c3e584ab18629c52253d036fd52802476f24060c40117273853d7862c6359c47d8da69732402c89cf2e7c07398 SHA512 168ee21480b5b065f0ec20b3a6916a479db25a358b4a7894d7bdccad4a2505fe12d975ee363b8a687fe0f395e5a07f12d3fc44eb0eacae5bbbe087cfbc4e259c
+EBUILD upx-4.0.1.ebuild 651 BLAKE2B 79aca51cc6fa40e8a39fecd5d512cd191d9981c3e584ab18629c52253d036fd52802476f24060c40117273853d7862c6359c47d8da69732402c89cf2e7c07398 SHA512 168ee21480b5b065f0ec20b3a6916a479db25a358b4a7894d7bdccad4a2505fe12d975ee363b8a687fe0f395e5a07f12d3fc44eb0eacae5bbbe087cfbc4e259c
MISC metadata.xml 479 BLAKE2B fafbeeb827ba16ec14c3682982e7cbb1ef9264b637086d58aca32a632b1f273f1cc7ede069d61439a498f04e09368e4095829de7dd95b17afafc80f7ceb15695 SHA512 956e31235fec93e773f9bdbe62de739e3994d92b3a56ea97f65db5b20f182f4fbeed62370a28bf98447fddfa89efec4b8b4d63daf9020210810bd8bb201534e4
diff --git a/app-arch/upx/upx-4.0.1.ebuild b/app-arch/upx/upx-4.0.1.ebuild
new file mode 100644
index 000000000000..04a011030c35
--- /dev/null
+++ b/app-arch/upx/upx-4.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="https://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+S="${WORKDIR}/${P}-src"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="!app-arch/upx-bin"
+BDEPEND="app-arch/xz-utils[extra-filters]"
+
+src_test() {
+ # Don't run tests in parallel, #878977
+ cmake_src_test -j1
+}