summaryrefslogtreecommitdiff
path: root/app-arch/upx-bin/upx-bin-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 02:22:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 02:22:31 +0000
commit3b32ae7547d742f6e65770361188670710bec186 (patch)
tree51b5a45e8291644df70197de17f086e1640e9c7e /app-arch/upx-bin/upx-bin-4.0.0.ebuild
parentdd03974882f85ca04e35cfbc97f7ff756f5d5c20 (diff)
gentoo auto-resync : 21:02:2023 - 02:22:31
Diffstat (limited to 'app-arch/upx-bin/upx-bin-4.0.0.ebuild')
-rw-r--r--app-arch/upx-bin/upx-bin-4.0.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-arch/upx-bin/upx-bin-4.0.0.ebuild b/app-arch/upx-bin/upx-bin-4.0.0.ebuild
deleted file mode 100644
index a6902194c16d..000000000000
--- a/app-arch/upx-bin/upx-bin-4.0.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit pax-utils
-
-MY_P="${PN/-bin}-${PV}"
-
-DESCRIPTION="Ultimate Packer for eXecutables, binary version with proprietary NRV compression"
-HOMEPAGE="https://upx.github.io/"
-SRC_URI="x86? ( https://github.com/upx/upx/releases/download/v${PV}/${MY_P}-i386_linux.tar.xz )
- amd64? ( https://github.com/upx/upx/releases/download/v${PV}/${MY_P}-amd64_linux.tar.xz )
- arm64? ( https://github.com/upx/upx/releases/download/v${PV}/${MY_P}-arm64_linux.tar.xz )
- arm? ( https://github.com/upx/upx/releases/download/v${PV}/${MY_P}-armeb_linux.tar.xz )
- mips? ( https://github.com/upx/upx/releases/download/v${PV}/${MY_P}-mipsel_linux.tar.xz )
- ppc? ( https://github.com/upx/upx/releases/download/v${PV}/${MY_P}-powerpc_linux.tar.xz )
- ppc64? ( https://github.com/upx/upx/releases/download/v${PV}/${MY_P}-powerpc64le_linux.tar.xz )"
-
-LICENSE="GPL-2+ UPX-exception"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
-RESTRICT="strip"
-
-RDEPEND="!app-arch/upx"
-BDEPEND="app-arch/xz-utils[extra-filters]"
-
-S="${WORKDIR}"
-
-QA_PREBUILT="/opt/bin/upx"
-
-src_install() {
- cd ${MY_P}* || die
- into /opt
- dobin upx
- pax-mark -m "${ED}"/opt/bin/upx
- doman upx.1
- dodoc NEWS README THANKS upx-doc.html upx-doc.txt
-}