summaryrefslogtreecommitdiff
path: root/app-arch/unrpa
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/unrpa
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/unrpa')
-rw-r--r--app-arch/unrpa/Manifest6
-rw-r--r--app-arch/unrpa/metadata.xml15
-rw-r--r--app-arch/unrpa/unrpa-1.4.1.ebuild30
-rw-r--r--app-arch/unrpa/unrpa-1.4.2.ebuild30
-rw-r--r--app-arch/unrpa/unrpa-9999.ebuild30
5 files changed, 111 insertions, 0 deletions
diff --git a/app-arch/unrpa/Manifest b/app-arch/unrpa/Manifest
new file mode 100644
index 000000000000..5af09a24c637
--- /dev/null
+++ b/app-arch/unrpa/Manifest
@@ -0,0 +1,6 @@
+DIST unrpa-1.4.1.tar.gz 14367 BLAKE2B 91e29a4867f8ae9901e5e06663cb8fb8cd1567e7efa4491d54d16aaa6bdcad4ec8314082b4dfff45a99727453b8f19f54df0f156a2194a0eaec35acfba4e6e01 SHA512 9b058adda9a39178950df4c39af40726cdca410f0fca699d0dec1bd5d7046c75c8811c8914c0c8756c29988b6362d3b4ad3756aa77f238eafb13d4414d3266cc
+DIST unrpa-1.4.2.tar.gz 14458 BLAKE2B eb3cf0a0501de06d264047e063805c45aca95a8fb0273ebae4fcefe4e7ab975db6f89123b60cfdc43063e38cfb974c8c8b950cb718ecd238bc4f7146832b2b29 SHA512 2608f4ec11540de1b14290ce1aaad6f06e8111a55b5c6a38c0c9e4d7228c04ccef480425f812a7cbc3913c0ed6865d0b63c8aa0d5ec9131495eab40bbdfcdcc5
+EBUILD unrpa-1.4.1.ebuild 635 BLAKE2B 33ee08b1dc4f669ce6bc553b006a0023e6b1906005a3fcb3c80f6cf6b6976770483b5ab8f2aaed024230df6f7a74a92ae68815676893f993df0176c8faf13ece SHA512 f902a1168f7043abebd81b68089bc32decfe21f624f09fcd07367360f65319d0f225fa6d05002307dfc4db195c6b3c9d5dca81da3b956611ce3531bf38d22ae2
+EBUILD unrpa-1.4.2.ebuild 649 BLAKE2B 41f929559103ea845f9d506b2d051633435ff30420c00b4c494df94a9c5e4fb82d9703a73f5fb820d01f4cdf30b3729b713c4c9a7af70ea4b6a28158a719f0de SHA512 7c14f5bb9a71dcf41307b368ee05a9ca8fe1d8c85ba16552ff5ee7eecce8704537c07b3213f78365c0f44b127d9a8ac4c89ab8ddb3652ded2890492b6244b1a3
+EBUILD unrpa-9999.ebuild 649 BLAKE2B 41f929559103ea845f9d506b2d051633435ff30420c00b4c494df94a9c5e4fb82d9703a73f5fb820d01f4cdf30b3729b713c4c9a7af70ea4b6a28158a719f0de SHA512 7c14f5bb9a71dcf41307b368ee05a9ca8fe1d8c85ba16552ff5ee7eecce8704537c07b3213f78365c0f44b127d9a8ac4c89ab8ddb3652ded2890492b6244b1a3
+MISC metadata.xml 489 BLAKE2B 38e48e25c0ca75341f8192b2511ab974f435f919c38ed09923665fdc9894aa5faaa19aa84c1421615dbf45cb61fc386e3f6663065eb0a615c01f2ea87fb3e61b SHA512 801ef857b1af21d77179f7ab9c0a00060178146509a43cd8d7e18ee89191f435bcf080e1a14367d38a08242eb387eb5cb78afedbfa46274b45bb9a88d1081c29
diff --git a/app-arch/unrpa/metadata.xml b/app-arch/unrpa/metadata.xml
new file mode 100644
index 000000000000..d3970960d42d
--- /dev/null
+++ b/app-arch/unrpa/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <longdescription>
+ Unrpa is a script to extract files from archives created for
+ the Ren'Py Visual Novel Engine (http://www.renpy.org/)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Lattyware/unrpa</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/unrpa/unrpa-1.4.1.ebuild b/app-arch/unrpa/unrpa-1.4.1.ebuild
new file mode 100644
index 000000000000..08b6cbe02bcc
--- /dev/null
+++ b/app-arch/unrpa/unrpa-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Lattyware/unrpa.git"
+else
+ SRC_URI="https://github.com/Lattyware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Ren'Py's RPA data file extractor"
+HOMEPAGE="https://github.com/Lattyware/unrpa"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}
diff --git a/app-arch/unrpa/unrpa-1.4.2.ebuild b/app-arch/unrpa/unrpa-1.4.2.ebuild
new file mode 100644
index 000000000000..116e57d6b1bb
--- /dev/null
+++ b/app-arch/unrpa/unrpa-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Lattyware/unrpa.git"
+else
+ SRC_URI="https://github.com/Lattyware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Ren'Py's RPA data file extractor"
+HOMEPAGE="https://github.com/Lattyware/unrpa"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ python_doscript "${PN}"
+ dodoc README
+}
diff --git a/app-arch/unrpa/unrpa-9999.ebuild b/app-arch/unrpa/unrpa-9999.ebuild
new file mode 100644
index 000000000000..116e57d6b1bb
--- /dev/null
+++ b/app-arch/unrpa/unrpa-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Lattyware/unrpa.git"
+else
+ SRC_URI="https://github.com/Lattyware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Ren'Py's RPA data file extractor"
+HOMEPAGE="https://github.com/Lattyware/unrpa"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ python_doscript "${PN}"
+ dodoc README
+}