summaryrefslogtreecommitdiff
path: root/app-arch/unrar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-07 02:07:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-07 02:07:26 +0000
commit2198f8593ae0312add1bdccb49edfcb935e5f8a6 (patch)
tree67d79ffd7e91cc3858d188c49a65f46860a9bac7 /app-arch/unrar
parentd285f0ab4ab38d4ea1cd0757a465db5f06764e06 (diff)
gentoo auto-resync : 07:12:2024 - 02:07:26
Diffstat (limited to 'app-arch/unrar')
-rw-r--r--app-arch/unrar/Manifest2
-rw-r--r--app-arch/unrar/unrar-7.1.2.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-arch/unrar/Manifest b/app-arch/unrar/Manifest
index 4a2e0f23d12b..57ed929e21b3 100644
--- a/app-arch/unrar/Manifest
+++ b/app-arch/unrar/Manifest
@@ -1,4 +1,6 @@
AUX unrar-6.2.6-honor-flags.patch 1238 BLAKE2B 3006316800d6933f85935b0d1d4a224ae63d76d826c2a71f21ba148466d17e76e0a93f24d9c88015a8c58c4ca8f602ad25da48d097b80a078dbcc38a1a47715d SHA512 11cb495b661272b44078368318d2ec9f91e5d70bc79e5504c41a7d8e5207dc6b9afbad7cb36ac3188268f3797fa236bee55fcad8c95daeda2191a9e2a26dfd60
DIST unrar-7.0.9.tar.gz 258287 BLAKE2B 4933d62c8b7ea227b5eee8ce078a08cbe7534f35641ee0ce33bdd246f1045c65f773894d5868738b2174ea2bb2858745b5bd31dc5f958ef70188bcb805165300 SHA512 4dff760bd69275dcd9bacac7a8fa9a6e68e2d047ea3775abc16a80d9a6e277b686153faafb1b711582d86eabfdf3254c601d9f585b28104dbd85ece4868876ed
+DIST unrar-7.1.2.tar.gz 264081 BLAKE2B e5cd9c577ae4c8b8025970e597b7b270fe74beb47974ce038ce334c6cd49eb3bbbd1126eecf7093703f998f5a55a3be3ea911d950dd25040ef0f98272d5d84dd SHA512 3492334ef95916728af573f8f5bcb8d5a8c4a014b5daa0ffeaa67c9c56a5603a2389b030c6e0126064b1f281db5143907fa83f8c4249d23abc3273a5387d90d6
EBUILD unrar-7.0.9.ebuild 2685 BLAKE2B 332085c550f25cb82bee91c44b781d92a759d5f703dbca420572ccd56835bd1860b49f4f53a85e1eed2813df7928b70576a937c3c2e012e57293550f64574836 SHA512 4303ffb94537dfd8c243787933d60ecb25853ba79edf8ac5bf312c816be886128e75ae455431650b6085d5149994882aae1854e5df2345c2d5d06385fb0881af
+EBUILD unrar-7.1.2.ebuild 2692 BLAKE2B bba031bf53b4af6754f50ae2ad40f17af1037d5395702c7810dd1e7065833a8cac34b3e1d3bccc9f86535ecc32c7cb801d3df2c668b7cfa0bfd2ebc7c3b9d14b SHA512 5395896675abed2dcb4c5ebd2a9f5d1766e4824fcdb773cb83a3134e0d1469daa514e404313eb5c75ab434a422903743044b77f171ac210440191bd38374d15d
MISC metadata.xml 520 BLAKE2B d8b7da005139f02d8fdb948cb6e2c6af4073fab248ee05e80aaf4c706d9213a7600010b89b3ad99e89cbb651caf647dc898373225315ec1dc2c6f5a51424fa8a SHA512 65e6387fe9ecb267f630480287bfb4376c16b1d8088fa4f2078a747d53210ea92ef3ff03f05fdbcadf97af71e47a691f19425573b0b630b5c7640caab2ca890a
diff --git a/app-arch/unrar/unrar-7.1.2.ebuild b/app-arch/unrar/unrar-7.1.2.ebuild
new file mode 100644
index 000000000000..126f730b8cc9
--- /dev/null
+++ b/app-arch/unrar/unrar-7.1.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib toolchain-funcs
+
+MY_PN="${PN}src"
+
+DESCRIPTION="Uncompress rar files"
+HOMEPAGE="https://www.rarlab.com/rar_add.htm"
+SRC_URI="https://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/unrar"
+
+LICENSE="unRAR"
+SLOT="0/7" # subslot = soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PATCHES=( "${FILESDIR}/${PN}-6.2.6-honor-flags.patch" )
+
+src_prepare() {
+ default
+
+ local sed_args=( -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" )
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed_args+=( -e "s:-shared:-dynamiclib -install_name ${EPREFIX}/usr/$(get_libdir)/libunrar$(get_libname ${PV%.*.*}):" )
+ else
+ sed_args+=( -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" )
+ fi
+ sed -i "${sed_args[@]}" makefile || die
+}
+
+src_configure() {
+ mkdir -p build-{lib,bin} || die
+ printf 'VPATH = ..\ninclude ../makefile' > build-lib/Makefile || die
+ cp build-{lib,bin}/Makefile || die
+}
+
+src_compile() {
+ unrar_make() {
+ emake AR="$(tc-getAR)" CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@"
+ }
+
+ unrar_make CXXFLAGS+=" -fPIC" -C build-lib lib
+ ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname) || die
+ ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname ${PV}) || die
+
+ unrar_make -C build-bin
+}
+
+src_install() {
+ dobin build-bin/unrar
+ dodoc readme.txt
+
+ dolib.so build-lib/libunrar*
+
+ # unrar doesn't officially install headers, but unofficially, software
+ # depends on it anyway. There is no standard for where to install them,
+ # but the most common location (shared by nearly all vendors) is "unrar".
+ # FreeBSD alone uses "libunrar". Gentoo formerly used "libunrar6" and
+ # had a compat symlink for FreeBSD, then passed the compat location in
+ # ./configure scripts e.g. for sys-fs/rar2fs. Software in the wild
+ # seems to expect either "unrar" or "libunrar".
+ # See: https://bugs.gentoo.org/916036
+ #
+ # We now use the "standard" (hah) location, and keep the compat symlink but
+ # change the destination. The version-suffixed location lacks utility, but
+ # we would keep it if we could, just in case -- unfortunately portage is
+ # buggy: https://bugs.gentoo.org/834600
+ #
+ # Hopefully, no one has ever actually used it and therefore this does not
+ # matter. The odds are on our side, since it periodically changed location
+ # arbitrarily.
+ insinto /usr/include/unrar
+ doins *.hpp
+ dosym unrar /usr/include/libunrar
+
+ find "${ED}" -type f -name "*.a" -delete || die
+}