summaryrefslogtreecommitdiff
path: root/app-arch/unp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-11 11:34:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-11 11:34:48 +0000
commit70fb964b97d74b88cbbdd3fcbf5871d57323dfd3 (patch)
tree1fe339777089a670d8f34e4cef95a2ef382b8e96 /app-arch/unp
parente644f875e1d27155e8829b8f7385a8b2d790bcce (diff)
gentoo auto-resync : 11:02:2024 - 11:34:48
Diffstat (limited to 'app-arch/unp')
-rw-r--r--app-arch/unp/Manifest2
-rw-r--r--app-arch/unp/unp-2.0_pre10.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-arch/unp/Manifest b/app-arch/unp/Manifest
index 9a50059d1524..fce41a018717 100644
--- a/app-arch/unp/Manifest
+++ b/app-arch/unp/Manifest
@@ -1,3 +1,5 @@
+DIST unp_2.0~pre10.tar.xz 17992 BLAKE2B 63d8c995091a1342677b6aed5854293c582cb6d42c6748ef3d92347ca75e1d3e9e5b128309299ec0b6fc0361bc14dededcc8e290fe8721aecfe82665e07998e9 SHA512 3f8f9f20eef88658b4b00efd37208d859fb3220178f9446696f755a864fea3c3dd301100668bd9c97ca9312ebe961aaf9ec523d8817b8aacb5a1ee6a36213666
DIST unp_2.0~pre9.tar.xz 16424 BLAKE2B 9042f48be0f80d5e40a08161a35c282ba458dc98cf13992835bdeecebd5fbadd33b3af9165738332cb9f508550a234a48d314332f00ecdacc808a8051eb0740b SHA512 74c9a6e143c9023bdd456dacff5c3a6e30722e259f324c066fe3eed9e4a09c38b399b381719c8677c2fa84434c1e7720384d782d97c098fa6fbcbdbf4030986e
+EBUILD unp-2.0_pre10.ebuild 1150 BLAKE2B eba072022b195163c0c2d3124ef249bc0c2db671bb19c31c42396c2e9c5bef8def083998b91d027e812c4f6134d241164f43672f0c3241688afbcde9cb2bebf5 SHA512 6ccc815f11aac1cd61f6a97fce24eeb76ecafcf94a4318f7a5264e65b7e6f08c9bcb4bae66849fc2a7035bb043623630fc5858241f5ba070972bce6072fbf1ea
EBUILD unp-2.0_pre9.ebuild 1077 BLAKE2B 9577cdb1f0c55646b8eaa29665e77ed70a3ccb2eb5d537ac20cfeb4236843c77b04e09a4ff77f1d1141875942ccf951206c51c724484f8a395024cbf58379495 SHA512 3d2834f70dc9ada249c4e7afe54a8c85feea8e55448f34c0cdfc7597728dbbbd66a17b0d77c04773e6e56311e53e3a7bcf5221102cdb1e5cd8f972731bb4b240
MISC metadata.xml 217 BLAKE2B 4c798b28d6d7cb91ce9efa46084d222e24f1f62814b89dc32e8ee4c2d2e761392fa46cb368de68fdaf0c020acc5603a124b3a96edaa8e6ee333ba3f71ea59ad5 SHA512 83aaf1cf450d1a0769b0d5bc9533bb17e683dd88d04d3318da131cd1c8c66492451b9518f9f2b08d144ac0a2ba4113ed09ffaff1b7c4779f6c35bd7bdcabb874
diff --git a/app-arch/unp/unp-2.0_pre10.ebuild b/app-arch/unp/unp-2.0_pre10.ebuild
new file mode 100644
index 000000000000..c719be032835
--- /dev/null
+++ b/app-arch/unp/unp-2.0_pre10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 strip-linguas
+
+DESCRIPTION="Script for unpacking various file formats"
+HOMEPAGE="https://packages.qa.debian.org/u/unp.html"
+MY_PV="${PV/_pre/$'\x7e'pre}"
+SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${MY_PV}.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+# tests in upstream tarball are missing sample files
+RESTRICT="test"
+
+src_compile() {
+ if use nls; then
+ strip-linguas -i .
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.po }.po"
+ else
+ emake -C po
+ fi
+ fi
+}
+
+src_install() {
+ dobin unp
+ dosym unp /usr/bin/ucat
+ doman debian/unp.1
+ dodoc debian/changelog debian/README.Debian
+ newbashcomp debian/unp.bash-completion unp
+
+ if use nls; then
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.mo }.mo" DESTDIR="${D}" install
+ else
+ emake -C po DESTDIR="${D}" install
+ fi
+ fi
+}