summaryrefslogtreecommitdiff
path: root/app-arch/torrentzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-arch/torrentzip
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-arch/torrentzip')
-rw-r--r--app-arch/torrentzip/Manifest2
-rw-r--r--app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch8
-rw-r--r--app-arch/torrentzip/torrentzip-0.9-r1.ebuild27
3 files changed, 37 insertions, 0 deletions
diff --git a/app-arch/torrentzip/Manifest b/app-arch/torrentzip/Manifest
index 3f1ac1812459..9169b9a33a65 100644
--- a/app-arch/torrentzip/Manifest
+++ b/app-arch/torrentzip/Manifest
@@ -1,3 +1,5 @@
+AUX torrentzip-0.9-autoconf-quote.patch 337 BLAKE2B 6d1f630d365eaa9aff9d2c910ad30ad79694906cbb3ec7fccf665a468458d8103a0ebbc4e0d3fed1969e18b92780217fa47ed9a6260c42888f8bc022db15b3a6 SHA512 6ec05d00be36479084005c0938fb3df58b960914496ed149cb7eea9a6b4cb6067f9caa3ae7c835cf3bd79f357e17e18b8fcf80994dc1d550247c32416d71596d
DIST torrentzip-0.9.tar.gz 59007 BLAKE2B eb5d7d8d9026115367afd88ef0cf33d2eed600e6eaa773f039a713c76a48a39e12cb5a8ac6faf2937d3563c9270029543bdb6361d2f22a39e2341953872f589c SHA512 691cd25f501de3de16b5b15b2afadfc34b833c3e93208c2c3497674936580ad2c3532a02e02531b89974302eee7b36f7579a412718914b1b38044b78a39a4d4d
+EBUILD torrentzip-0.9-r1.ebuild 566 BLAKE2B b5d754d804cac2edf328429321fa02bed15fd400c6b56a74106026f6245a55dbb65df0187292dff9715967454580b079d2c4e5a24972a71f240f08fe8ee750c4 SHA512 39469d9ee90af1bab0ea8f97f56907953a46cac3c706ed8080169c03816826c1c3015fd098ca0406d3318b2e207d2d4b02a301a3825701c62c38d6f1d978c8c7
EBUILD torrentzip-0.9.ebuild 545 BLAKE2B d611213e01e6fa3257de87fba67f97d8c58a00e5b465f4068c92dcaced997147995d5cb0829b051ce5d109e76f0f8091fa86868e31863afb03aa51bf47755e76 SHA512 e8529a17ef17a9907b32c91fa31bb743a2773ed4bff637fd0cce9f88e510e50e814fb779f96e93567b32485fa7cf2130bd32daac22219e4ffec61e83e89ee5bd
MISC metadata.xml 721 BLAKE2B 3a3fff9bfc6d5ab338abecf42f6a742f6e46e00907bb4858c6c41144d46dc40612346a7421274d62b33d4e66f284049da348c5389627492550c2c853aa0e2c34 SHA512 3e9c20623abceddb37559d631e498012bdd080a9b63f29aed8503553e6db7dfc2bff44226f3615c56a9bcc4ddb1c15b2f322d9f77fc1dc1788e62b4b2ea4c2ae
diff --git a/app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch b/app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch
new file mode 100644
index 000000000000..f1f15ced173e
--- /dev/null
+++ b/app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch
@@ -0,0 +1,8 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,4 +1,4 @@
+-AC_INIT([TorrentZip], [0.0], [StatMan, shindakun, Ultrasubmarine, r3nh03k <http://trrntzip.sf.net>], [trrntzip])
++AC_INIT([TorrentZip], [0.9], [[StatMan, shindakun, Ultrasubmarine, r3nh03k <http://trrntzip.sf.net>]], [trrntzip])
+
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER(config.h)
diff --git a/app-arch/torrentzip/torrentzip-0.9-r1.ebuild b/app-arch/torrentzip/torrentzip-0.9-r1.ebuild
new file mode 100644
index 000000000000..522a52f4749c
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-0.9-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Create identical zip archives over multiple systems"
+HOMEPAGE="https://sourceforge.net/projects/trrntzip"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOCS=(README AUTHORS)
+
+PATCHES=("${FILESDIR}/${P}-autoconf-quote.patch")
+
+src_prepare() {
+ default
+ export CPPFLAGS+=" -DOF\\(args\\)=args"
+ eautoreconf
+}