summaryrefslogtreecommitdiff
path: root/app-arch/torrentzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/torrentzip
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/torrentzip')
-rw-r--r--app-arch/torrentzip/Manifest3
-rw-r--r--app-arch/torrentzip/metadata.xml22
-rw-r--r--app-arch/torrentzip/torrentzip-0.9.ebuild30
3 files changed, 55 insertions, 0 deletions
diff --git a/app-arch/torrentzip/Manifest b/app-arch/torrentzip/Manifest
new file mode 100644
index 000000000000..3f1ac1812459
--- /dev/null
+++ b/app-arch/torrentzip/Manifest
@@ -0,0 +1,3 @@
+DIST torrentzip-0.9.tar.gz 59007 BLAKE2B eb5d7d8d9026115367afd88ef0cf33d2eed600e6eaa773f039a713c76a48a39e12cb5a8ac6faf2937d3563c9270029543bdb6361d2f22a39e2341953872f589c SHA512 691cd25f501de3de16b5b15b2afadfc34b833c3e93208c2c3497674936580ad2c3532a02e02531b89974302eee7b36f7579a412718914b1b38044b78a39a4d4d
+EBUILD torrentzip-0.9.ebuild 545 BLAKE2B d611213e01e6fa3257de87fba67f97d8c58a00e5b465f4068c92dcaced997147995d5cb0829b051ce5d109e76f0f8091fa86868e31863afb03aa51bf47755e76 SHA512 e8529a17ef17a9907b32c91fa31bb743a2773ed4bff637fd0cce9f88e510e50e814fb779f96e93567b32485fa7cf2130bd32daac22219e4ffec61e83e89ee5bd
+MISC metadata.xml 721 BLAKE2B 3a3fff9bfc6d5ab338abecf42f6a742f6e46e00907bb4858c6c41144d46dc40612346a7421274d62b33d4e66f284049da348c5389627492550c2c853aa0e2c34 SHA512 3e9c20623abceddb37559d631e498012bdd080a9b63f29aed8503553e6db7dfc2bff44226f3615c56a9bcc4ddb1c15b2f322d9f77fc1dc1788e62b4b2ea4c2ae
diff --git a/app-arch/torrentzip/metadata.xml b/app-arch/torrentzip/metadata.xml
new file mode 100644
index 000000000000..8c0252f5120a
--- /dev/null
+++ b/app-arch/torrentzip/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex.miller@gmx.de</email>
+ <name>Alexander Miller</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <longdescription>
+ TorrentZip is a replacement for MameZip. The goal of the program is to
+ use standard values when creating zips to create identical files over
+ multiple systems. It has the ability to create a torrentzip format
+ from a zip file.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">trrntzip</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/torrentzip/torrentzip-0.9.ebuild b/app-arch/torrentzip/torrentzip-0.9.ebuild
new file mode 100644
index 000000000000..0aa3083323bf
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Create identical zip archives over multiple systems"
+HOMEPAGE="https://sourceforge.net/projects/trrntzip"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ sys-libs/zlib"
+
+DEPEND="
+ ${RDEPEND}
+ app-arch/unzip"
+
+DOCS=(README AUTHORS)
+
+src_prepare() {
+ default
+ export CPPFLAGS+=" -DOF\\(args\\)=args"
+ eautoreconf
+}