summaryrefslogtreecommitdiff
path: root/app-arch/tarsync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/tarsync
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/tarsync')
-rw-r--r--app-arch/tarsync/Manifest5
-rw-r--r--app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch59
-rw-r--r--app-arch/tarsync/files/tarsync-0.2.1-make.patch13
-rw-r--r--app-arch/tarsync/metadata.xml5
-rw-r--r--app-arch/tarsync/tarsync-0.2.1-r1.ebuild33
5 files changed, 115 insertions, 0 deletions
diff --git a/app-arch/tarsync/Manifest b/app-arch/tarsync/Manifest
new file mode 100644
index 000000000000..0cbd6bd3674d
--- /dev/null
+++ b/app-arch/tarsync/Manifest
@@ -0,0 +1,5 @@
+AUX tarsync-0.2.1-gcc5.patch 2069 BLAKE2B eaa4c529c95caa2d70eda5c9a6901cc92ca3e885a0fd2ef3c4df1a6e53d6b1febe8aba4a043844dd31334aea0d58df964152c1245cccdc112658d2bdc229cf1e SHA512 f62fa7f65e506d34d6f9a90579cda2e0568da55cd11c0926dc8f39b5f3d0f4952e6984bd4b6913f3bff938271d37e689e2b8168f393382a04ae269aafbebcd8c
+AUX tarsync-0.2.1-make.patch 269 BLAKE2B 07b9391018c76b5e34c4cea40bf458bc7681aac0c0e16ae23071c0ff603d156051e321007401cced3d0e1208927f5352e4773c0d275314443bd9be2a48fb18dd SHA512 011c028ffad1575f0b7c1eca10d9744d1466fa74efd9414af54d8b0ef336ef1f7d340ff486a915a946ed2720141016597d3831f452c560bc6fda9569de90643f
+DIST tarsync-0.2.1.tar.bz2 13593 BLAKE2B 4841d501587c8d4932031fe939fce9f41019622af2a4253bfe12c01160956e7eaeebf5ff00174332dce6b17ae150ead42b7c1a57483f948ba191b5c3943f6596 SHA512 bebf8e495ad196c002414c41f9fe9737b5300de18b7c3b16576a7d3bfd94608f36f1b86cb6ed4879c600b71c7706255d9b2d4140b73c5743a473fa2500dbca2d
+EBUILD tarsync-0.2.1-r1.ebuild 662 BLAKE2B 1bb5ce8d30d45e4d00c8c3a670a7e9e692921243988c1ccc45b27f8f108187657cd51d2819ad6f773e62432446a3ac6c9d5b53e640c9e44929e469978d9c71f1 SHA512 d511e4cafdfa0bc266b3dce3d4de5d96c688b89fd39990dd1f60e144fc5420d5a9053762eb2d8abe2e26279212e34dfd9e37acfbdcedce8ba940c5a1696701b1
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch b/app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch
new file mode 100644
index 000000000000..f11c86bb248a
--- /dev/null
+++ b/app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch
@@ -0,0 +1,59 @@
+diff --git a/excludes.c b/excludes.c
+index b7c928d..fa43cef 100644
+--- a/excludes.c
++++ b/excludes.c
+@@ -106,7 +106,7 @@ build_exclude(fnm_exclude **ex_ptr, const char *pattern)
+ }
+
+
+-inline int
++int
+ match_excludes(const char *dir, const char *file, fnm_exclude **excludes)
+ {
+ char *p;
+diff --git a/main.c b/main.c
+index 84feed4..2c2da3e 100644
+--- a/main.c
++++ b/main.c
+@@ -42,8 +42,8 @@ int remove_node(const char *path, struct stat *st);
+ int ensure_files_layout(const tar_entry **ttar, const unsigned int ttar_count, tar_entry ***missing,
+ unsigned int *missing_count, tar_entry ***existing, unsigned int *existing_count,
+ fnm_exclude **excludes);
+-inline int check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st);
+-inline int enforce_owner(const char *path, const tar_entry *t, struct stat *st);
++int check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st);
++int enforce_owner(const char *path, const tar_entry *t, struct stat *st);
+ int copy_whole_file(cfile *tar_cfh, const tar_entry *ttent);
+
+ static int check_mtime = 1;
+@@ -669,7 +669,7 @@ recursively_delete_dir(const char *path)
+ return ret;
+ }
+
+-inline int
++int
+ check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st)
+ {
+ int type;
+@@ -685,7 +685,7 @@ check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st
+ return 0;
+ }
+
+-inline int
++int
+ enforce_owner(const char *path, const tar_entry *t, struct stat *st)
+ {
+ struct stat st2;
+diff --git a/tar.c b/tar.c
+index 792ccd4..42dc8e7 100644
+--- a/tar.c
++++ b/tar.c
+@@ -40,7 +40,7 @@ int check_str_chksum(const char *block)
+
+ /* possibly this could be done different, what of endptr of strtol?
+ Frankly I worry about strtol trying to go too far and causing a segfault, due to tar fields not always having trailing \0 */
+-inline unsigned long octal_str2long(const char *string, unsigned int length)
++unsigned long octal_str2long(const char *string, unsigned int length)
+ {
+ if(string[length]) {
+ char *ptr = strndup(string, length);
diff --git a/app-arch/tarsync/files/tarsync-0.2.1-make.patch b/app-arch/tarsync/files/tarsync-0.2.1-make.patch
new file mode 100644
index 000000000000..72591115a45a
--- /dev/null
+++ b/app-arch/tarsync/files/tarsync-0.2.1-make.patch
@@ -0,0 +1,13 @@
+Respect CC and LDFLAGS.
+
+--- Makefile
++++ Makefile
+@@ -2,7 +2,7 @@
+ CC=gcc
+ endif
+ tarsync: main.o names.o tar.o string-misc.o fs.o options.o excludes.o
+- gcc $(CFLAGS) $^ -o tarsync -lcfile
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o tarsync -lcfile
+ all: tarsync
+
+ clean:
diff --git a/app-arch/tarsync/metadata.xml b/app-arch/tarsync/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-arch/tarsync/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-arch/tarsync/tarsync-0.2.1-r1.ebuild b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..c9db986bc6c6
--- /dev/null
+++ b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86 ~amd64-linux"
+IUSE=""
+
+DEPEND=">=dev-util/diffball-0.7"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${P}-gcc5.patch
+}
+
+src_install() {
+ dobin "${PN}" #make install doesn't support prefix
+}