summaryrefslogtreecommitdiff
path: root/app-arch/tardy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/tardy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/tardy')
-rw-r--r--app-arch/tardy/Manifest4
-rw-r--r--app-arch/tardy/files/tardy-1.28-test-utc.patch10
-rw-r--r--app-arch/tardy/metadata.xml9
-rw-r--r--app-arch/tardy/tardy-1.28.ebuild32
4 files changed, 55 insertions, 0 deletions
diff --git a/app-arch/tardy/Manifest b/app-arch/tardy/Manifest
new file mode 100644
index 000000000000..b2dbdc4aa490
--- /dev/null
+++ b/app-arch/tardy/Manifest
@@ -0,0 +1,4 @@
+AUX tardy-1.28-test-utc.patch 247 BLAKE2B 32ef5f3ac00059cca3f4562b81de9059e472bb5d30d84f22e84af09104cdfe48b0e3ce30be893e867e35c36c8d87961a4b733ba92f688d28dc2da0bf3e255754 SHA512 402988d7e0f73cde0bffbcb9ffa4ec60eee310e17c108a80993effdeb6bf00c8a5d6298e7c0b6ad71f85a74046b9d3722346cb4d0beea958653ec29dcafd8b7a
+DIST tardy-1.28.D001.tar.gz 1848303 BLAKE2B 5e0c7869e691e83a40ef09cc7f45cabe32dcf14e56685d85628f507e55e4131e7a4488bfa7b890abebe06a59959d9d715e03470fa9da5d1ddf239c4a3cac32c5 SHA512 d8f02d8a310cd3d84f89a67f3bf4e91689e33631b1701a98b70d32b801b1a7cafee5755f13ed18e31bb9d5b1ec147da21b13b57722e1bf15a9efc355ea5438df
+EBUILD tardy-1.28.ebuild 703 BLAKE2B 0b2527f5337a9b8230571a7d940396d640f654e0c72de1e1c4d2713d45cb77807dc1fe4652ea9ec423dc01be7ba8936c2e499649c1df66ee8c18ad0407cebfe4 SHA512 95d4f4660acec1239ab747cbd7632c4cb511d4fcc95b388cd409e8bc54e7cf000107afabe7d643b481a8358eb9eca0f75c0e3c35680e612fa5e1f50dd4504f0f
+MISC metadata.xml 343 BLAKE2B 7082ea3371e041a810013911796bcf9bc81b7c5eea2fcafb3ee4b647851350621e3da098db50c4a0943e49487680020f8fa16ee1678c417484ee7f11adfc961c SHA512 97b6897b8a642636f9a9b5e1a09eda1c81469a281c7d53278753aca7638a58c0ac7053699f9f6bb31a4642c17489d46f34ccfdd4c98b9d96fe70cf2cadb6741d
diff --git a/app-arch/tardy/files/tardy-1.28-test-utc.patch b/app-arch/tardy/files/tardy-1.28-test-utc.patch
new file mode 100644
index 000000000000..3f15c38020e7
--- /dev/null
+++ b/app-arch/tardy/files/tardy-1.28-test-utc.patch
@@ -0,0 +1,10 @@
+--- tardy-1.28/test/00/t0075a.sh
++++ tardy-1.28/test/00/t0075a.sh
+@@ -19,6 +19,7 @@
+
+ TEST_SUBJECT="tarballs >2GB"
+ . test_prelude
++export TZ=UTC
+
+ # |||||
+ # beware potential timezone mismatch: vvvvv
diff --git a/app-arch/tardy/metadata.xml b/app-arch/tardy/metadata.xml
new file mode 100644
index 000000000000..5af9ba8260f4
--- /dev/null
+++ b/app-arch/tardy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>Tardy is a tar post-processor for manipulating the file headers.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tardy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/tardy/tardy-1.28.ebuild b/app-arch/tardy/tardy-1.28.ebuild
new file mode 100644
index 000000000000..1c542688d194
--- /dev/null
+++ b/app-arch/tardy/tardy-1.28.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A tar post-processor"
+HOMEPAGE="http://tardy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tardy/${P}.D001.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="app-arch/bzip2
+ app-arch/xz-utils
+ dev-libs/libexplain
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+src_prepare() {
+ sed -e 's/$(CXX) .* $(CXXFLAGS) -I./\0 -o $@/' \
+ -e '/mv \(.*\)\.o $@/d' \
+ -e '/@sleep 1/d' \
+ -e 's#^\(install-man: $(mandir)/man1/tardy.1\).*#\1#' \
+ -i Makefile.in || die
+
+ epatch "${FILESDIR}"/${P}-test-utc.patch
+ tc-export AR
+}