summaryrefslogtreecommitdiff
path: root/app-arch/tapeutils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-arch/tapeutils/files
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-arch/tapeutils/files')
-rw-r--r--app-arch/tapeutils/files/tapeutils-0.4-fix-C-decl.patch31
-rw-r--r--app-arch/tapeutils/files/tapeutils-0.4-fix-build-system.patch11
2 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/tapeutils/files/tapeutils-0.4-fix-C-decl.patch b/app-arch/tapeutils/files/tapeutils-0.4-fix-C-decl.patch
new file mode 100644
index 000000000000..ee07c252d168
--- /dev/null
+++ b/app-arch/tapeutils/files/tapeutils-0.4-fix-C-decl.patch
@@ -0,0 +1,31 @@
+--- a/tapecopy.c
++++ b/tapecopy.c
+@@ -26,6 +26,8 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#include <stdlib.h>
++
+ #include "tapeio.h"
+ #include "stdio.h"
+ #include "stdarg.h"
+--- a/tapedump.c
++++ b/tapedump.c
+@@ -26,6 +26,8 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#include <stdlib.h>
++
+ #include "tapeio.h"
+ #include "stdio.h"
+ #include "stdarg.h"
+@@ -158,7 +160,7 @@
+ len = getrec (src, buf, MAX_REC_LEN);
+ if (len == 0)
+ {
+- printf ("total length of file %d = %d records, %d bytes\n",
++ printf ("total length of file %d = %d records, %lu bytes\n",
+ file, record, filebytes);
+ tapebytes += filebytes;
+ file++;
diff --git a/app-arch/tapeutils/files/tapeutils-0.4-fix-build-system.patch b/app-arch/tapeutils/files/tapeutils-0.4-fix-build-system.patch
new file mode 100644
index 000000000000..e1670a47fe2b
--- /dev/null
+++ b/app-arch/tapeutils/files/tapeutils-0.4-fix-build-system.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -20,8 +20,6 @@
+ # options
+ # -----------------------------------------------------------------------------
+
+-CFLAGS = -O2
+-LDFLAGS =
+
+ # CFLAGS = -g
+ # LDFLAGS = -g