summaryrefslogtreecommitdiff
path: root/app-arch/stuffit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/stuffit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/stuffit')
-rw-r--r--app-arch/stuffit/Manifest3
-rw-r--r--app-arch/stuffit/metadata.xml6
-rw-r--r--app-arch/stuffit/stuffit-5.2.0.611.ebuild67
3 files changed, 76 insertions, 0 deletions
diff --git a/app-arch/stuffit/Manifest b/app-arch/stuffit/Manifest
new file mode 100644
index 000000000000..14f52665da9b
--- /dev/null
+++ b/app-arch/stuffit/Manifest
@@ -0,0 +1,3 @@
+DIST stuffit520.611linux-i386.tar.gz 1955619 BLAKE2B fb80abef29d266c93747b3359c62840afa15a32786a82ee01cab22cf0eddad750817c87b767632df5bb2ef681c1c9dd6dfe136dae388f8390bcab0b137a2c0bc SHA512 a1d4631c2d238b49c710816cd5ed8a01dcf52c29b870297b8dfd76fb0cb6e725c5b0f9d4a6c155c7b6980005df52fc4597632f72e90f00bf93ad80a28972270a
+EBUILD stuffit-5.2.0.611.ebuild 1471 BLAKE2B 33b12391d0b2ee3a638b85f5010ad500032570d52a875ed72f36403f43fd238a6e47b9316f30be82966a78e6f602ff45b9db764d898f6894490e1eada29cacce SHA512 816b2b903025599753824cff5eed538c327b49ab146c26967e5246fdc0e2b2168f1531266970c1670d2cf2bcf1f45ab7eb3332b41294734c2214ad7e69b42cea
+MISC metadata.xml 302 BLAKE2B f1870466f061240593b130854dc1baaffbc351f573e2f8e7bd4e5d8dcb986a794d151bc6a41bb7929b34a5bea104f0f95efbedd3bd068af39896fd444997cf45 SHA512 cb8ca2c4b1b49221c5e2ef4d37a9f8faa4a03ec8e116dfe31185f0a09aeaadf1034f45f655d984658e8318f057ca9028edb4cd373abb0d5bfe05ff6dd83d00b3
diff --git a/app-arch/stuffit/metadata.xml b/app-arch/stuffit/metadata.xml
new file mode 100644
index 000000000000..9721c8429868
--- /dev/null
+++ b/app-arch/stuffit/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription>Stuffit is a archive creating application, supporting .sit, .sitx .zip, and self-extracting archives</longdescription>
+</pkgmetadata>
diff --git a/app-arch/stuffit/stuffit-5.2.0.611.ebuild b/app-arch/stuffit/stuffit-5.2.0.611.ebuild
new file mode 100644
index 000000000000..2e6528ed2126
--- /dev/null
+++ b/app-arch/stuffit/stuffit-5.2.0.611.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="stuffit520.611linux-i386"
+
+DESCRIPTION="Aladdin Software's StuffIt and StuffIt Expander"
+HOMEPAGE="http://www.stuffit.com/"
+SRC_URI="http://my.smithmicro.com/downloads/files/${MY_P}.tar.gz"
+
+LICENSE="Stuffit"
+SLOT="0"
+KEYWORDS="-* x86 amd64"
+IUSE=""
+RESTRICT="fetch strip"
+
+S="${WORKDIR}"
+
+INSTALLDIR=/opt/stuffit
+
+pkg_nofetch() {
+ einfo "Please download stuffit from"
+ einfo "${SRC_URI}"
+ einfo "and put the file in ${DISTDIR}"
+ einfo
+ einfo "Note that StuffIt requires registration within 30 days,"
+ einfo "but StuffIt Expander is freeware."
+ einfo
+}
+
+src_install() {
+ # First do the binaries
+ exeinto ${INSTALLDIR}/bin
+ doexe bin/stuff
+ doexe bin/unstuff
+
+ # Now the registration binary
+ exeinto ${INSTALLDIR}/extra
+ doexe bin/register
+
+ # Now the documentation
+ docinto stuff
+ dodoc doc/stuff/{README,stuff.html}
+ docinto unstuff
+ dodoc doc/unstuff/{README,unstuff.html}
+
+ # And now the man pages
+ doman man/man1/*
+
+ # Also add the executables to the path
+ dodir /etc/env.d
+ cat > "${T}"/10stuffit <<- EOF || die
+ PATH="${EPREFIX}${INSTALLDIR}/bin"
+ ROOTPATH="${EPREFIX}${INSTALLDIR}/bin"
+ EOF
+ doenvd "${T}"/10stuffit
+}
+
+pkg_postinst() {
+ elog
+ elog "Reminder: StuffIt requires registration within 30 days."
+ elog "The registration program is located in ${INSTALLDIR}/extra"
+ elog
+ elog "The binaries are named 'stuff' and 'unstuff'"
+ elog
+}