summaryrefslogtreecommitdiff
path: root/app-arch/sharutils/sharutils-4.15.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-arch/sharutils/sharutils-4.15.2-r1.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-arch/sharutils/sharutils-4.15.2-r1.ebuild')
-rw-r--r--app-arch/sharutils/sharutils-4.15.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/sharutils/sharutils-4.15.2-r1.ebuild b/app-arch/sharutils/sharutils-4.15.2-r1.ebuild
new file mode 100644
index 000000000000..ca36f985b19e
--- /dev/null
+++ b/app-arch/sharutils/sharutils-4.15.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+MY_P="${P/_/-}"
+DESCRIPTION="Tools to deal with shar archives"
+HOMEPAGE="https://www.gnu.org/software/sharutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 s390 ~sh sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="app-arch/xz-utils
+ sys-apps/texinfo
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ epatch "${FILESDIR}/sharutils-4.15.2-glibc228.patch"
+ epatch "${FILESDIR}/sharutils-4.15.2-CVE-2018-1000097.patch"
+
+ # Upstream is aware but thinks this isn't a bug/problem in sharutils itself
+ # See http://lists.gnu.org/archive/html/bug-gnu-utils/2013-10/msg00011.html
+ append-cflags $(test-flags-CC -Wno-error=format-security)
+}
+
+src_configure() {
+ strip-linguas -u po
+ econf $(use_enable nls)
+}