summaryrefslogtreecommitdiff
path: root/app-arch/pxz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/pxz
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/pxz')
-rw-r--r--app-arch/pxz/Manifest4
-rw-r--r--app-arch/pxz/metadata.xml15
-rw-r--r--app-arch/pxz/pxz-5.0_pre20151029.ebuild29
-rw-r--r--app-arch/pxz/pxz-9999.ebuild41
4 files changed, 89 insertions, 0 deletions
diff --git a/app-arch/pxz/Manifest b/app-arch/pxz/Manifest
new file mode 100644
index 000000000000..7c29da553944
--- /dev/null
+++ b/app-arch/pxz/Manifest
@@ -0,0 +1,4 @@
+DIST pxz-5.0_pre20151029.tar.gz 12271 BLAKE2B 6ba2cb7629b0475761b59620375a2d0de7c6a3a61f7af20140e214383f737e046c45f0c602830c0331794fe1d38332d8d309ed0b8451e3a780ef1a2835de85e6 SHA512 d26bfdf9b70baf91c575e21824920cb42d0a9bd171254b99147a6e5e322ed3d1f7351a570358213431bdacdcbe6e7b22646a2dd2d7a127e167c8237bc4f3038a
+EBUILD pxz-5.0_pre20151029.ebuild 760 BLAKE2B f612a0a8e208c9307ecba3daf1dcc5b2140eb93edbd296a9e243909f0e2e03ada3d1d8e5ce1f338c6b3b05433b14d1c7e0f2ca7e233d5122b5e17a89dbadf9d2 SHA512 eca8f250030d3336529c2e435bdf73ca404799924f5e040c63b37d1fcb6b32848ba3acad3af9e3dcebeb4246f623ad1e27150fcb76c2678bf8b6de2ca51513f0
+EBUILD pxz-9999.ebuild 938 BLAKE2B 97012bed530fc61b2a72b6bf94c63c5d6d0eb08b6dcc03acae211e60b8e46b12008068dd3de04db16df233f63b011463bec2bb69a746a8c5c21e7ea5c381d965 SHA512 1c959a24fc0dc0584d735cc4f612608e42bcb4098530df8d93a767ba820133ba1db077edbd52b2f5d43a7d6770760b23a8d7028d48b8d73f7e05332f7460f004
+MISC metadata.xml 589 BLAKE2B 2a18a26af893fcf39313001b7e3199ccae582cbc2dd71738c0affe08fea79c59f9908e9a9eab5d5517bf778441c65ac259197a539c68235df868d7c6ac66e3d0 SHA512 4d345f2f0e3097fef6c502d28abb4ea2f236ec608c4ef0a56d2769513dc3f170e1589f9c14850e365c9914f25868a67352c52e8335a5c9694b69fcb3c27033ac
diff --git a/app-arch/pxz/metadata.xml b/app-arch/pxz/metadata.xml
new file mode 100644
index 000000000000..1d95e2b04b5d
--- /dev/null
+++ b/app-arch/pxz/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>chutzpah@gentoo.org</email>
+<name>Patrick McLean</name>
+</maintainer>
+<longdescription lang="en">
+Parallel XZ is a compression utility that takes advantage of running LZMA
+compression of different parts of an input file on multiple cores and
+processors simultaneously. Its primary goal is to utilize all resources
+to speed up compression time with minimal possible influence on compression
+ratio.
+</longdescription>
+</pkgmetadata>
diff --git a/app-arch/pxz/pxz-5.0_pre20151029.ebuild b/app-arch/pxz/pxz-5.0_pre20151029.ebuild
new file mode 100644
index 000000000000..1ae6092ecb65
--- /dev/null
+++ b/app-arch/pxz/pxz-5.0_pre20151029.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Parallel implementation of the XZ compression utility"
+HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
+SRC_URI="https://github.com/jnovy/pxz/archive/fcfea93957d96b7661d1439cf4b767ecfd341eed.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux"
+IUSE=""
+
+# needs the library from xz-utils
+# needs the libgomp library from gcc at runtime
+RDEPEND="app-arch/xz-utils
+ sys-devel/gcc:*[openmp]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ tc-check-openmp
+ tc-export CC
+ export BINDIR="${EPREFIX}"/usr/bin
+ export MANDIR="${EPREFIX}"/usr/share/man
+ default_src_prepare
+}
diff --git a/app-arch/pxz/pxz-9999.ebuild b/app-arch/pxz/pxz-9999.ebuild
new file mode 100644
index 000000000000..24f23c3bd088
--- /dev/null
+++ b/app-arch/pxz/pxz-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jnovy/pxz.git"
+ inherit git-r3
+else
+ MY_PV=${PV/_}
+ case ${MY_PV} in
+ *beta?*) MY_PV="${MY_PV/beta/beta.}git" ;;
+ esac
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://jnovy.fedorapeople.org/pxz/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P/beta*/beta}
+fi
+
+DESCRIPTION="parallel LZMA compressor (no parallel decompression!)"
+HOMEPAGE="https://jnovy.fedorapeople.org/pxz/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# needs the library from xz-utils
+# needs the libgomp library from gcc at runtime
+DEPEND="app-arch/xz-utils
+ sys-devel/gcc:*[openmp]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ tc-check-openmp
+ tc-export CC
+ export BINDIR="${EPREFIX}"/usr/bin
+ export MANDIR="${EPREFIX}"/usr/share/man
+ default_src_prepare
+}