summaryrefslogtreecommitdiff
path: root/app-arch/pure-sfv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/pure-sfv
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/pure-sfv')
-rw-r--r--app-arch/pure-sfv/Manifest4
-rw-r--r--app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch22
-rw-r--r--app-arch/pure-sfv/metadata.xml8
-rw-r--r--app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild29
4 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/pure-sfv/Manifest b/app-arch/pure-sfv/Manifest
new file mode 100644
index 000000000000..ddb4fb155873
--- /dev/null
+++ b/app-arch/pure-sfv/Manifest
@@ -0,0 +1,4 @@
+AUX pure-sfv-0.3-fix-build-system.patch 517 BLAKE2B 87fddfd692c2d21ba5369ed57280d7b56568bae03396d9702e963285d6346a95693b049ef046c68a5116c7dd98e50444b1a50419c18fde99be0e67a142b775fa SHA512 317527bbf283ec603d06cf4705adf04915d57d7251301403dc43c359359f644728f61ba0997b04753f5c1c820341d5e0986ad0e3fb8c93a932d2000c9fc2c207
+DIST pure-sfv_0.3_src.tar.gz 79069 BLAKE2B 77bfa8ccad35a9f3bde4a5710deceb9e0786e905cd0ff44903b08154043012849c7f5f797806429b9005aa6977e23c451cd1cfeee2870c35298248d0783a078c SHA512 defacdaa0b78f708c83198e911ad93a5c5456bf15e2b33df61c984241df8a82ff4d962b8c7994c6413b36a61df2cc6d91c467bf8994fa43e0ac01db2585a78a6
+EBUILD pure-sfv-0.3-r1.ebuild 618 BLAKE2B 2eb5441f25c272303a5135009948eba2123fa7c65db8f512ceca160a0163dbd538dea456aa1b3a59e61797ba20d069dfdfbbef3971924df2a57b981fec4dceb3 SHA512 085a72af3f963aa2a5e9a6eb53ab191e4fb055e851bbc758209a285ca48a5450b6979d4ff081e774e4649c69977b385f198b944da2d5ec098118145c1d05622c
+MISC metadata.xml 245 BLAKE2B 8b7fc4825aab5e4cfdb98dbb19741e82e1f550601f15430d7ef70ea99e7d589cac19abfb8e248252be008b25820fb6de7b23d80cba84301e823e313fbb848a25 SHA512 4423c18a453e8c9b251ccc387341ffa1e1f492c2b0408d05b3948b94fd8f135145740bb9a04862d5f567c931c50c113f685a08fb10667ed1fcd1a005cbbe46da
diff --git a/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch b/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch
new file mode 100644
index 000000000000..ca2143f1f956
--- /dev/null
+++ b/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -54,18 +54,16 @@
+
+ VC_CRAP = pure-sfv.ncb pure-sfv.plg
+
+-CFLAGS += -Wall -Werror -O2 -g -Wno-unused
+ INSTALL_PREFIX = /usr/local
+ INSTALL_PROGRAM = /usr/bin/install -c
+
+ all: pure-sfv
+
+-CC = gcc
+
+ OBJ = ${SRCS:%.c=%.o}
+
+ pure-sfv: $(OBJ)
+- $(CC) -lm -DVERSION=\"$(VERSION)\" $(CFLAGS) -o $(PROG) $(OBJ)
++ $(CC) -DVERSION=\"$(VERSION)\" $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $(PROG) $(OBJ) -lm
+
+ PURIFY_OPTIONS=-follow-child-processes=yes -always-use-cache-dir=yes
+ PURIFY=purify
diff --git a/app-arch/pure-sfv/metadata.xml b/app-arch/pure-sfv/metadata.xml
new file mode 100644
index 000000000000..e48e0f140627
--- /dev/null
+++ b/app-arch/pure-sfv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">pure-sfv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
new file mode 100644
index 000000000000..f28c6df42ec4
--- /dev/null
+++ b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="utility to test and create .sfv files and create .par files"
+HOMEPAGE="http://pure-sfv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pure-sfv/${PN}_${PV}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86"
+IUSE=""
+RESTRICT="test"
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}"/${PN}-0.3-fix-build-system.patch )
+
+src_configure() {
+ append-cflags -Wall -Wno-unused
+ tc-export CC
+}
+
+src_install() {
+ dobin pure-sfv
+ newdoc ReadMe.txt README
+}