summaryrefslogtreecommitdiff
path: root/app-arch/pdlzip/pdlzip-1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/pdlzip/pdlzip-1.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/pdlzip/pdlzip-1.8.ebuild')
-rw-r--r--app-arch/pdlzip/pdlzip-1.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/pdlzip/pdlzip-1.8.ebuild b/app-arch/pdlzip/pdlzip-1.8.ebuild
new file mode 100644
index 000000000000..160eee1561e9
--- /dev/null
+++ b/app-arch/pdlzip/pdlzip-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Public-domain version of lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/pdlzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases/lzip/pdlzip/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CPPFLAGS="${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}