summaryrefslogtreecommitdiff
path: root/app-arch/mt-st
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/mt-st
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/mt-st')
-rw-r--r--app-arch/mt-st/Manifest4
-rw-r--r--app-arch/mt-st/metadata.xml11
-rw-r--r--app-arch/mt-st/mt-st-1.3.ebuild24
-rw-r--r--app-arch/mt-st/mt-st-9999.ebuild23
4 files changed, 62 insertions, 0 deletions
diff --git a/app-arch/mt-st/Manifest b/app-arch/mt-st/Manifest
new file mode 100644
index 000000000000..ec8e43d0f454
--- /dev/null
+++ b/app-arch/mt-st/Manifest
@@ -0,0 +1,4 @@
+DIST mt-st-1.3.tar.gz 35341 BLAKE2B c58eee9bd58a3fa5105fe3f8dfb56f1af1c5ed73f99e5179ea14bc11d66151d1e6b6c99f61194c700ed79ce10a7e7f75f78ffe9b7d2c45c85e620d4da1aaeb5c SHA512 1d026ae85e1ca367e72f1810042314070f592306d9ddec331b95ea4e1153dc3edee68d8798bdf7e055a4cf9c67ec8c539e5d188e87f0546f48b5f4ee4bc6a820
+EBUILD mt-st-1.3.ebuild 553 BLAKE2B 771bd7f4331a3bf7a3d47c14c767e998219474d3e1740a6cb0e6479f1fafd64cbc16ee5da23c9fea150aef89be89a919f4b2984bd57927bc3ea47d1953274470 SHA512 4a03eaace0857dd917054aab4a5040872bfee230cdb5b3b5560d3b2982c31a3ba235ed821920faf78c93b69aa31e9b48b97e57d0975c51f59363fbdc61e410bd
+EBUILD mt-st-9999.ebuild 483 BLAKE2B 87f468fd1451e561a88a635b6720ef63c39af6a2d576eb671c542519a56f4ad4211a5ccb432bdd23bab63246bfec9ccc3a5cf9f5005db43c0696977c14efaff1 SHA512 d10eb52475d7b3cf4068e819e40241edbf23e3b0f973428837318898c339616a894468111c5d28c188f6ecb8b2626d7aaf419dc89300036c5694fc04a1078c76
+MISC metadata.xml 321 BLAKE2B 3f2c57ecada60ab514926a4ddfe2fc0bdc11148a50bdeed1d336f13863e735f83056d4e647e80995c90fba92466252c2ec202e2fa9e3c667ba5a8ae6acbcece1 SHA512 79dc941553281909153cdda8422d4ac5da172a6d782936986b581a1300dcf4b4781704bb7c730f48905f0dc487f5ce781bd96abde16691d67bf5da220eb94471
diff --git a/app-arch/mt-st/metadata.xml b/app-arch/mt-st/metadata.xml
new file mode 100644
index 000000000000..5fa14a0aa1e3
--- /dev/null
+++ b/app-arch/mt-st/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">iustin/mt-st</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/mt-st/mt-st-1.3.ebuild b/app-arch/mt-st/mt-st-1.3.ebuild
new file mode 100644
index 000000000000..d45c956874e4
--- /dev/null
+++ b/app-arch/mt-st/mt-st-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="control magnetic tape drive operation"
+HOMEPAGE="https://github.com/iustin/mt-st"
+SRC_URI="${HOMEPAGE}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dosbin mt stinit
+ doman mt.1 stinit.8
+ dodoc README* stinit.def.examples
+}
diff --git a/app-arch/mt-st/mt-st-9999.ebuild b/app-arch/mt-st/mt-st-9999.ebuild
new file mode 100644
index 000000000000..7433526bff92
--- /dev/null
+++ b/app-arch/mt-st/mt-st-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit eutils git-r3 toolchain-funcs
+
+DESCRIPTION="control magnetic tape drive operation"
+HOMEPAGE="https://github.com/iustin/mt-st"
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dosbin mt stinit
+ doman mt.1 stinit.8
+ dodoc README* stinit.def.examples
+}