summaryrefslogtreecommitdiff
path: root/app-arch/mt-st
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
commit59c2499e0c9720169c9d5a02168c51c807a21467 (patch)
tree48c68a8a7e0094b2edaace12850e6c059bc3636b /app-arch/mt-st
parenta25cc082a26782e5d39ded4559c91ff11bc3c299 (diff)
gentoo auto-resync : 14:05:2024 - 00:01:24
Diffstat (limited to 'app-arch/mt-st')
-rw-r--r--app-arch/mt-st/Manifest4
-rw-r--r--app-arch/mt-st/mt-st-1.7.ebuild30
-rw-r--r--app-arch/mt-st/mt-st-9999.ebuild6
3 files changed, 36 insertions, 4 deletions
diff --git a/app-arch/mt-st/Manifest b/app-arch/mt-st/Manifest
index 292e64543c55..2d555806aead 100644
--- a/app-arch/mt-st/Manifest
+++ b/app-arch/mt-st/Manifest
@@ -1,4 +1,6 @@
DIST mt-st-1.4.tar.gz 37864 BLAKE2B 25ae656b6442e53570366405ba76da9150cf1d4fe33c612bf922d8be967ce6b60be191948507a62bb1881d4be63ed192f7d03f1d63c38f5772aec2f3d2fe455b SHA512 e6655a5957d3ac470c0cb0a1955a12397aa22f3ea1a427cf776f6bf2d6fd665439b2bfa54c3870b7974da537f0fe71d3be43126be1a7db903e6bc7be4cfb10ec
+DIST mt-st-1.7.tar.gz 39932 BLAKE2B 4083160035972cef89ba18a990c274730241819904cd08f88cbca7fd777a43d9d5fc551fb6de2b5b935818bf32d67eb00dd0002e3a67a82b28a79c17d2c7d369 SHA512 a274d098d8d028d0b32f38104645b628fad549708cc8ff87eb4155ed6270549bdf162a9ccdad468696f35ebe3f86b8923490bb969e7c22b4f827d65b87c5c3cb
EBUILD mt-st-1.4.ebuild 528 BLAKE2B 2ce8b51f400288a3a20320a9371c6e4e8cc2c860c3d762fc30fbb229b74a3985a646c6ddce726eceac4df6b5c72d23dc8d06c10640efa8cf473ebdb1403079e0 SHA512 109e20d78bc5ced7268c7fbf0c3e36d365386bf03036dbab0e6b77df22b88e6b1196a2b69131812066c5d0cd669941e28d80b2f7b5ee75e8040afcb46d080f37
-EBUILD mt-st-9999.ebuild 442 BLAKE2B eec75acf65e5cf086bad28749243bf479c4fae4f314905277f2cb878519fdbf7095ba6430e69648c1deb742fe9bd21259f965ebf7b6d6965ca0ef7f4d62e8796 SHA512 d8e72531838ac93eb103f46cfb3707f00b2aa2cf0109cc5190114f9b0d8505458d502237b2b3aa3d0c8efe64e6dd6c830ca832ad39ea2e4998428e43f57f60e7
+EBUILD mt-st-1.7.ebuild 621 BLAKE2B 0ec961b84aa13f421c20aad95011ab523266802bf9af0a7ce19f1f15b241e27d0f911dd8d9cfd92358a0e320f52cd084a1815f10ee2103ca481ff233440a0ce6 SHA512 b398fe8aeac7e69797e4ba220c7e5f31d4d9ab901013ba56bd79d366b8b200dbb61f5786a6175e451db6defeee61c1cf2d0e60311ea4803022a1e1a018866c37
+EBUILD mt-st-9999.ebuild 442 BLAKE2B a48a702dada8ed2d84d74c5c4043d27850ae7cbd509fc1f88404a8f6963098b88d36473f65b1dfcb2b26ce295c6f672326f8c6dd4fe5916783941943abf4495f SHA512 f9cb97c2c967db94d0f684e0967f0aae116afb1cb8cc44b7ee5abb99d3fbdc44b3b41a5c4f47419e7e150aed7ec467d8f8ccd54d3a6075bf563e874c4e357cb1
MISC metadata.xml 245 BLAKE2B 4acf0e81c7f55f1eaacdcef60e4e9f51ba0854cf7123851c2c62c674750cd228429a1d0e827e952b65174ce0b5edf002f7faa2a442f7fd5a79492529da4ea08a SHA512 1df2eb4d8b454828c932654cc142c647300453018b7ea24bda56872734a68d08667a9630229c4da9b78a4818c54f5f1fe90b5c9afe1c703baa262de7453ee092
diff --git a/app-arch/mt-st/mt-st-1.7.ebuild b/app-arch/mt-st/mt-st-1.7.ebuild
new file mode 100644
index 000000000000..a49f93912a95
--- /dev/null
+++ b/app-arch/mt-st/mt-st-1.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Control magnetic tape drive operation"
+HOMEPAGE="https://github.com/iustin/mt-st"
+SRC_URI="https://github.com/iustin/mt-st/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-util/shelltestrunner )
+"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin mt stinit
+ doman mt.1 stinit.8
+ dodoc README* stinit.def.examples
+}
diff --git a/app-arch/mt-st/mt-st-9999.ebuild b/app-arch/mt-st/mt-st-9999.ebuild
index 4588f304d124..d4c4a8443f3d 100644
--- a/app-arch/mt-st/mt-st-9999.ebuild
+++ b/app-arch/mt-st/mt-st-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit git-r3 toolchain-funcs
-DESCRIPTION="control magnetic tape drive operation"
+DESCRIPTION="Control magnetic tape drive operation"
HOMEPAGE="https://github.com/iustin/mt-st"
EGIT_REPO_URI="https://github.com/iustin/mt-st"