summaryrefslogtreecommitdiff
path: root/app-arch/lzma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /app-arch/lzma
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'app-arch/lzma')
-rw-r--r--app-arch/lzma/Manifest4
-rw-r--r--app-arch/lzma/lzma-19.00.ebuild41
-rw-r--r--app-arch/lzma/metadata.xml15
3 files changed, 55 insertions, 5 deletions
diff --git a/app-arch/lzma/Manifest b/app-arch/lzma/Manifest
index fc437a048152..583e71d1a384 100644
--- a/app-arch/lzma/Manifest
+++ b/app-arch/lzma/Manifest
@@ -1,3 +1,5 @@
+DIST lzma-19.00.7z 1082692 BLAKE2B 88aca3f3225d589c9b1b0fbf4c196db8e6e8df362f926736a45e1f80d302c132b25537203b0a903da9de5f3b0398b10901f126cf6905fcbdf0a57ee894e74b6d SHA512 60532483249d86960d5c481dc88ebeafabb7e435afb6188bc26f38177b8534ef3da83317d6920d99103d4f10a8dcdb624489ea5ddad8e0c8732bab1bb4ebd7eb
DIST lzma-9.20.tar.bz2 534077 BLAKE2B c1be526d6fb9f68da10b654940a92420b6c708c7aefe213394cf1c7650b3d65c4f54d3ca0663e52be13aa9f996ff9cc87262fac8b76dd0654e839cefc073c374 SHA512 1c495530834107430a675fb48c006093edc301ec7a2c2f273efd62ff260f3056503bb2c3ddef63e82f5ff04b1347381055cf6cacd59eee9d451c4d841c13cd35
+EBUILD lzma-19.00.ebuild 1011 BLAKE2B d3d3c3c01ecde62a039b622d54a28fbc1fe28d73be0a77ffc944252dcad90d821082cfe65daeccc93ed068672c42f0e2734218e2bed108d691981128ad9cc4f3 SHA512 2516f46777a11dc8b00a4a4ff69bb091f2da95ac676373cd2283bc3f7abd7ecb1613dc744a8ae54673ba9b649f97373274a59a338790b9ebc96bc0fcc7d5d0b0
EBUILD lzma-9.20-r1.ebuild 902 BLAKE2B 768a2f1db8ffa970a91e108e9666a1ce3fb2d7061bd8f79c678333ee2c7f864391e0d605d4255bf73934288f3b2afbd84bb0ae4385a49b3cb763851602a6fb08 SHA512 c472806e0b31156679c40ef8ae60e6a6b4b079e49c721a8879683b5991dfae9630550663c983289bf3533dc5eda47eb6eae92c0b5830dd84c545ba0d073afdac
-MISC metadata.xml 250 BLAKE2B e05a373f0ea02a1a107bb27632d2f6b87bb754d82a7a7c6f56b7bb6041a92a0bea6ef1a6353cd535f5f9d992b10cb68e402c4efa3189d7f65d2c9fc904a4610a SHA512 7bd753e69082bd70f8afe68f12584dd5ee18b9972c27c523570075d4d0168f3e3d8eb638da7ca08ab3969904e39ec2c76f4891fd649a26553abd4115a41b70bb
+MISC metadata.xml 444 BLAKE2B aec04279877865b9a1cea3f7feb010894c28ac21f120a9d90749a9a625b9fb8b8ef70b141031cd85e10d648deb217dbfb808b8a14566b4c130ae9623a80e919a SHA512 81f32c3de736c2adc84c87340765e18e12a7a3868b135a4e585fe91f646767698208c18aebfc6a772eace180cbbb65ada2dcc8b88ba603cdc3337077dcdf6029
diff --git a/app-arch/lzma/lzma-19.00.ebuild b/app-arch/lzma/lzma-19.00.ebuild
new file mode 100644
index 000000000000..491acc885393
--- /dev/null
+++ b/app-arch/lzma/lzma-19.00.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${PN}${PV//.}"
+DESCRIPTION="LZMA Stream Compressor from the SDK"
+HOMEPAGE="https://www.7-zip.org/sdk.html"
+SRC_URI="mirror://sourceforge/sevenzip/${MY_P}.7z -> ${P}.7z"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+BDEPEND="app-arch/p7zip"
+
+S=${WORKDIR}
+
+src_compile() {
+ cd CPP/7zip/Bundles/LzmaCon || die
+ emake -f makefile.gcc \
+ CXX="$(tc-getCXX) ${CXXFLAGS} ${CPPFLAGS}" \
+ CXX_C="$(tc-getCC) ${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ newbin CPP/7zip/Bundles/LzmaCon/lzma lzmacon
+ dodoc DOC/lzma.txt DOC/lzma-history.txt
+ use doc && dodoc DOC/7zC.txt \
+ DOC/7zFormat.txt \
+ DOC/Methods.txt \
+ DOC/lzma-sdk.txt \
+ DOC/lzma-specification.txt
+}
+
+pkg_postinst() {
+ einfo "The lzma binary is now 'lzmacon' to avoid xz-utils conflicts #218459"
+}
diff --git a/app-arch/lzma/metadata.xml b/app-arch/lzma/metadata.xml
index 86f4ac1ea62b..3a5f1e16e766 100644
--- a/app-arch/lzma/metadata.xml
+++ b/app-arch/lzma/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">sevenzip</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>hfern@fernhout.info</email>
+ <name>Hans Fernhout</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sevenzip</remote-id>
+ </upstream>
</pkgmetadata>