summaryrefslogtreecommitdiff
path: root/app-arch/lz5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/lz5
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/lz5')
-rw-r--r--app-arch/lz5/Manifest3
-rw-r--r--app-arch/lz5/lz5-2.0.ebuild33
-rw-r--r--app-arch/lz5/metadata.xml8
3 files changed, 44 insertions, 0 deletions
diff --git a/app-arch/lz5/Manifest b/app-arch/lz5/Manifest
new file mode 100644
index 000000000000..4ddf2624495c
--- /dev/null
+++ b/app-arch/lz5/Manifest
@@ -0,0 +1,3 @@
+DIST lz5-2.0.tar.gz 207478 BLAKE2B a283650b9d44b75c169e054574b6e4a76b9735ceead51c6dc80fab16666813cc19a5cba1d7e153a9eecd7f95dcda0c36ae02d4c1ea40e1224a803e563fc7824b SHA512 be304d4fe95ff237420cdc054ce7751c5b51e9b438f6cfcb3189e138909331175201cf77615d289d4ea016d66118592794b961ea07c318f477a27263eff2b82e
+EBUILD lz5-2.0.ebuild 832 BLAKE2B 0d91a023f1301bb509511dfd79d08f2b667d112f10c1c83c19bc79eb40e6b59e3e6d6a8b716d05b736e52760af594602e8e7feb48d04c7550f5c9a36368551a8 SHA512 a5df64cee6f516ea011bbd88fdb941367d29a6b6a6068e99ba108217cb40e57ff3116961d0da188e66fdb183232e1f8ecb7f222767b99f086cd7ab7dbbc62637
+MISC metadata.xml 242 BLAKE2B bd9ff4373c957e6c210561f874dc3bc0553deabb554e8c44c40d402511b901aee2f3a642c3cebb0c7b8d4e6a7e331bdb882dd2f68cf1b887d093f482a1e52534 SHA512 8f5562898c2a92f16bfe6b66dc5fde18195f65dbfee8719ec2a3653006046c42867207f60ba682a34229aee5dcc940496eabf783ca213b89c7f96fc20f81e8c2
diff --git a/app-arch/lz5/lz5-2.0.ebuild b/app-arch/lz5/lz5-2.0.ebuild
new file mode 100644
index 000000000000..1e20502cc3bb
--- /dev/null
+++ b/app-arch/lz5/lz5-2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="An efficient compressor with very fast decompression"
+HOMEPAGE="https://github.com/inikep/lz5"
+SRC_URI="https://github.com/inikep/lz5/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD-2"
+SLOT="0/2"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ sed -i -e 's/install: lz5$(EXT)/install:/' programs/Makefile || die
+ sed -i -e 's/install: lib liblz5.pc/install:/' lib/Makefile || die
+}
+
+src_compile() {
+ emake -Clib CC="$(tc-getCC)" lib liblz5.pc
+ emake -Cprograms CC="$(tc-getCC)" lz5
+}
+
+src_install(){
+ emake install DESTDIR="${D}" PREFIX="/usr" LIBDIR="/usr/$(get_libdir)"
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/liblz5.a || die
+ fi
+}
diff --git a/app-arch/lz5/metadata.xml b/app-arch/lz5/metadata.xml
new file mode 100644
index 000000000000..dffa8fbd23c4
--- /dev/null
+++ b/app-arch/lz5/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">inikep/lz5</remote-id>
+ </upstream>
+</pkgmetadata>