summaryrefslogtreecommitdiff
path: root/app-arch/lz4/lz4-1.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-30 10:48:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-30 10:48:18 +0100
commit005a5b259b876973202153b9c5c5e77bea56df6c (patch)
tree62e787239ec670df6ea942997fd18c32f3879774 /app-arch/lz4/lz4-1.9.4.ebuild
parent048bd060badd229e3bb596029874760a86d27060 (diff)
gentoo auto-resync : 30:08:2022 - 10:48:18
Diffstat (limited to 'app-arch/lz4/lz4-1.9.4.ebuild')
-rw-r--r--app-arch/lz4/lz4-1.9.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/lz4/lz4-1.9.4.ebuild b/app-arch/lz4/lz4-1.9.4.ebuild
new file mode 100644
index 000000000000..8b9add9dbac7
--- /dev/null
+++ b/app-arch/lz4/lz4-1.9.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+SRC_URI="https://github.com/lz4/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+SLOT="0/r132"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/build/cmake
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake_src_configure
+}